SQL Azure sync - There was no endpoint listening (404)


  • I'm unable to sync our on-premises database and get 'no endpoint listening' messages.  I've checked with our network admins and all seems fine.

    I can access the service page by URL (

    The error logged by the Azure management portal also includes 'The remote server returned an error: (404) Not Found' messages.

    Is there a config issue?



    Monday, March 19, 2012 10:52 AM

All replies

  • have you looked at the Event Viewer if it has log entries with informaton on the error?

    try Event Viewer->Applications and Services Logs->Sql Azure Data Sync Preview

    or Event Viewer->Applications and Services Logs->Data Sync Service

    Monday, March 19, 2012 1:32 PM
  • yes, and it just gives the errors above I'm afraid.   I've tried uninstalling the agent and re-adding with a new key but still the same.   There were earlier messages in the log about invalid keys, but I can connect to the agent and see the local database now so assume that's not the problem.

    Not sure what else to do now, and we've got to release this very soon...


    Monday, March 19, 2012 2:50 PM
  • try turning logging in verbose mode.

    Open LocalAgentHost.exe.config in notepad. This file should be present in your installation directory.

    a) Uncomment the section that is currently commented
    < !--
    < switches>
    < add name="SyncAgentTracer" value="4" />
    < /switches>
    < trace autoflush="true" indentsize="4">
    < listeners>
    < add name="myListener" type="Microsoft.SqlAzureDataSync.ClientLogging.DSSClientTraceListener, Microsoft.SqlAzureDataSync.ClientLogging, Version=" initializeData="DSSAgentOutput.log" />
    < remove name="Default" />
    < /listeners>
    < /trace>

    b) Stop and restart SQL Azure Data Sync Preview Windows Service.
    Now you would find the detailed logs in files named DSSAgentOutput*.log.

    Monday, March 19, 2012 3:01 PM
  • More 404 errors in there I'm afraid. 

    and lots of 'ThreadId:26. Dispatcher calling GetRequest'

    Monday, March 19, 2012 3:41 PM
  • the Dispatcher calling GetRequest is just normal as the service checks for tasks from the cloud service.

    on which region did you provision the service?

    are you able to hit this url?

    Tuesday, March 20, 2012 1:50 AM
  • Western Europe.

    No problem hitting that URL...

    I'm going to try it from another server, but clutching at straws now really...

    Tuesday, March 20, 2012 10:48 AM
  • no other errors in the logs apart from the 404 errors?
    Wednesday, March 21, 2012 1:37 AM
  • Hi,

    Can you please clarify the following:

    - when you say the agent is able to list the databases, are you referring to the Client Local Agent is able to list the databases?  Or are you saying the Management Portal can make a connection to the Client Local Agent and you see the available databases listed in the Portal?

    Also, do you have the actual Client Local Agent log snippet with the error?



    Thursday, March 22, 2012 2:31 AM
  • Hi,

    The Management Portal can list the local databases and get the schema.  

    The message is:

    Inner exception: There was no endpoint listening at that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.
    Inner exception: The remote server returned an error: (404) Not Found.

    For more information, provide tracing id ‘9c908466-62d6-4243-9087-7ab35d104988’ to customer support.

    thanks for all the help.



    Thursday, March 22, 2012 9:15 AM
  • have you tried provisioning a new subscription for Data Sync and configuring the sync group there?
    Thursday, March 22, 2012 3:25 PM
  • I've just removed (sync group and local sync service agent) and re-installed, re-provisioned in a different region (North Europe) and still get the same error.

    Is that endpoint ( definitely correct?   It shouldn't be returning 404 errors surely?

    This is quite an issue for us as our architecture relies on data synchronisation.


    Friday, March 23, 2012 3:33 PM
  • I've also tried all this on a separate server...
    Friday, March 23, 2012 3:44 PM
  • Can you try a simple database instead of the one you are currently using to see whether that will pass for you?

    If it shows problem, please use Fiddler to capture the network traffic that can be installed from

    After it's installed, go to Tools - Fiddler options - HTTPS, select Capture HTTPs Connects and Decrypt HTTPS traffic, when a certificate dialog pops up, click yes.

    Now when local agent communicating with the Sync service, find the red errors in the Fiddler window. and for the red errors, check the Inspectors windows on the right pane (you may then select Raw for request and response content), if you see the 404 returned as response, please capture the context and let us know. Thanks!

    Monday, March 26, 2012 5:28 PM