none
Uninstall DPMagent from registry RRS feed

  • Question

  • Hi

    Machine: windows server2008 r2 Hyper-v

    While trying to uninstall a DPM agent, my machine, got booted and the uninstall got messed up.

    I have tried to uninstall via msiexec /x {the agent key left in uninstall registry}

    Since that didn't work i have tried manually deleting all registry keys with DPM and Data protection manager

    But when i try installing/uninstalling it still says that there is an installation present.

    Which reg key am i missing?

    Kind Regards

    Tom Andersen


    Ta
    Monday, March 7, 2011 3:08 PM

Answers

  • Hello,

    So you tried:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
    Each of the applications has a guid listed under this key. Under the guid, you’ll see an entry for UninstallString.  You should be able to run the entry in that field from the command prompt.

    For DPM it should be:

    DPM 2007: MsiExec.exe /X {5EB850FE-84F7-4856-A203-0F80BC93C66A}
    DPM 2010: MsiExec.exe /X{3EC7C770-9F3F-4177-A754EBFF04A1AFF2}

    You can open up a command prompt and paste that in and hit enter and reboot.  The DPM agent should be uninstalled.

    WARNING
    doublecheck this in the registry to make sure the as to the value. Also make a backup of the registry before you try this method.

    So this did not work for you? Correct?

    Method #2
    1.) Copy the install directory over to the target server.
    2.) Open up a command prompt and navigate to that directory with the dpmra.msi package.
    3.) Type:

    msiexec /uninstall dpmra.msi

    Reboot.

    Shane

     

    Friday, March 11, 2011 10:10 PM

All replies

  • Hi,

    Try these steps to see if tey help:

    1) Run DCOMCNFG - then under Component Services, Computers, My Computer, DCOM Config - locate the "DPM RA Service" and delete it.
    2) Open computer management and under Local users and groups, delete the DPMRADCOMTrustedMachines and DPMRADmTrustedMachines local groups.


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, March 7, 2011 5:31 PM
    Moderator
  • Hi Mike

    Thanks for the reply.

    I tried your steps, well step number 2 that is.
    When trying step number 1 i ran my head to the wall, i tried to run dcomcnfg from a remote server, but kept getting an error.
    I tried to set the correct access rights via
    http://social.technet.microsoft.com/Forums/en/windowsserver2008r2management/thread/f26e40a9-31ee-447f-957c-087600f9a5f3
    And
    http://blogs.technet.com/b/jhoward/archive/2008/03/30/part-3-hyper-v-remote-management-you-do-not-have-the-requested-permission-to-complete-this-task-contact-the-administrator-of-the-authorization-policy-for-the-computer-computername.aspx

    But no luck. i can't edit DCOM ont the hyper-v core server via dcomcnfg.

    The only soulution i can see is a reinstall of the server.

    Kind regards

    Tom Andersen

     


    Ta
    Tuesday, March 8, 2011 2:56 PM
  • Hello,

    So you tried:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
    Each of the applications has a guid listed under this key. Under the guid, you’ll see an entry for UninstallString.  You should be able to run the entry in that field from the command prompt.

    For DPM it should be:

    DPM 2007: MsiExec.exe /X {5EB850FE-84F7-4856-A203-0F80BC93C66A}
    DPM 2010: MsiExec.exe /X{3EC7C770-9F3F-4177-A754EBFF04A1AFF2}

    You can open up a command prompt and paste that in and hit enter and reboot.  The DPM agent should be uninstalled.

    WARNING
    doublecheck this in the registry to make sure the as to the value. Also make a backup of the registry before you try this method.

    So this did not work for you? Correct?

    Method #2
    1.) Copy the install directory over to the target server.
    2.) Open up a command prompt and navigate to that directory with the dpmra.msi package.
    3.) Type:

    msiexec /uninstall dpmra.msi

    Reboot.

    Shane

     

    Friday, March 11, 2011 10:10 PM