locked
An update conflict has occurred, and you must re-try this action. The object SearchDataAccessServiceInstance was updated by <domainname\user name>, in the OWSTIMER (1908) process, on machine <machinename>. RRS feed

  • Question

  • Hi all,

    I am currently using SharePoint Server 2016 running on Aug 2016 Cumulative update. Can you please advise how to correct this error as it is happening every 2 mins in Event Viewer.

    I have noticed the below error in the Event Viewer.

    Application Server Administration job failed for service instance

    Microsoft.Office.Server.Search.Administration.SearchServiceInstance (a96349e3-0fc3-493f-ab60-6d449c0860d4).

    Reason: An update conflict has occurred, and you must re-try this action. The object SearchDataAccessServiceInstance was updated by <domainname\user name>, in the OWSTIMER (1908) process, on machine <machinename>.  View the tracing log for more information about the conflict.

    Technical Support Details:
    Microsoft.SharePoint.Administration.SPUpdatedConcurrencyException: An update conflict has occurred, and you must re-try this action. The object SearchDataAccessServiceInstance was updated by APEXMU\sp_admin, in the OWSTIMER (1908) process, on machine SP-WEB-02.  View the tracing log for more information about the conflict.
       at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize()
       at Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)

    Thanks

    Monday, January 9, 2017 7:00 AM

All replies

  • Hi

    Did you run config wizard after update?


    顺其自然地勇往直前!—Justin Liu

    Monday, January 9, 2017 9:23 AM
  • There could be issue with any time job stuck up related to Search.

    Please get all jobs and try to kill the desired one. You can use the following powershell cmdlet.

    $myJob = Get-SPTimerJob | Where-Object {$_.Name –like "*search*"}

    $myJob .Delete()

    Try to list all the jobs and select appropriate job to delete.


    One day your life will flash before your eyes, make sure its worth watching....

    Monday, January 9, 2017 9:46 AM
  • Hi LiinaaS,

    Please stop timer service, clean the configuration cache, and then start the timer service. Check if it works after clearing the cache.

    1. Stop the timer service.

    2. Delete all the XML files in the config cache. There are loads of XML files that can be found in the folder “%SystemDrive%\ProgramData\Microsoft\SharePoint\Config\”. (Do not delete the folder and Cache.ini file).

    3. Back up the Cache.ini file. Edit the “cache.ini” file, set the content to 1. This indicates that all cache settings need to be refreshed. Eventually this value gets automatically updated to another number when the cache is repopulated.

    4. Start the timer service.

    Information about Clearing SharePoint configuration cache, you could refer to the following article.

    https://blogs.msdn.microsoft.com/jamesway/2011/05/23/sharepoint-2010-clearing-the-configuration-cache/

    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Proposed as answer by Victoria Xia Thursday, January 12, 2017 9:57 AM
    Tuesday, January 10, 2017 8:30 AM
  • Hello,

    This didn't work for me.

    Any other advice?

    I am on SharePoint 2013.

    Many Thanks.

    • Edited by JSBachra Monday, February 26, 2018 12:22 PM
    Monday, February 26, 2018 12:21 PM
  • Hello Linda, I have a client who is experiencing this problem, even after performing the steps that you described, after a few days the problem happens again. Would you know the root of the problem? Why does this happen again so fast?
    I thank the attention.
    Monday, April 8, 2019 4:09 PM