none
Extensible Connectivity 2.0 MA - Export and Import works but not in same Run Profile (no-start-ma error) RRS feed

  • Question

  • Hi.

    I am a newbie on ECMA 2 and have a problem that hopefully is easy to resolve. I have migrated an old Custom MA to the ECMA2 interface but I have some problems getting it to work correctly. Export and Import works correctly but when I put them in the same Run Profile (for instance Export+Full Import-Full Sync) I get a no-start-ma error on the second operation. The order of operations does not matter, i.e. if I do a Import first and export after that, the export fails. The second operation, whichever that is, does not reach any code that I have written so it seems to happend internally in FIM.

    I have tried running it in separate process, changed between .Net 3.5 and 4.0, upgraded the server to R2 without any success. My worries are that I have missunderstood some basic ECMA 2 stuff. I have for instance not found any good information explaining the usage of CustomData in the ImportRunStep (for instance GetImportEntriesRunStep) or in the result (for instance GetImportEntriesResults).

    The only thing I can find in the eventlog is:

    FIMSynchronizationService 
    - EventID 6401 
       EventRecordID 89262 
    - EventData 
       BAIL: MMS(9844): d:\bt\9394412\private\source\miis\ma\extensible\extensionmanager.cpp(550): 0x8000ffff (Catastrophic failure) BAIL: MMS(9844):
    d:\bt\9394412\private\source\miis\ma\extensible\extensionmanager.cpp(1354): 0x8000ffff (Catastrophic failure) BAIL: MMS(9844):
    d:\bt\9394412\private\source\miis\ma\extensible\import.cpp(404): 0x80231348 (unable to get error text) BAIL: MMS(9844):
    d:\bt\9394412\private\source\miis\cntrler\cntrler.cpp(2733): 0x80231348 (unable to get error text) BAIL: MMS(9844):
    d:\bt\9394412\private\source\miis\ma\extensible\extensionmanager.cpp(550): 0x8000ffff (Catastrophic failure) BAIL: MMS(9844):
    d:\bt\9394412\private\source\miis\ma\extensible\extensionmanager.cpp(1497): 0x8000ffff (Catastrophic failure) BAIL: MMS(9844):
    d:\bt\9394412\private\source\miis\ma\extensible\import.cpp(595): 0x8000ffff (Catastrophic failure) ERR_: MMS(9844):
    d:\bt\9394412\private\source\miis\shared\utils\libutils.cpp(9944): Failed to start run because of undiagnosed MA error Forefront Identity Manager 4.1.2273.0 

    Currently running FIM 2010 R2.

    Best regards and thanks for any reply
    Håkan

    PS! Another totally unrelated question is that I have not found a way to retreive the complete CS-entry in the Connector. Can this be performed as easy as it was before?

    Tuesday, July 3, 2012 10:06 AM

All replies

  • I've found this to be true also (R2 beta, R1 Rollup 2, R2 final), chalked it up to ECMA2 growing pains, and simply configured separate run profiles for each step.  There is probably nothing wrong with your code as you are not required to use or set the CustomData fields unless you want to support delta imports (it's just "cookie space" for your extension to use however you see appropriate).

    Tuesday, July 3, 2012 6:31 PM
  • Tanks for the reply Steve.

    I just have a problem to accept that this is the way it is suppose to be. But at the same time the MA works flawlessly as long as one run the operations in different Run Profiles.

    I also, today, installed the MA on a totally fresh FIM 2010 R2 machine with the hope that it was my development server that had some kind of problem; but I get the same problem on this new server.

    Best regards
    Håkan


    Best regards Håkan Andersson

    Tuesday, July 3, 2012 10:15 PM
  • I've seen this problem as well - and I'm still investigating. I have yet to rule out my code, since this looks like some initialization code maybe being called twice. To my best knowledge, it's not a requirement to run seperate steps for ECMA, so the two step Run Profile should be possible.

    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | twitter at https://twitter.com/#!/MrGranfeldt

    Friday, July 6, 2012 8:27 AM
  • This was happening to me.  I turned off logging for the run profile and it was back in business.  There was something goofy with file permissions.
    Monday, July 16, 2012 11:53 PM
  • I'll have to try twiddling the logging options on and off, but I never create run steps with logging and it reliably goes kaboom.  Do you still have any of your stack traces around to share?
    Tuesday, July 17, 2012 10:13 PM
  • Any updates or solutions to this problem?  I have recently finished an ECMA 2.0 with the same result.  While I am able to work around the issue, it would be nice to have resolution to the issue.

    Running FIM 2010 R2 build 4.1.2515.0

    Source:        FIMSynchronizationService
    Event ID:      6401
    The management agent controller encountered an unexpected error.
     
     "ERR_: MMS(5240): d:\bt\792\private\source\miis\shared\utils\libutils.cpp(9944): Failed to start run because of undiagnosed MA error
    Forefront Identity Manager 4.1.2515.0"

    Tuesday, September 11, 2012 2:43 PM
  • I am having this same behavior, exports runs and after export a delta import gives me the error:

     The management agent controller encountered an unexpected error. "ERR_: MMS(8824): d:\bt\25920\private\source\miis\shared\utils\libutils.cpp(10186): Failed to start run because of undiagnosed MA errorForefront Identity Manager 4.1.3508.0"


    I have tried turning on and off the logging options but this does not help, does anybody know how to fix this?

    Running a separate delta import works fine


    Need realtime FIM synchronization and advanced reporting? check out the new http://www.imsequencer.com that supports FIM 2010, Omada Identity Manager, SQL, File, AD or Powershell real time synchronization!

    Monday, June 16, 2014 12:19 PM
  • I'm experiencing exactly the same problem with the official Microsoft FIM WAAD connector (http://msdn.microsoft.com/en-us/library/dn511001(v=ws.10).aspx) which also seemed to be based on ECMA 2.0.

    Find me on linkedin: http://nl.linkedin.com/in/tranet

    Thursday, June 19, 2014 9:01 AM
  • I'm having the same issue also with ECMA 2 MA as well as BHold MA (AMC).  I've found if you combine import with an export the 2nd run step fails with no-start-ma.

    Thanks,

    Peter

    Friday, June 20, 2014 1:19 PM
  • I'm pretty sure that this is a bug in the framework that hopefully will be fixed in the coming releases. For now, I'm using one-step Run Profiles for my ECMA's

    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt

    Friday, June 20, 2014 9:33 PM
  • Hi Soren,

    I'm doing the same one-step run profile also.  this isn't breaking anything, but definitely seems like a bug.

    -Peter

    Friday, June 20, 2014 9:43 PM
  • I just ran into this, using MS' own "Generic Connector" (from hotfix).  Has anyone found a way to eliminate this problem besides making the separate run profile?
    Monday, November 17, 2014 1:27 PM
  • Hi

    I m using fim2010 GAL mode only, and when I upgrade it to FIM 2016 appeared the same error

    #Failed to start run because of undiagnosed MA error Forefront Identity Manager 

    #no-start-ma error

    only on Export step, other functions worked properly

    little googling give me working answer. Q was in version of .NET . Hope that link help some one else

    http://setspn.blogspot.ru/2015/09/mim-2016-no-start-ma-when-exporting-to.html

    Wednesday, September 23, 2015 3:09 PM
  • It's been a while since people report this issue.

    I have a home-made custom ECMA 2.2 MA and can't run E-DI-DS in the same RunProfile. This is typically failing at the Import step.

    Not a big problem although the runs in a single profile is typically for export confirmation and the idea was to run the import/sync right after an export step and only if there were pending exports...

    I have the feeling that MS will never fix that... :)


    Benoit Boudeville - Avanade France & Belux Microsoft Certified Master - Office Communications Server 2007/R2 http://unifiees.blogspot.com

    Thursday, December 8, 2016 6:01 PM