none
Using one SIP Domain with different Primary SMTP addresses that exists on the same Exchange server RRS feed

  • Question

  • I have an organization that has business units that use different email domain names for their email addresses, but they all use the same exchange 2013 server.

    There is one SIP domain, for example: contoso.com

    For example, say the main email domain name is @contoso.com and the SIP domain name is contoso.com, integration between Lync 2013 and Exchange 2013, for users with an email domain name of @contoso.com and SIP domain of contoso.com works fine.

    For users that have a different email domain name, say for example @diffcontoso.com, integration between Lync 2013 and Exchange 2013 doesn’t work completely.

    I tried creating autodiscover.diffcontoso.com DNS record for the @diffcontoso.com email domain and creating a server to do HTTP redirects to the exchange 2013 server, but this didn’t work for those users

    What do I need to do, to get integration fully working for users that have the @diffcontoso.com email domain?


    • Edited by JeffDK Friday, January 30, 2015 10:51 PM
    Friday, January 30, 2015 10:49 PM

Answers

  • Steps I took to enable this scenario to work.

    • Disable email comparison for Lync users on the Lync server
      • In the Lync server Management shell, run “Set-CsClientPolicy -DisableEmailComparisonCheck $true”
    • On the internal DNS server, create a Forward Lookup Zone for each SMTP domain in your organization.
      • For example:  diffcontoso.com
    • Add a DNS A record, autodiscover.<SMTP Domain> to each Forward Lookup Zone for each SMTP domain in your organization
      • For example: autodiscover.diffcontoso.com
    • Add autodiscover.<SMTP Domain> to the Subject Alternative Name on the Exchange cert
      • autodiscover.diffcontoso.com
    • Use Group Policy to modify the TrustModelData registry value
    • Proposed as answer by Thamara.Wijesinghe Wednesday, February 4, 2015 1:41 AM
    • Marked as answer by JeffDK Thursday, February 5, 2015 1:42 AM
    Tuesday, February 3, 2015 10:50 PM

All replies

  • Jeff - When I run into this situation typically as long as autodiscover is deployed internally there are not any problems.  So when you deploy autodiscover.diffcontoso.com that should point to your Exchange 2013 Servers.  You would need to ensure that server has that name assigned to the certificate on that box so it can properly respond to the request.  The server should return an XML file essentially directing the client (both Lync and Outlook) to the right place to get EWS integration.

    Hopefully that helps a bit.

    Richard


    Richard Brynteson, Lync MVP | http://masteringlync.com | http://lyncvalidator.com

    Friday, January 30, 2015 10:55 PM
  • Richard,
    I’m am unsure what name I should have on the cert for the exchange server:

    What name do we need for this to work? conexch.diffcontoso.com?

    conexch.contoso.com is one of many names on the cert

    The internal name of the exchange server is conexch.intcontoso.local

    I ran the following command on the exchange server and got the following:


    [PS] C:\Windows\system32>Get-ClientAccessServer | Select-Object Name, AutoDiscoverServiceInternalUri | Format-List


    Name                           : CONEXCH
    AutoDiscoverServiceInternalUri : h***s://conexch.contoso.com/autodiscover/autodiscover.xml




    • Edited by JeffDK Saturday, January 31, 2015 1:42 AM
    Saturday, January 31, 2015 1:18 AM
  • You don't say exactly what isn't working but if the SIP address and SMTP addresses don't match you need to set a client policy to ignore this.

    Depending on how you want to do it you could create a new client policy called diffcontoso and then:
     Set-CsClientPolicy -identity diffcontoso -DisableEmailComparisonCheck $true

    Or you could just update your existing policy.


    Chris Clark - | MCTS:OCS & UC Voice Specialization | MCSE | MCSA | CCNA http://www.unitycomms.com

    Saturday, January 31, 2015 9:39 AM
  • Hi JeffDK,

    As Richard said , if you have the correct certificate and DNS records configured, there should not be any problem.

    In addition to the certificate, you should add the autodiscover DNS record for diffcontoso.com.

    You can check this https://social.technet.microsoft.com/Forums/en-US/05e73b19-0467-4286-a9bb-4a13a9b56b32/sip-and-smtp-domains-dont-match?forum=lyncdeploy

    Best regards,

    Eric

    Monday, February 2, 2015 8:36 AM
    Moderator
  • Steps I took to enable this scenario to work.

    • Disable email comparison for Lync users on the Lync server
      • In the Lync server Management shell, run “Set-CsClientPolicy -DisableEmailComparisonCheck $true”
    • On the internal DNS server, create a Forward Lookup Zone for each SMTP domain in your organization.
      • For example:  diffcontoso.com
    • Add a DNS A record, autodiscover.<SMTP Domain> to each Forward Lookup Zone for each SMTP domain in your organization
      • For example: autodiscover.diffcontoso.com
    • Add autodiscover.<SMTP Domain> to the Subject Alternative Name on the Exchange cert
      • autodiscover.diffcontoso.com
    • Use Group Policy to modify the TrustModelData registry value
    • Proposed as answer by Thamara.Wijesinghe Wednesday, February 4, 2015 1:41 AM
    • Marked as answer by JeffDK Thursday, February 5, 2015 1:42 AM
    Tuesday, February 3, 2015 10:50 PM
  • Hello Jeff

    Do we need to have different Forward look up zone created for each domain

    Because we have one primary domain and 33 email domains

    those who are in primary domain has the same email and SIP domain

    for them the EWS works fine

    Also in our test environment, the account we use have email domain different from SIP domain and EWS is fine on the test machine

    we have routed the autodiscover.primarydomain.com to the VIP of the netscalar where we have all the servers added to it 

    also when I use wireshark, it fetches the autodiscover.primarydomain.com and gets the right VIP IP as an answer

    Still we have this problem

    Friday, November 15, 2019 9:37 PM