none
cache behaviour Reporting Service RRS feed

  • Question

  • Hi,

    I have few reporting server reports and I am using those inside a dashboard and published the dashboard inside SharePoint. The reports are using SQL Server table as source.

    The scenario is I have my SharePoint page open, I changed some data in Database and refresh the page and I don't see the reflection. If I close the browser and re-open then I got the new data.

     

    Now, as it is from Reporting service to PerformancePoint to SharePoint I am not sure what are the settings affecting this cache behaviour.

     

    Any idea?

     

    Regards,

    Monday, April 7, 2008 4:53 AM

Answers

  • On the Properties tab of the report inside Reporting Services, under Execution, do you have the report set to 'Always run this report with the most recent data' and 'Do not cache temporary copies of this report'?

     

    Cheers,


    David

    Monday, April 21, 2008 8:35 PM

All replies

  • Hello smguljar,

     

    In Dashboard Designer, go to the Editor tab of the SQL Table data source. Set the "Cache Settings" interval 0 instead of the default 10. This should set the cache to nothing so that the refresh is instant. Also when you refresh the SharePoint site did you try using "CTRL+F5"? That is a hard refresh that also negates loading the IE page from cache.

     

    Thanks,

    Jon Thomas

    Monday, April 7, 2008 11:50 PM
    Moderator
  • I tried CTRL+F5. That doesn't work.

    And please note I am not using SQL server data source from PerformancePoint directly. I am hosting Reporting service reports in PerformancePoint. So Cache settings is not applicable here.

     

     

    Tuesday, April 8, 2008 12:18 AM
  • On the Properties tab of the report inside Reporting Services, under Execution, do you have the report set to 'Always run this report with the most recent data' and 'Do not cache temporary copies of this report'?

     

    Cheers,


    David

    Monday, April 21, 2008 8:35 PM