locked
Issue with ProClarity Analytics Server 6.3 RRS feed

  • Question

  •  

    Hi,

     

    I have a Windows Server 2008 running out BI products like SQL 2005, PerformancePoint Server 2007 on top of SharePoint Services 3.0

     

    The problem is when ProClarity Analytics Server 6.3 installed, it install by default to the Default Website port 80. Our SharePoint has been configured to use port 80 and the default web site has been stopped.

     

    I have create a seperate application pool (PAS) using port 800 and web site (PAS) contain to web applications (PAS and PASUploads).

     

    I have enabled the port 800 through the firewall.

     

    I have been successful browsing to http://<servername>:800/pas (link obviously will not work for you) which fires up the ProClarity web site and displays currently no libraries.

     

    The problem is when I use the Analytics Server Administration Tool and prompts me for a user name and password, it states that "Please specify a user name and password to access http://<servername>/PAS..." which actually should be going to <servername>:800/PAS

     

    How can I fix this?

     

    Do I need to put both apps in the SharePoint Website so to use port 80 or can I keep it separate and point the Admin Tool to the right place?

     

    Cheers,

    Thursday, July 24, 2008 2:20 AM

Answers

  • Hi,

     

    Thank you for your prompt response. When I click the right mouse button of the PAS server name the only options are:

    View

    New Windows from Here

    Refresh

    Help

     

    1. I then removed the server and then I Register ProClarity Analytics Server...

    2. Server Name, I type ADLAP03

    3. Server URL: I type http://ADLAP03:800/PAS

    4. I then get a message in the Management Console "Server Error This account does not have sufficient privileges to retrieve connection information."

    I researched the help files and it states "To use the Administration Tool, you must be a member of the Analytics Server Administrator role"

    I checked Administration Tools / Computer Management / Local Users and Groups and there is no such role (group) and in SQL in the ProClarity_PAS database / Security / Roles and both Database Roles and Application Roles do not have a Analytics Server Administrator role.

    I have added the service account and my login to the local Administrators Group and in SQL given both db_accessadmin and db_owner roles and still get the same response in the Management Console not having enough privileges.

     

    Where is this Analytics Server Administrator role?

     

    BANG! just found the problem

     

    When I created the PAS application under the PAS web site, I had most of the Authenication switch to enabled. I noticed that when I logged onto the web site it showed IUSER was logged on and not my user login. so it must have been passing Anonymous Authentication even though I has Basic and Windows Authentication enabled too.

     

    As soon as i disabled Anonymous Authentication I was enable to see the server details in the console.

     

    Thank you for you help anyway. But if someone could answer where is that role. I have also checked Analysis Services and there is no role.

     

    Friday, July 25, 2008 1:04 AM

All replies

  • On the Analytics Server Administration Tool, if we right click on the PAS server name then choose Properties, on the Server URL we can specify http://<servername>:800/pas instead of http://<servername>/pas

    Regards,

    Vincent

     

    Thursday, July 24, 2008 11:04 AM
  • Hi,

     

    Thank you for your prompt response. When I click the right mouse button of the PAS server name the only options are:

    View

    New Windows from Here

    Refresh

    Help

     

    1. I then removed the server and then I Register ProClarity Analytics Server...

    2. Server Name, I type ADLAP03

    3. Server URL: I type http://ADLAP03:800/PAS

    4. I then get a message in the Management Console "Server Error This account does not have sufficient privileges to retrieve connection information."

    I researched the help files and it states "To use the Administration Tool, you must be a member of the Analytics Server Administrator role"

    I checked Administration Tools / Computer Management / Local Users and Groups and there is no such role (group) and in SQL in the ProClarity_PAS database / Security / Roles and both Database Roles and Application Roles do not have a Analytics Server Administrator role.

    I have added the service account and my login to the local Administrators Group and in SQL given both db_accessadmin and db_owner roles and still get the same response in the Management Console not having enough privileges.

     

    Where is this Analytics Server Administrator role?

     

    BANG! just found the problem

     

    When I created the PAS application under the PAS web site, I had most of the Authenication switch to enabled. I noticed that when I logged onto the web site it showed IUSER was logged on and not my user login. so it must have been passing Anonymous Authentication even though I has Basic and Windows Authentication enabled too.

     

    As soon as i disabled Anonymous Authentication I was enable to see the server details in the console.

     

    Thank you for you help anyway. But if someone could answer where is that role. I have also checked Analysis Services and there is no role.

     

    Friday, July 25, 2008 1:04 AM
  • I am facing same issue while installing PAS:

    4. I then get a message in the Management Console "Server Error This account does not have sufficient privileges to retrieve connection information."

    Was you able to find where "Analytics Server Administrator" role is?
    Friday, June 19, 2009 3:13 PM
  • ProClarity roles are permission groups that you can create.  The only default role is 'Administrator' and you can access it from the Analytics Server Administration Tool by clicking on the PAS server and then the 'Roles' folder.

    Hth!
    Sean
    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, June 19, 2009 3:31 PM