Problem with 3TB raid1 in configuration in windows 2012 with HP proliant microserver N40L RRS feed

  • Question


    I have purchased HP Proliant microserver N40L with 2 Seagate 3TB HDD for RAID1 configuration. I configured RAID1 from the bios utility and installed Server 2012. After the 1st clean install, I went and checked my RAID drives and It surprised by when I saw two separate 3TB hard drives in the disk management, Disk-2 is allowing me to create a GPT parition and Disk-1 is completely unaccessible. Ideally, Windows should have now shown me two separate drives at all in the hardware RAID1 mode. I tried lot of fixes without success, I even tried windows 2012 Essential hoping it might fix the probelm

    I than install Windows 7 to check if it is my hardware, and to my surprise it worked, it showed me a one 3 TB drive and allowed me to create a one GPT parition of all full size, I copied some files and tested a fail safe scenario removing single hard drive and restarting and accessing those files.

    I have also checked this in WHS 2011 without any problem

    I now giving up, I don't understand why windows server 2012 has problem with my 3 TB disks. Windows 7 and WHS 2011 are older and I was thinking they would have problems with my 3 TB hard drives instead, they worked fine and Server 2012 is giving me a trouble, inpiste of being a new windows server OS

    Immediate help will be appreciated




    Monday, February 4, 2013 7:48 PM

All replies

  • I'd get in touch with HP about operating system compatabilty / drivers for Windows Server 2012




    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Monday, February 4, 2013 8:25 PM
  • when I saw two separate 3TB hard drives in the disk management, Disk-2 is allowing me to create a GPT parition and Disk-1 is completely unaccessible

    Can you send snapshot of diskmgmt to me? Are these disk visible in diskmgmt? At times I too have seen disks not getting visible in diskmgmt



    Tuesday, February 5, 2013 6:09 AM
  • Thanks Satish and Patrick,

    As I mentioned, I gave up with Windows server 2012 because of this issue so I can't send you the snapshot of diskmgmt of server 2012.

    One thing I can tell you for sure is, 2012 was not taking Hardware RAID1 disks as 1 dist and disk-1 was failing over whatever I try to do (Initialize, create volume, convert to GP etc)

    Right now I have windows 7 installed on this machine and both the disks (1 disk) configured properly. Please find the attached screenshot. I have also tested fail safe scenario withing windows 7 successfully

    Please let me know if you really required the error screenshot, I will install server 2012 and send you the screen shot

    Unfortunately I am not able to attach an image here, it says your account must be veryfied though I am MSDN premium scubscriber. Please let me know how can I attach a screenshot here?

    Tuesday, February 5, 2013 3:16 PM
  • Hi,

    You could upload your screenshot to skydrive. If the hardware RAID1 cannot be recognized correctly in Windows 2012, as Patrick mentioned, you could have a try to contact with hardware provider to see if there is any update (driver/firmware) needed.

    Here are the steps to upload a picture.

    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Thursday, February 7, 2013 6:24 AM
  • Thanks

    Now it is asking me email ids of you guys when I try to Share, I don't have share with everyone option.

    Monday, February 11, 2013 9:11 PM
  • Sharing with public should not be an issue. We already have multiple people shared their content. You can generate a link using right click on the item and it would give you further options,



    Tuesday, February 12, 2013 6:25 AM
  • I give up now, I can't upload the screenshot there

    Do you really required error screenshot? Did anybody tried to recreate the issue?

    Monday, February 18, 2013 4:12 PM
  • I am having the same issue.

    I could create a funktional RAID in Windows Server 2012 with the AMD RaidXpert (2x4TB WD RAID Edition). But the configuration is not in sync with RAID Controller BIOS. As far as i have found out, the new Drivers do not "talk" with the RAID BIOS correctly. HP would ne to update the AMD RAID BIOS to a Minimum of Version 3.3.1540.11 (and Later).

    I hope HP will do this soon......

    Friday, April 12, 2013 7:17 AM
  • Configuration: N40L, Windows 2012 Essentials, 1 hp 250GB, 2x4TB wd40efrx.

    I made using raid bios two logical drives:

     - ld1 - raid ready i am using the 250GB hd for OS

     - ld2 - raid 1 using the two 4tb disks.

    Using the drivers/software from windows 2008R2 : 100412a-101846C-HP.zip and WHQL_SB8xx_RAID_2K8_3.2.1540.75.zip i was able to obtain a functional raid configuration using RaidXpert.

    You need to install SB8xx_RAIDXpert.exe version 3.2.1540.10. Btw i experienced the same issue when i used RaidXpert version 3.3.1540.19.

    In the end windows is reporting correctly 1 disk for the raid1. 

    • Proposed as answer by KeeFeeRe Tuesday, October 30, 2018 8:50 AM
    Saturday, October 19, 2013 10:12 PM
  • Thanks! Same here - WS2012R2 on SSD and moved from 2*2TB raid1 to 2*3TB raid1. Did not see in device manager raid volume only disks itself. I'm installed:


    Re-create volume in RAID BIOS and it's working!

    Tuesday, October 30, 2018 8:55 AM
  • I replaced Windows 7 with Windows 10 and had to upgrade BIOS from original version to version 2013.10.01 (A) (15 NOV 2013) in order to fix network card problem (Windows 10 could see NIC but complained that Ethernet cable was not connected even if it was plugged in). I read that same NIC problem was found on Windows Server 2012.

    Detailed description of BIOS upgrade is here: https://homeservershow.com/blog/hp-microserver/hp-proliant-microserver-bios-flash-sp64420/

    SP64420.exe (2.6 MB) can be downloaded from here: https://cloudrun.co.uk/server/bios-for-hp-proliant-microserver-g7-n54l/

    After that I added 2x 4TB WD RED disks, configured them as RAID1 in RAID BIOS and ended up with the same problem that Windows 10 saw them as two separate disks in Disk Management console.

    I downloaded AMDXpert_V32154010_XPVISTAWIN7.zip and installed RAIDXpert version 3.2.1540.10.

    The file is available here: https://www.driverguide.com/driver/detail.php?driverid=1800617

    Then I downloaded AMD RAID driver WHQL_SB8xx_RAID_2K8_3.2.1540.75.zip from here: https://vhrms.tistory.com/217

    I replaced AMD RAID driver version 3.7.1540.43 (added automatically during Windows 10 installation) with 3.2.1540.75.

    I restarted the server, again configured RAID1 in RAID BIOS for 2x 4TB WD RED disks, opened RAIDXpert application (using “admin” for both login and password) and saw 2x 4TB WD RED disks, configured into one RAIS1 disk.

    I opened Disk Management console, also saw one 4TB disk there, initialized it with GPT and quickly formatted with NTFS.

    It was long tricky journey but I managed following tips from Adrian Ionita and KeeFeeRe.

    Thank you so much!

    Friday, July 24, 2020 8:23 AM