none
Windows Firewall won't turn off RRS feed

  • Question

  • I have a laptop running Windows 10/64 Pro. I use an alternate Firewall, Comodo which is running without problem. I have been trying to turn off Windows Firewall because it keeps trying to block things like Skype and can't seem to remember when I tell it not to block such applications. When I turn off Windows Firewall, it always turns itself back on, sometimes within a few seconds, sometimes it takes an hour. I have tried turning it off for both Private and Guest-Public networks through the usual Control Panel settings but no permanent results. I have also tried turning it off with the command line "netsh advfirewall set allprofiles state off" but next time I reboot, Windows Firewall is back on, blocking things again. I am not joined to a domain at this time and so I think there is no override from the corporate AD rules. I tried everything I can think of. Anyone have any ideas?

    Thanks in advance,

    DMS

    Thursday, April 28, 2016 9:28 AM

Answers

  • Hi DMSchmi,

    If the main issue is to disable Windows Firewall, we could try to change the "Windows Firewall" services status to "disable".

    The registry key should be

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MpsSvc\Start

    "4" means disable.

    "2" means auto.

    In addition, the following gpo could be used to disable windows firewall.

    Computer Configuration, Administrative Templates, Network, Network Connections,Windows firewall,domain or standard, Windows firewall:protect all network connections

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by DMSchmi Tuesday, May 3, 2016 11:53 AM
    Friday, April 29, 2016 6:44 AM
    Moderator

All replies

  • Hi DMSchmi,

    If the main issue is to disable Windows Firewall, we could try to change the "Windows Firewall" services status to "disable".

    The registry key should be

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MpsSvc\Start

    "4" means disable.

    "2" means auto.

    In addition, the following gpo could be used to disable windows firewall.

    Computer Configuration, Administrative Templates, Network, Network Connections,Windows firewall,domain or standard, Windows firewall:protect all network connections

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by DMSchmi Tuesday, May 3, 2016 11:53 AM
    Friday, April 29, 2016 6:44 AM
    Moderator
  • Dear MeipoXu,

    Thanks very much for the advice. That finally worked. It seems like it should not be so hard to turn things on and off in Windows....whatever version. Now that I know where it is, I suppose you could also do this though the Windows Computer Management and then go into services and set the Firewall to manual or disabled.

    Thanks again,

    DMSchmidt

    Tuesday, May 3, 2016 11:57 AM
  • sorry to bring this topic up again, but I have the same problem, but the modification of the registers doesn't work for me. the firewall reactivates itself within a couple of seconds.

    any other suggestions?

    Best regards

    Tuesday, October 18, 2016 1:31 PM
  • you could try doing it from the Computer management console. Right click on the start button and select Computer Management > Services and Applications > Services. Then scroll down to Windows firewall and double click it. Set the startup type to manual and then stop the service and click OK. Hopefully that will work.

    Rgds,

    DMS

    Tuesday, October 18, 2016 2:46 PM
  • This method was the one that finally worked although I could not change it to manual.  I had to disable it.  This was too hard.  Since Windows can detect when another Firewall is running, it should be easy in that situation to turn off Windows Firewall.  Conflicts between the two were creating problems of some of my applications.
    Saturday, September 30, 2017 3:03 PM
  • Hi DMSchmi,

    If the main issue is to disable Windows Firewall, we could try to change the "Windows Firewall" services status to "disable".

    The registry key should be

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MpsSvc\Start

    "4" means disable.

    "2" means auto.

    In addition, the following gpo could be used to disable windows firewall.

    Computer Configuration, Administrative Templates, Network, Network Connections,Windows firewall,domain or standard, Windows firewall:protect all network connections

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    This is an old post I know, But, I have just found as I have the same Problem. I tried this fix, but, for some reason I could not use Microsoft Store. Everything disappeared greyed out. I had to switch the win Firewall back on.


    Friday, September 7, 2018 1:40 PM
  • The registry trick works for me on Windows Server 2019 Core. Thanks!
    Thursday, October 18, 2018 4:49 AM
  • THANKS ITS WORK ON WINDOWS 10
    Thursday, December 13, 2018 12:10 PM
  • Hello I also have this problem and I cannot disable firewall from services because the options to stop it change the start up type or disable it are unclickable help please 
    Saturday, August 31, 2019 9:48 PM
  • OMG! i can't believe . it's working for me.
    Wednesday, April 8, 2020 10:22 AM