none
Installed products not available for Office Assessment RRS feed

  • Question

  • As a follow up to http://ctp.social.technet.microsoft.com/Forums/en-ZA/map/thread/3a390fcd-71c7-4eb4-a1e1-bf6d453dc2a4 (since this is now not a CTP program)...

    I too am running into this problem. My MAP 5.5 scanning server is 2008 R2 SP1.  All our clients are XP SP3 with various office versions installed (2000 to 2010). Of the ~400 PCs scanned, this is what its reported, which isn't very helpful for a full picture.

    Office Application Name

    Number of installed copies

    Microsoft Office Professional Edition 2003

    83

    Microsoft Office Professional Plus 2007

    6

    Microsoft Office Professional Plus 2010

    16

    Microsoft Office XP Professional

    3

    Individual Office product

    323

    I went ahead and manually checked a few PCs which Office2010Assessment*.xlsx reported with a WMI status =  Success (and other fields like os, bios, cpu, memory, etc were filled out), yet the Other Installed Office Products = Installed Product List Not Available.

    PC1 = Has office 2003 installed (validated the existence of c$\Program Files\Microsoft Office\OFFICE11\winword.exe)
    PC2 = Has office 2003 installed (validated the existence of c$\Program Files\Microsoft Office\OFFICE11\winword.exe)
    PC3 = Has office 2003 installed (validated the existence of c$\Program Files\Microsoft Office\OFFICE11\winword.exe)

    What is the next step for troubleshooting this problem?

    Friday, July 1, 2011 10:20 PM

Answers

  • Followup

    Michael and the MAP team helped me resolve the issue.  Even upgrading from MAP 5.5 to 6 didn't help.  Apparently in my environment, the WMI queries for the CDROM were failing, which ends up causing the collection of registry data (including installed products) to get skipped for those machines. 

    This issue might be resolved in MAP 6.5.



    • Marked as answer by BSOD2600 Thursday, July 28, 2011 7:14 PM
    Thursday, July 28, 2011 7:14 PM

All replies

  • MAP 5.5 gets the product list from HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\installer\UserData\*\Products\*\InstallProperties. Is your question why aren’t the office products showing up in the report?

     

    If so, can you send the database to mapfdbk@microsoft.com and reference the question in the subject line so that I know it is from the forum post? 

     

    Thanks

    ---------------------------

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, July 6, 2011 6:48 PM
    Moderator
  • The question is why did so many workstations come back with Installed Product List Not Available when Office clearly IS installed and MAP was able to retrieve other information about the workstation (os, cpu, memory, free disk, etc).

    I spot checked a few workstation from Office2010Assessment*.xlsx which have Installed Product List Not Available listed.  Sure enough, they all had 'Microsoft Office Professional Edition 2003' in the registry (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\9040110900063D11C8EF10054038389C\InstallProperties).

    I'll send you the database here shortly.

    Wednesday, July 6, 2011 7:55 PM
  • Followup

    Michael and the MAP team helped me resolve the issue.  Even upgrading from MAP 5.5 to 6 didn't help.  Apparently in my environment, the WMI queries for the CDROM were failing, which ends up causing the collection of registry data (including installed products) to get skipped for those machines. 

    This issue might be resolved in MAP 6.5.



    • Marked as answer by BSOD2600 Thursday, July 28, 2011 7:14 PM
    Thursday, July 28, 2011 7:14 PM