none
Windows 10 and Remote Web Workplace RDP

    Question

  • Hello.

    I am having problems with having a Windows 10 PC access a workstation via RDP through Remote Web Workplace running on SBS 2008.  When the Windows 10 PC tries to access the workstation a dialog box appears:

    1. Title:  VBScript Remote Desktop Connection
    2. Message:  The wizard cannot configure Remote Desktop Connection settings.  Make sure that the client version of Remote Desktop Protocol (RDP) 6.0 or later is installed on this computer.

    The Windows 10 PC can access the same workstation without problems when they are not "remote" from each other---just not through the Remote Web Workplace.

    Any thoughts?


    Sunday, July 19, 2015 11:17 AM

Answers

  • I found a work around for this on SBS 2008.  Navigate to "C:\Program Files\Windows Small Business Server\Bin\webapp\Remote" on the SBS server.   In that directory you will find a file named tsweb.aspx, right click it and edit it.  Go about 1/4 to 1/3 of the way through the file and look for the section that looks this:

    sub window_onload()
    Dim targetMachineName
    Dim version 
    On Error Resume Next
    version = MsRdpClient.Version
    if Err then
      msgbox ControlLoadFailed_ErrorMessage,0,RemoteDesktopCaption_ErrorMessage
      exit sub
    end if  
    On Error GoTo 0
    if strcomp(version,"6.0.6000") < 0 then
       msgbox IncorrectClientVersion_ErrorMessage, 0, RemoteDesktopCaption_ErrorMessage
       window.close
       exit sub
    end if

    What I did was to comment out the second part of that statement so it looks like this

    'if strcomp(version,"6.0.6000") < 0 then
    '   msgbox IncorrectClientVersion_ErrorMessage, 0, RemoteDesktopCaption_ErrorMessage
    '   window.close
    '   exit sub
    'end if

    I have done limited testing and this seems to work, but I don't know if there are any bad side effects at this time.  Windows 7 clients do not seem to have issues connecting after this change was made.  

    You also may have to temporarily adjust permissions on that file so that you can save the file.  

    I also had the compatibility mode on and had it as a trusted site, but I have not tested it without those on.



    Thursday, July 30, 2015 2:21 PM

All replies

  • Hi,

    I am having problems with having a Windows 10 PC access a workstation via RDP through Remote Web Workplace running on SBS 2008

    Please check event logs to see whether any detailed information was logged.

    In addition, I suggest you add the Remote Web Workplace website address into compatibility view to see whether it works.

    More information for you:

    How to connect to SBS 2008 domain clients using RWA from a remote Windows 8 computer

    http://blogs.technet.com/b/sbs/archive/2012/12/06/a-remote-windows-8-computer-fails-to-connect-to-sbs-2008-domain-clients-using-rwa.aspx

    RWW error: Wizard cannot configure Remote Desktop Connection settings. W7 Home Premium to SBS 2008r2

    https://social.technet.microsoft.com/Forums/en-US/07f970eb-b2f7-4166-8167-36dd9fbb0e26/rww-error-wizard-cannot-configure-remote-desktop-connection-settings-w7-home-premium-to-sbs-2008r2?forum=winserverTS

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 20, 2015 10:03 AM
    Moderator
  • Unfortunately, I had already tried the compatibility view settings for IE.  This works fine for the Win8.x PCs.  Just not the Win10 one.
    Tuesday, July 21, 2015 2:02 AM
  • I've been chasing down the same issue since I started previewing Windows 10 at the earliest stages...

    I can connect to my SBS 2011 servers without a problem

    SBS 2008 Servers - No Joy!  Adding them to compatibility mode will allow the Connect to Computer option to reappear but when selected I get the must have RDP 6.0 or higher message as the original poster mentions.

    This is a major problem for me as I manage a fair # of SBS 2008 installations.  I must always resort to my Win 8.1 Laptop or an old XP VM that I keep around to access older Dell DRACs etc. just to access the server.

    I'm sure its an easy fix on either the server or client side or both - most likely the server needs to recognize and accept RDP 10 connections as this is what the current Client Versions of Windows 10 are running.

    The thing is - as I plan to make the switch to Windows 10 across the board for all of my personal and work devices (Win7 - Win 8.1 and so on) as a private IT Consultant / SysAdmin it makes it a very difficult sell in advising my clients on whether to likewise make the jump to Win10 on all of their client PC's when silly little things like this are net yet worked out - and with the clock ticking its just not a conversation that I am currently driving at the moment - and I am practically dreading if and when a client might ask.

    The one time it has come up with a client we haven't gotten into this particular issue but what did come up was that while they like Win10 personally they don't see its place in the workspace.  To which I countered there are a great many security enhancements and global sync across device capabilities that will certainly enhance the workplace use as employees move from their desktops to their laptops or tablets in the field etc.  From a mobility and security standpoint I think great strides have been made - the clients concern is that her employees will be all caught up in the tile interface playing on Facebook / Reading the News and Watching Funny dog / cat videos all day - I guess I will be digging into Group Policy and limiting / standardizing people's desktops in ways a lot more invasive and restrictive than in the past.  Granted you could always get to these things on your own anyway even in the days of XP but having it in your face like that will certainly distract many more than your occasional office lacky...but I digress


    JMS

    Monday, July 27, 2015 7:10 PM
  • I found a work around for this on SBS 2008.  Navigate to "C:\Program Files\Windows Small Business Server\Bin\webapp\Remote" on the SBS server.   In that directory you will find a file named tsweb.aspx, right click it and edit it.  Go about 1/4 to 1/3 of the way through the file and look for the section that looks this:

    sub window_onload()
    Dim targetMachineName
    Dim version 
    On Error Resume Next
    version = MsRdpClient.Version
    if Err then
      msgbox ControlLoadFailed_ErrorMessage,0,RemoteDesktopCaption_ErrorMessage
      exit sub
    end if  
    On Error GoTo 0
    if strcomp(version,"6.0.6000") < 0 then
       msgbox IncorrectClientVersion_ErrorMessage, 0, RemoteDesktopCaption_ErrorMessage
       window.close
       exit sub
    end if

    What I did was to comment out the second part of that statement so it looks like this

    'if strcomp(version,"6.0.6000") < 0 then
    '   msgbox IncorrectClientVersion_ErrorMessage, 0, RemoteDesktopCaption_ErrorMessage
    '   window.close
    '   exit sub
    'end if

    I have done limited testing and this seems to work, but I don't know if there are any bad side effects at this time.  Windows 7 clients do not seem to have issues connecting after this change was made.  

    You also may have to temporarily adjust permissions on that file so that you can save the file.  

    I also had the compatibility mode on and had it as a trusted site, but I have not tested it without those on.



    Thursday, July 30, 2015 2:21 PM
  • I found a work around for this on SBS 2008.  Navigate to "C:\Program Files\Windows Small Business Server\Bin\webapp\Remote" on the SBS server.   In that directory you will find a file named tsweb.aspx, right click it and edit it.  Go about 1/4 to 1/3 of the way through the file and look for the section that looks this:

    sub window_onload()
    Dim targetMachineName
    Dim version 
    On Error Resume Next
    version = MsRdpClient.Version
    if Err then
      msgbox ControlLoadFailed_ErrorMessage,0,RemoteDesktopCaption_ErrorMessage
      exit sub
    end if  
    On Error GoTo 0
    if strcomp(version,"6.0.6000") < 0 then
       msgbox IncorrectClientVersion_ErrorMessage, 0, RemoteDesktopCaption_ErrorMessage
       window.close
       exit sub
    end if

    What I did was to comment out the second part of that statement so it looks like this

    'if strcomp(version,"6.0.6000") < 0 then
    '   msgbox IncorrectClientVersion_ErrorMessage, 0, RemoteDesktopCaption_ErrorMessage
    '   window.close
    '   exit sub
    'end if

    I have done limited testing and this seems to work, but I don't know if there are any bad side effects at this time.  Windows 7 clients do not seem to have issues connecting after this change was made.  

    You also may have to temporarily adjust permissions on that file so that you can save the file.  

    I also had the compatibility mode on and had it as a trusted site, but I have not tested it without those on.



    This worked for me as well;  I found plenty of the local PC work around solutions but nothing that worked with the new IE11.  Thank you so much for putting this up!!!!!!

    James


    James

    Thursday, July 30, 2015 11:47 PM
  • Hi,

    @AE_MGS, thank you very much for sharing the workaround!

    @M-A-S, please try the workaround and check whether the issue goes way.

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 31, 2015 1:37 AM
    Moderator
  • Brilliant!  I've been struggling with this problem all day.  So far, I've tested this workaround on Win 10, 8.1 & 7 -All using IE 11.  This resolves Remote Web Workspace connectivity issues with Win 10 and I have not seen any adverse effects or issues with connectivity using Win 8.1 or 7.

    Thank you so much for this post!

    • Proposed as answer by FelinoJC Saturday, August 01, 2015 12:45 AM
    • Unproposed as answer by FelinoJC Saturday, August 01, 2015 12:45 AM
    Saturday, August 01, 2015 12:45 AM
  • Does not seam to work on RTM :-( .   At least for me...
    Tuesday, August 04, 2015 5:13 PM
  • @AE_MGS Thank You! This workaround did the trick.
    Tuesday, August 04, 2015 10:47 PM
  • Wow! Thanks! I spent 2 hours trying to fix this.  You made Windows 10 a viable option for me.

    Sunday, August 09, 2015 7:47 PM
  • Thank you Amy.  I'd updated my laptop to Windows 10, am going on travel next week, and as administrator, was really upset/worried that I couldn't remote into our server if needed while on travel.  Your patch works like a charm.  You saved my day!

    Scott

    Wednesday, August 12, 2015 2:53 AM
  • I am still having the same issue.. is anyone can help me with this.
    Monday, August 31, 2015 10:58 AM
  • You my friend are a genius.

    It works. 

    Friday, September 04, 2015 1:27 AM
  • Yes, indeed, this hack works.

    But it also defeats the test: If you try to connect with an old RDPClient, you will not be denied to do so.

    sub window_onload()
                                       Dim targetMachineName
                                       Dim version 
                                       Dim Parts
                                       Dim Major
                                       On Error Resume Next
                                       version = MsRdpClient.Version
                                       if Err then
                                          msgbox ControlLoadFailed_ErrorMessage,0,RemoteDesktopCaption_ErrorMessage
                                          exit sub
                                        end if  
                                       Parts= split(version,".")
                                       Major=CInt(Parts(0))
                                       On Error GoTo 0
                                       if Major < 6 then
                                          msgbox IncorrectClientVersion_ErrorMessage+"Version:"+version, 0, RemoteDesktopCaption_ErrorMessage
                                          window.close
                                          exit sub
                                       end if
    

    You should never use a text compare if you need to test between integers.

    BTW, as you are modifiying this file, remember to change the RDP61SettingsOnly Sub

    sub configRdp61OnlySettings
    	' If GatewayCredSharing is not set, customer will see two logon prompts - for TSG and TS server, but we should continue
    	On Error Resume Next
    	if (<%=UseTsGatewayFlag%>) then 
    		' Pass the credentials used for the gateway to the remote computer
    		MsRdpClient.TransportSettings2.GatewayCredSharing = 1
    		MsRdpClient.TransportSettings2.GatewayDomain = "<%=RWWUtilities.QuoteVbscriptString(strQualifiedDomainName)%>"
    	end if
    	MsRdpClient.AdvancedSettings6.EnableCredSspSupport = TRUE
    end sub

    Just my two cents.

    Thursday, October 15, 2015 3:19 PM
  • I just tried this now on my SBS 2008 box as I have two users trying to connect however it's still giving me the same error. I restarted all the terminal services on the server as well. Any suggestions?
    Friday, October 23, 2015 3:41 PM
  • I tried this and it did not work for me.

    I am in a shutdown state because of lack of backwards compatibility. I upgraded based upon MS recommendations.

    I thought simple things like insuring a new product are to work with older products are thought through and worked out before releasing, no?

    Any suggestions?

    • Proposed as answer by tallpaul4343 Thursday, December 17, 2015 3:57 PM
    • Unproposed as answer by tallpaul4343 Thursday, December 17, 2015 3:57 PM
    Tuesday, November 03, 2015 1:36 AM
  • There is another workaround for Windows 10 without modifying the code on the SBS server. You can simply skip using the Remote Web Workplace all together by just using the Remote Desktop Connection built into Windows.

    1. Open the Remote Desktop Connection application on your computer. The easiest way to do this is go to start and search for Remote Desktop using Cortana.

    2. In the Remote Desktop Connection click on Options, then go to the Advanced tab, select the button labeled Settings... 

    3. Select the option to connect to a gateway, and enter the URL for your remote web workplace site without the HTTPS://, for example: remote.contoso.com

    4. Also on this Tab, enabled the checkbox option to Use my RD Gateway credentials for the remote computer. Then click OK

    5. Go back to the General Tab, in the Computer Name field enter the internal network name of the computer on the SBS network. This can be looked up by going to the Control Panel then to System on the computer you want to connect to.

    6. Press Connect and enter your credentials when prompted. 


    • Edited by tallpaul4343 Thursday, December 17, 2015 4:37 PM
    • Proposed as answer by Ross_SteamDesk Wednesday, September 28, 2016 10:10 AM
    Thursday, December 17, 2015 4:36 PM
  • Thank you so much for putting this up. You are the best

    5 stars

    José Carvalho

    Wednesday, March 02, 2016 9:27 PM
  • TallPaul's solution won't allow you to take control of a remote workstation. You would need to open up port 3389 and forward it to the IP address of the workstation you wish to control.

    -Kevin Weilbacher (SBS MVP)
    "The days pass by so quickly now, the nights are seldom long"
    KW Support MVP Blog
    MVP's do NOT work for Microsoft. We give our time freely to support the SBS community!

    Tuesday, May 31, 2016 3:05 AM
  • Editing the "C:\Program Files\Windows Small Business Server\Bin\webapp\Remote\tsweb.aspx" file worked for me too! Thank you

    Saturday, June 11, 2016 8:22 PM
  • Thanks great way in via rdp than the browser great solution thank you.

    ollie

    Monday, July 04, 2016 9:00 AM
  • Actually TallPauls' solution works for hitting the remote workstations.  You just put in the name of the computer.  You don't open up 3389 at all, it's all over 443.
    Saturday, August 06, 2016 2:54 AM
  • For those still using sbs 2008 and Windows 10, be aware the AU release breaks this again.  For now use the rdp gateway workaround. 

    I'm not sure we can find a workaround this time so prepare yourselves.

    Or -- roll back from the AU release as you only have 10 days to roll back.

    Saturday, August 06, 2016 2:58 AM
  • I'm also having this problem with SBS 2008 and Windows 10 after installing the "Anniversary Update".  Any suggestions?
    Thursday, August 25, 2016 2:01 AM
  • See this thread:

    https://community.spiceworks.com/topic/1788483-win-10-anniversary-update-kills-sbs-2008-rww-connection-vbscript-error-50331676?page=1#entry-6249233

    • Proposed as answer by Tricsity Tuesday, October 04, 2016 11:54 AM
    • Unproposed as answer by Tricsity Tuesday, October 04, 2016 11:54 AM
    Friday, September 30, 2016 3:11 PM
  • Hello,

    I have a client with SBS2008.  I just tried to setup a Windows 10 with RWW to connect to a Windows 7 PC but failed...the Windows 10 machine does have the anniversary update.  I tried with the RWW website after updating both the tsweb.aspx per above and adding site to compatibility view settings in I.E.  but still failed.

    I was able to connect by:  Using RDP through RDG by configuring the  "Connect from Anywhere" settings on the Advanced tab in the RDP client.  It continually failed with credentials error until I added the "full computer name" (per the control panel/system icon) of the target PC...for example pcname.domain.local.  After I added the ".domain.local' part I was able to successfully connect.

    I'm very interested if this works for anyone else.

    Tuesday, October 04, 2016 12:12 PM