locked
Explorer Window Contents do not auto-refresh (Vista SP1) RRS feed

  • Question

  • Hello all,

    I'm not sure at what point this began to happen, but I have several machines in the office that now exhibit this problem.  When you do something within an explorer window that changes the content of a folder (copy/delete/move a file or folder, create a new folder, etc.), the contents of the window do not change unless I manually refresh the view (F5).  Is there a registry/control panel setting that turns this feature on or off?  I haven't been able to find any other info on this, and it's starting to annoy my users.  Thanks in advance!

    SN
    Monday, September 22, 2008 7:53 PM

Answers

All replies

  •  

    Hi, this issue can be caused by Thumbnails database, let’s perform the following steps to rebuild it and check the result:

     

    1.       Click Start, type cleanmgr in Start Search and press Enter. You can also go to Start – All Programs – Accessories – System Tools – Disk Cleanup.

    2.       After performing Disk Cleanup on system partition, put a checkmark on Thumbnails.

    3.       Press OK.

    4.       After that, let's check if the issue is resolved.

    Wednesday, September 24, 2008 6:23 AM
    Moderator
  •  

    Have the same problem on Vista Enterprise. Drop a file into a folder on the network and it does not appear until F5 is pressed. If a file is dropped in a folder on the local disk C: it appears as expected. Cleaning Thumbnails database as suggested does not help.
    Wednesday, September 24, 2008 7:26 AM
  • Clearing thumbnails didn't resolve it here, either.
    Wednesday, September 24, 2008 3:19 PM
  • No suggestions here other than deleting the thumbnail cache?
    Thursday, October 9, 2008 4:15 AM
  • Hi BassoProfundo,
    Can you please elaborate on your scenario? does this happen when copying from a network share to a local drive or is it the other way around? or both ? does the view never refresh automatically ?

    Thanks,

    Alexander Sklar | Software Development Engineer - Windows Serviceability

     

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, October 22, 2008 8:18 AM
    Answerer
  •  

    In our case, it is when you drop a file into a network drive folder. It does not appear until you refresh. Same if you make a New Folder in a network drive folder, it does not appear until you refresh.
    Wednesday, October 22, 2008 9:04 AM
  • It was exactly as grimrian describes.  Unfortunately, I can no longer simulate the problem on my machine as my primary hard drive died, resulting in my having to reload the OS.  The affected users had their machines re-"ghosted" as well with our stock image (Vista Business w/SP1) and no longer suffer from the issue either.  It sounds as if grimrian can work with you to troubleshoot, though.

    Wednesday, October 22, 2008 2:47 PM
  • Thanks for the clarifications. I will look into this issue.

    Thanks,

    Alexander Sklar | Software Development Engineer - Windows Serviceability

     This posting is provided "AS IS" with no warranties, and confers no rights.


    Wednesday, October 22, 2008 3:36 PM
    Answerer
  • just to add my details, i have vista home premium sp1 and have the same issue as the op. i have not tried it on network drives - it occurs on local folders. computer is not joined to a domain. i have deleted the thumbnail cache and it has made no difference whatsoever.
    Sunday, October 26, 2008 8:57 PM
  • Try this:
    http://support.microsoft.com/kb/823291

    I realize it says it is for XP, but it may also resolve the problem in Vista.  I deployed this to my organization using a Group Policy Preference to prevent this problem in XP (we use DFS with redirected folders).  We haven't started deploying Vista yet, but it's worth a shot.
    Wednesday, October 29, 2008 2:54 AM
  • grimrian/bassoprofundo:

    how are you launching explorer window that points to the network folder? is it through a shortcut? if so, which OS release was used to create it ?

     

    I don't think the local folder refresh issue has the same root cause as this one (can't really tell without more details, does this happen consistently?)

     

    Alexander Sklar | Software Development Engineer - Windows Serviceability

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, October 30, 2008 2:04 AM
    Answerer
  • I was just having the same problem (Google sent me here lol), no auto update on create new folder. Although copying files did update the filelist on the remote drive. Turns out I transferred all my XP .lnk files to Vistas desktop and they are somehow different. To solve it, I just deleted the old .lnk's and used the 'create shortcut' option in Vista to make new ones. Works perfectly now.
    • Proposed as answer by chadleong Friday, January 16, 2009 12:47 AM
    Sunday, November 2, 2008 9:59 PM
  • BRILLIANT!! Yes, this is it! Folders opened through old Win2000 links will not update automatically. Folders opened through Vista link will update! Thanks Shengis - I hope our friends in Microsoft sees your posting soon!

    Monday, November 3, 2008 11:21 AM
  • Thank You Shengis ! That was it.

     

    Thursday, November 13, 2008 4:49 PM
  •  Hi,

    I'm happy to announce that this issue has been addressed by a hotfix. Please go to http://support.microsoft.com/kb/960954 to download the fix.
    Thanks for reporting this issue.

    Alexander Sklar | Software Development Engineer - Windows Serviceability
    http://blogs.msdn.com/asklar
    This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, January 12, 2009 2:22 AM
    Answerer
  • I am facing this problem in Windows XP SP3 machines.
    Is there any hotfix for XP SP3.
    Tuesday, August 25, 2009 5:38 AM
  • Hi Vanan - this hotfix addresses a specific issue which only occurs in Vista, so the root cause of what you're experiencing in XP is probably different.

    Alexander Sklar| Software Development Engineer
    http://blogs.msdn.com/asklar
    This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, August 31, 2009 8:47 PM
    Answerer
  • I have got this problem on Vista SP2 machines, too.
    Is there a hotfix available?

    the posted one is not compatible to Vista SP2
    Tuesday, September 22, 2009 9:10 AM
  • The hotfix for SP1 is included in Windows Vista SP2. Can you describe what the exact environment is that you're seeing this in? are you navigating to a mapped network drive? or is it just a share like \\server\share? what is the OS on the server?

    Alexander Sklar| Software Development Engineer
    http://blogs.msdn.com/asklar
    This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, September 24, 2009 12:38 AM
    Answerer
  •        Thanks for your reply. To respond takes a little bit longer, because the system is not at my workplace, at the moment.


           Server: NetApp, Version: 7.2.6.1p2 Filesystem:    WAFL 

           Client: Mapped network drive by logon script

     

           The problem appreas, for example, if you drag & drop a mail from outlook 2007 (sp2) to the mapped network share.

           After pressing 'f5' the message file appears in the explorer window

     

           The client has already the sp2 for vista installed.

    Friday, September 25, 2009 7:02 AM
  • Thanks MDeffner for the info. The issue reproduces on mapped network drives, I will bring this to the attention of my team so that we give it the appropriate consideration to fix it. In the meantime, consider accessing the resource through UNC syntax (i.e. \\server\share).

    Thanks for taking the time to report this issue.

    Alexander Sklar| Software Development Engineer
    http://blogs.msdn.com/asklar
    This posting is provided "AS IS" with no warranties, and confers no rights.

    Saturday, September 26, 2009 1:54 AM
    Answerer
  • Hello dear,
    I'm facing the same issue on Windows 7 64 Ultimate.
    Every thing is working properly in the normal usage, when I start VM ware with windows 2008 images, the issue starts.

    I found this KB which describes the same issue which I'm facing (http://support.microsoft.com/kb/823291) File list in the Windows Explorer folder is not refreshed after you create, move, or delete files.
    But it is for Windows XP.

    Any help is appreciated
     
    tariq
    Thursday, October 22, 2009 8:44 AM
  • what folder are you experiencing this with? which Windows 7 build is this? please describe your scenario clearly and completely, specifically what it is you are doing with VMWare and what files you're changing and where.

    Alexander Sklar | Software Development Engineer
    http://blogs.msdn.com/asklar
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, October 22, 2009 8:53 AM
    Answerer
  • All the folders on my laptop
    Build 7100
    I can create, cut, move files without the need to manually refresh the explorer. when I start VM ware, I run 4 windows server 2008 machines to test Exchange 2010. once VM ware starts the issue appears. when I create folder or cut and move files, I have to refresh manually to be able to see tne new changes!

    Http://tariqjaber.com/blog
    Thursday, October 22, 2009 9:42 AM
  • Same sort of problem for me. Brand new Win7 custom install. When deleting a file in windows explorer the icon remains unless I manually refresh.
    Saturday, October 24, 2009 3:25 PM
  • Build 7100 was the Release Candidate, we have fixed many issues since then, so I would recommend you upgrade to the released Win7 RTM build. In any case, if the issue starts when VMWare is started, I would suggest you contact VMWare.

    Alexander Sklar | Software Development Engineer 2
    http://blogs.msdn.com/asklar
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, October 26, 2009 5:55 PM
    Answerer
  • Is there any news on this. I also have this problem on Vista SP2 64 bit systems where mapped network drives do not autorefresh and UNC syntax acces does autorefresh.
    Wednesday, October 28, 2009 10:02 AM
  • Same problem here, exactly as described above.  Window 7 x64 Enterprise.
    Wednesday, November 25, 2009 3:31 AM
  • Any news with W7 and WMWare?
    I have the same problem...
    Tuesday, February 2, 2010 6:21 PM
  • I have the same issue.  I'm on Win 7 Ultimate (32). 

    I've experienced this in both network and non-network folders.  However, the network folders issue and Win2k shortcuts aren't the problem for me.  I just browsed to a sub-folder of My Docs and copied two Word docs, minimized the folder and pasted to my desktop.  They didn't appear until I manually refreshed. 

    As others have noted, the Win XP fix is very relevant, but I'm not gonna run that on my Win7 system until either several users have tried this with successful, or MS approves that fix for Win 7. 

    I'm subscribed to replies on this post.  So, please let us know if this is resolved.

    Wednesday, April 7, 2010 6:56 PM
  • Looks like I can be added to another list of users who has vanishing folders until you hit refresh. My scenario is i go to a folder, and every so often when i hit "new folder" nothing appears. Hitting refresh will show me the new folder and its even already in edit mode to be renamed like it should have been, its very odd and does not happen often but often enough to be annoying.

    I am also noticing odd system performance, perhaps something in the hardware is failing? diskchk does not show anything wrong :(.

    I have WIN7 RTM x64bit on my Lenovo W500 laptop.

    Thursday, June 17, 2010 3:26 AM
  • It seems I'm having the same issue as LyalinDotCom.  In Windows 7 Professional 64-bit, I can create a new folder, but it doesn't show up until I press F5 to refresh manually.  Then it lets me edit the folder name.  Also when copying files from a memory card, or other location into a folder, the copy process finishes, but no files show up in that folder.  I have to manually refresh each time to see any changes.  It's really quite annoying.

    It may be something on my computer, but so far I can't see what that might be.  I've also seen "pauses" for no reason on my system.  After clicking on an icon to run something or open a file, there's an extended pause for around 5-10 seconds before anything occurs.  Unfortunately this only occurs rarely and I haven't found any pattern to it.  This also could be something on my computer, but so far I can't find any processes, malware/viruses, or any other reason for it.

    Don't really expect a solution here, but I found this thread researching the problem so I thought I'd post my experience.

     

    Tuesday, July 20, 2010 3:00 AM
  • Just registered because I was reading this topic and found a fix. Enjoy guys!

     

    If that doesn't help then I suppose you need to tweak your registries. Make sure you take the backup before performing this tweak because if anything went wrong you know you have some thing to restore it back. So open up Windows registry by typing "regedit" in the Start search box. Search for "dontrefresh" in the registries. Most probably it should be under HKEY_CLASSES_ROOT\CLSID{BDEADE7F-C265-11D0-BCED-00A0C90AB50F}\Instance. So, as per your situation, it should have the value of 1. Change it to "0".

    • Proposed as answer by Gr11zzly Tuesday, November 8, 2011 5:05 AM
    • Unproposed as answer by Gr11zzly Tuesday, November 8, 2011 5:12 AM
    Monday, December 13, 2010 2:29 AM
  • I found a solution that works for me.  I don't think this solution has been posted yet, so let me try to explain what happened to me and how I fixed it.

    My problem was very similar to others posted here.  When I created a new folder it wouldn't show up in the Windows File Explorer list until I hit F5 to refresh Explorer (at which point the folder would appear in edit mode).  The new folder should appear without hitting F5 (i.e. without manually refreshing the window).

    When I started troubleshooting this problem the first thing I noticed is that it only occurred when I used one of my "Favorites" shortcuts to go the folder "Libraries\Documents\test".  If I clicked on "Documents" in the "Libraries" section and then browsed to my "test" folder I wouldn't have this problem.

    The next thing I noticed that was different between my working and non-working test folder explorer window was the path.  In normal mode the working window (i.e. the one where I manually browsed to my test folder) and my non-working window (the one where I used my Favorites shortcut) both displayed the same "Libraries > Documents > test" path.  However, if I clicked in the address bar the path then changed to the fully qualified path and these paths were different!
    Working path:        C:\Users\williamgates\Documents\test
    Non-working path:    C:\Users\williamgates\My Documents\test

    So the direct cause of my problem seemed to be using a "My Documents" path when Win7 apparently prefers a "Documents" path.  Now I was curious why this just started happening when all of my favorites used to work fine.

    After a bit of digging I came to this registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
    In the key all of my user folders were set to "My Documents" type paths.  For example "Personal" was set to "%USERPROFILE%\My Documents".  According to http://support.microsoft.com/kb/886549 none of these directories should have "My Documents" in the path.  For example "Personal" should be set to "%USERPROFILE%\Documents".

    Once I fixed all of these registry keys (removed "My Documents" from my paths) I assumed everything would start working again, but it didn't (even though my favorites shortcuts updated themselves).  I then rebooted my laptop confident that a magic reboot would be all that was needed to finish fixing this issue, but this still didn't work!

    Just to recap my favorite now (correctly) points to "C:\Users\williamgates\Documents\test", but doesn't work.  If I browse to "C:\Users\williamgates\Documents\test" by going through the "Documents" library it does work (i.e. new folders automatically appear).

    At this point I now deleted my "test" favorite shortcut and recreated it.  I did this with little hope that it would work, but much to my surprise this new favorite (which points to the exact same place as the old favorite) works!  Not only that, my other favorite shortcuts that didn't work (i.e. when you used the favorite new folders wouldn't automatically appear) also magically started working.

    I can't explain why my last step of recreating my favorite helped, but it appeared to be a required last step to resolve my issue.  It's also strange that using the “Documents” library always worked, whereas others report libraries as the cause of their problems.  I hope my pain and suffering can help someone else.

    Note that I'm using Win7 Enterprise.  A corporate registry update which mucked up my user folders appears to have been the trigger of my issues.

    I should also note that my "DontRefresh" registry keys are both set to 1, which sounds like it could cause this problem.  However I did NOT change these.  I.e. I left them both at 1 and it works ok for me (now that I've fixed my path and re-created my favorite link).
    Tuesday, December 21, 2010 6:18 PM
  • I had this error with my documents folder that was synced with \\dataserver\users\username\my documents. Alot of data, so took a while to sync, and i had errors. That's when the update, or rather lack thereof, started to happen. My problem was I had changed the UNC path to my docs, and win7 didn't give up syncing the old unc path, constantly getting errors.

    My recipe for success:
    Disable offline files. Reboot. Delete C:\windows\csc\ (you have to take ownership). Enable offline files. Reboot. Sync. Voila, my docs are updating again.

     Bottom line: Make sure Offline Files(Sync Center) has no errors.


    Asbjørn Vang Jacobsen
    Sunday, February 20, 2011 10:06 PM
  • (My OS: Windows 7 Professional, 64.bit)

    hi,

    I noticed I have a similar problem today. For me, this only occurs in some of my self defined library folders. I have the standard library folders (my music, pictures and so forth) and they all work as usual. Then I have one that I call "Audiobooks". This one is mapped to "C:\user\richard\my audiobooks" and works fine. Then I have three folders; Projects, School and Musicproduction, and none of them will auto refresh.

    The thing that sets Audiobooks apart from the other three is that it is only mapped to one folder. The other libraries are mapped to at least two.

    So to test my theory that this "bug" had something to do with having more than on folder mapped to a library, I created a new library called "Test" and mapped it to one of the not working folders. It still wouldn't auto refresh.

    So I guess something has been corrupted with the particular folders that my not working libraries are mapped to. But I don't know what to look for. Any suggestions?

    Also, one of my questions when I noticed this earlier today was; what have I been doing today that I don't usually do? Well, for one I've been editing "Environment variables" in Windows. I installed the Java JDK, and couldn't execute javac.exe from any folder, so I changed system variable "PATH" to "C:\Program Files\Java\jdk1.6.0_24\bin", which fixed that problem. However, now I don't know the default value, so I can't test if this is what's causing the error.

    Anyone know the default value?

    /Richard


    --- UPDATE

    After some more detective work I found out that for me this error seems to have something to do with catalog structure. If I define I new Library, and map it to c:\User\Richard\Anymapname it works. However if I map it to something like c:\user\Richard\Anymapname\Anothermap it doesn't.

    Still don't know how to fix this though.

    Tuesday, March 22, 2011 7:10 PM
  • I have some strange results to report.  I also had this problem, and while getting sick of pressing F5 every time I added or deleted a file something positive happened.

     

    In an unrelated event,I decided to uninstall the toshiba fingerprint utilities.  Once gone - the refresh returned to normal.  I reinstalled the utilities from a fresh download, and the refresh problem was still gone.  I don't know how this helps anyone, but perhaps the prams roblem does lie in programs running in the background and shown in the system tray.  I'd try disabling them uninstalling and re-installing.

     

    My system:  Toshiba Tecra A10, Windows 7 Pro (64 bit), SP1.  My culprit" Trusuite Access Manager and Toshiba  fingerprint utililty.

     

    I hope this helps someone.

     

    JeffVB

    Saturday, March 26, 2011 8:40 PM