none
Agent status - Unavailable (DPM 2010) RRS feed

  • Question

  • We seem to be experiencing problems with our DPM agents. Everything was working fine until we came in this morning to find that all of our DPM 2010 Agents were reporting 'Unavailable'

    'Protection agent version: 3.0.7706.0
    Error: Data Protection Manager Error ID: 308
     The protection agent operation failed because DPM could not communicate with the Protection Agent service.
    Detailed error code: VssError:Invalid value for registry
     (0x80040153)'

     

    We've tried all of the suggested steps to fix the problem without any success. Any suggestions would be greatly appreciated.

    Thank you!

    Monday, May 9, 2011 2:49 PM

Answers

  • I was able to fix the problem.

    On the DPM server, I found this entry in the registry. 'DefaultAccessPermission' in [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole]. Removed it, rebooted the DPM server and i'm now able to setup secondary protection.

     

    Thank you all for your help.

    Friday, June 10, 2011 3:33 PM

All replies

  • Hi,

     

    Are you seeing

    Event ID: 18213 in the System event logs of the protected servers?

    If so, it could be the DCOM permissions in the registry have become corrupted. Permissions for DCOM applications are stored in the registry. The steps below rewrite the permissions in the registry thus correcting the corruption:

    1. On the protected server that is generating the 18213 event run dcomcnfg.exe.
    2. Navigate to Component Services -> Computers -> My Computer -> DCOM Config -> DPM RA Service.
    3. Right-click on DPM RA Service and select Properties.
    4. On the Properties dialog go to the Security Tab. Edit the Launch and Activation Permissions.
    5. Simply Add “Everyone” and grant some permission to them ( e.g. Local Launch). Click OK then OK.
    6. Go back in and remove the permission just added.
    7. Exit dcomcnfg.exe

     

     

     

    Monday, May 9, 2011 3:16 PM
    Moderator
  • Hi Marc,

    Thank you for the quick reply.

    I'm not seeing EventID 18213 on protected servers, however, I'm seeing a bunch of EventID 18213 in the System event log of the DPM server. I tried your suggestion on the DPM server, but I'm still getting the errors. Any ideas?

    Thanks!

     

    Monday, May 9, 2011 3:34 PM
  • Hi Martin,

     

    I recommend you try the steps above on one of the protected servers also, despite the fact they are not logging the 18213 event.

     

    Thanks,

    Marc

    Monday, May 9, 2011 3:43 PM
    Moderator
  • Hi Marc,

    Tried it. Event 18213 still showing up on the DPM server and the agent status is still 'Unavailable'.

    Any other suggestions?

    Monday, May 9, 2011 5:39 PM
  • Hello Martin,

    Let's try some basic connectivity test first both to and from the DPM server and protected server. All from a command prompt:

      ping <protected server name> <---success or fail.
      net view \\<protected server name><---success or fail.
      Sc \\<protected server name> query<---success or fail.
      Wmic /node:"<protected server name>" OS list brief <---success or fail.

    Questions:
    Did any security templates or GPO changes take place recently?
    Do you also have the integrated firewall on DPM turn on whereas before it was turned off?


    Thanks,
    Shane

     

    Monday, May 9, 2011 8:43 PM
  • Hi Shane,

    I performed the tests on a couple of my protected servers and all were successful. I double checked all my GPOs and security templates. No changes. Firewall status is also unchanged. I’m running out ideas.

    Martin.

    Monday, May 9, 2011 10:34 PM
  • Hello,

    All is not lost Martin.  Pick a machine...any machine that is failing and check the DCOM settings as per:
    http://blogs.technet.com/b/askcore/archive/2008/05/09/troubleshooting-agent-deployment-in-data-protection-manager-2007-dcom.aspx

    Also, see if you can push\install an agent out to any new machine and if so, does it come back as "OK".


    Thanks
    Shane

     

    Tuesday, May 10, 2011 5:55 PM
  • Hi Shane,

    I checked the DCOM settings on a couple of my protected servers and everything looks good. I pushed an agent install to a new server. I got the message that the installation was successful but as soon as I refreshed the agent status, it came back as 'unavailable'

    Should I attempt a repair of DPM at this point?

    Martin.

    Wednesday, May 11, 2011 12:46 PM
  • Hello,

    Most likely it's either a networking issue breaking communication or a DCOM permission with the clients. 
    If the above has failed as well as following:
    http://blogs.technet.com/b/askcore/archive/2008/05/09/troubleshooting-agent-deployment-in-data-protection-manager-2007-dcom.aspx then I'd open up a support incident with Microsoft.

    Thanks
    Shane


    • Edited by ShaneB. _ Wednesday, May 11, 2011 2:04 PM added link
    • Proposed as answer by ShaneB. _ Monday, May 23, 2011 12:28 PM
    Wednesday, May 11, 2011 1:58 PM
  • Hi Martin,

    Are you getting any DCOM Launch error in event viewer(Error code 10016)?

    If so it DCOM issue.
    Go to Component Services, DCOM Config, DPM RA Service, Properties, and added the
    administrative account used to deploy DPM clients.

    Regards
    Mohammed Khalid Kherani [MSFT]
    This posting is provided AS IS, with no warranties, and confers no rights.


    Regards Mohammed Khalid [MSFT] This posting is provided AS IS, with no warranties, and confers no rights.
    Wednesday, May 11, 2011 2:02 PM
  • Hello,

    Are you still having this issue?

    Thanks
    Shane
    Monday, May 23, 2011 12:28 PM
  • Hi Shane,

    Sorry for the long delay in updating this thread, I was away at TechEd in Atlanta. We are definitely having problems with DCOM on the DPM server. In the DPM RA properties, we changed the Identity from the Systems account to a domain account and connections to all protection groups were re established. The server is now operating normally. How can we fix this? I tried setting up secondary protection for this server and the minute I attach it to the secondary server, all my protection groups become unavailable again. Not sure where to go from here.

    Wednesday, May 25, 2011 11:01 AM
  • Hello,

    I'd start by making sure the account being used is a member of the local administrator group for both DPM servers.

    Question: On the secondary DPM server are you also using the same account for DPMRA or the default system account?

    Thanks
    Shane

    Wednesday, May 25, 2011 12:27 PM
  • Yes, the account is part of the local administrator group. On the secondary DPM server i tried it with both accounts. Same result with both, protection groups unavailable.

    Martin.

    Wednesday, May 25, 2011 12:36 PM
  • I was able to fix the problem.

    On the DPM server, I found this entry in the registry. 'DefaultAccessPermission' in [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole]. Removed it, rebooted the DPM server and i'm now able to setup secondary protection.

     

    Thank you all for your help.

    Friday, June 10, 2011 3:33 PM
  • Hey guys, now i'm running into this exact same issue. Nothing changed but my secondary DPM stopped talking to primary.

     

    I have already completly uninstalled DPM from the second and re-installed. still nothing

     

    I have followed all the suggestions in this forum and still nothing. My Secondary DPM talks and sees primary without issue.

     

    I've gotten a little further but now on primary event log it says this

    DCOM was unable to communicate with the computer DPM2.pti.com using any of the configured protocols... all firewalls off. please help

    Wednesday, January 25, 2012 7:50 PM
  • Hi,

    I happened to get the same problem today. After a bit of research, I tried this :

    Agents are "unavailable" and "VssError: Invalid value for registry"

    This ia bit of an odd one and just "happened" on a previously perfectly happy server. We resolved this by simply removing the account used to push out the agents in the DCOM Config (run "dcomcnfg.exe"), find the "DPM RA" in the list and remove/readd the user. No idea what caused that mind!

    It worked right away, no service restart or anything. It happened to me while I was trying to add a secondary server which doesn't connect to my primary server anymore.

    Hope it helps!

    Wednesday, March 11, 2015 7:54 PM