locked
Random Sharing violation during xcopy RRS feed

  • General discussion

  • I use bat files and xcopy to do my securities--yup, I'm older than dirt!  When the bat file is executed to copy from Win 7 to an XP SP3 system all goes well and the file count is 3649.  If I try to xcopy the same directory to a WIN7 machine it abends on a random sharing violation--run it multiple times and is blows in different places.  If I simply do a drag & drop from one WIN7 machine to nother WIN7 machine the copy works successfilly, but the file count is 3893.  I'm guessing the additional files might be "thumbs", but the random sharing violation is annoying.

    Does anyone have any idea what is going on here?
    Sunday, December 13, 2009 4:19 PM

All replies

  • Hi Phil,
    do you have some additional information on your systems ?
    Virusscanner in use ? Which one ?
    Can you post the bat file ?
    Try to remove the directories from the indexing service (control panel, indexing options)
    If all this does not help, try to deactivate the preview and details pane from Windows Explorer (organize, layout uncheck preview and details pane)

    Happy Christmas

    Stefan
    Tuesday, December 22, 2009 11:20 PM
  • Sorry I missed your reply--I thought the utility would notify me if there was a reply.  I turned off indexing and will see if that makes a difference over the next few weeks. I'm using MS Security Essentials.  All maintenance is up to date.
    Sunday, April 11, 2010 2:51 PM