none
Turn off OneDrive domain wide

    Question

  • Hi,

    I am trying to turn off OneDrive domain wide. This looked dead easy. I have set the group policy and the laptop has the policy, but OneDrive still appears. The domain is Windows 2012 fully function domain and the laptop in Windows 8.1 Pro.

    Explorer still sees OneDrive and it is in the system tray. This is an o365 OneDrive account.

    I have attached the policy. Interestingly, the local group policy has two more entries in that section. I'm not sure if the Domain Group Policy Editor should have them.

    Friday, October 2, 2015 11:00 AM

Answers

  • Hi Michael,

    Is RSAT(Remote Server Administrator Tool) which the server tool you using in Win8.1? If you use the RSAT to remote to the 2012 R2 domain controller, it would be as the same as you log in the domain controller to edit the group policy management directly while you has the proper permission.

    And as you mentioned that you missing 2 policies on the domain controller GPMC under the One Drive group policy, I would suggest you to download and copy the latest OneDrive .admx file into the  central store and then check it again.

    You can refer the below link for the Administrative Templates (.admx) for Windows 8.1 and Windows Server 2012 R2 Update:

    http://www.microsoft.com/en-us/download/details.aspx?id=43413

    Hope it helps.

    Best Regards,

    Elaine


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 8, 2015 3:24 AM
    Moderator

All replies

  • Hello,

    Thanks for the post. The OneDrive Group Policies are only available through a Windows 2012 R2 domain controller to Windows 8.1 clients.  On the windows server 2012 R2 DC GPMC, there are 3 settings under the OneDrive policy: Save documents to Onedrive by default;

    Prevent the usage of oneDrive for file storage;

    Prevent OneDrive files from syncing over metered connection. 

    When you enabled the "Prevent the usage of one Drive for file storage" this policy, OneDrive doesn't appear in the navigation pane in File Explorer.

    So I would suggest you to check  if the group policy got applied and you could try to configure the policy on a windows server 2012R2 domain controller.

    You could also check the below link about the OneDrive group policy for more reference:

    https://technet.microsoft.com/en-us/library/dn921901.aspx

    Hope it helps.

    Best Regards,

    Elaine


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 5, 2015 9:01 AM
    Moderator
  • Hi Elaine,

    Are you saying I need to make this policy directly on the DC and NOT on my Windows 8.1 PC using the server tools?

    I can see the policy is RSOP of the machine I'm testing, but as I say I made the policy using the server tools on my Windows 8.1 PC. That is where I took the screenshot.

    Best wishes

    Michael


    Monday, October 5, 2015 8:56 PM
  • Hi Michael,

    Is RSAT(Remote Server Administrator Tool) which the server tool you using in Win8.1? If you use the RSAT to remote to the 2012 R2 domain controller, it would be as the same as you log in the domain controller to edit the group policy management directly while you has the proper permission.

    And as you mentioned that you missing 2 policies on the domain controller GPMC under the One Drive group policy, I would suggest you to download and copy the latest OneDrive .admx file into the  central store and then check it again.

    You can refer the below link for the Administrative Templates (.admx) for Windows 8.1 and Windows Server 2012 R2 Update:

    http://www.microsoft.com/en-us/download/details.aspx?id=43413

    Hope it helps.

    Best Regards,

    Elaine


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 8, 2015 3:24 AM
    Moderator
  • Hi Elaine,

    I opened a case with Microsoft and it turns out that policy is only for personal One Drive and not One Drive for Business.

    Best wishes

    Michael


    Wednesday, October 21, 2015 7:28 AM
  • Hi Michael,

    Thanks a lot for the feedback and the information you shared.

    Have a nice day. :)

    Best Regards,

    Elaine


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, October 21, 2015 7:48 AM
    Moderator