DefaultClientLanguage RRS feed

  • Question

  • I tried to change the DefaultClientLanguage on our server.

    I followed the article :


    Command :

    [PS] C:\>Set-OwaVirtualDirectory -identity "Owa (Default Web Site)" -DefaultClientLanguage 1033 -LogonAndErrorLanguage 1033

    When I try to create a new testuser I don't get the question anymore for the language but the Option button doesn't work anymore in the OWA.
    I can click the button, the page refreshes but stays at the mail screen.

    some extra command output :

    [PS] C:\>Get-Mailbox -Identity test2 | fl name, languages

    Name      : test2
    Languages : {}

    [PS] C:\>get-OwaVirtualDirectory -identity "Owa (Default Web Site)" |FL DefaultClientLanguage,LogonAndErrorLanguage

    DefaultClientLanguage : 1033
    LogonAndErrorLanguage : 1033

    Any ideas ?

    The Option button is still working for users I created before this setting.

    Wednesday, November 11, 2009 4:22 PM

All replies

  • When the new user goes to https://<servername>/ecp/ it's automaticly redirected to https://<servername>/owa/

    Any ideas ?

    Wednesday, November 11, 2009 9:22 PM
  • I opened a case with microsoft.
    Workarround :

    Set-OwaVirtualDirectory -identity "Owa (Default Web Site)" -DefaultClientLanguage 0 -LogonAndErrorLanguage 0

    Friday, November 13, 2009 4:31 PM
  • Confirmed as a bug, and it looks like its going to be fixed in SP1.
    Thursday, November 19, 2009 2:48 PM
  • Thanks for keeping us up to date! :)

    Brian Day, Overall Exchange & AD Geek
    MCSA 2000/2003, CCNA
    MCTS: Microsoft Exchange Server 2010 Configuration
    Thursday, November 19, 2009 2:54 PM
  • Do you know when we can expect Servie pack one.
    I have the same error and don't know how it was brought about since I did not touch the default Language settings at first,
     but then  I did try the work around and it did not get rid of my error.  Option button doesn't work in the OWA

    I did mess with ecp folder security to open it up but that did not work.

    Steve n
    Tuesday, January 26, 2010 4:09 PM
  • No microsoft support could not give a date for sp1.
    And they couldn't make a hotfix for this issue.
    Tuesday, January 26, 2010 4:29 PM
  • same problem here, your workaround works for me!

    This was a complete new installation of the total network (dc`s and everything)

    Monday, March 22, 2010 5:00 PM