BHOLD Organizationunits export error. "objectidentifier" is missing RRS feed

  • Question

  • trying to export organizationunits into the bhold core.

    Gettting export error "required objectidentifier is missing" on running export.

    Have followed the microsoft documentation but still facing issues.need help

    Thanks in advance


    Thursday, August 29, 2013 1:09 PM

All replies

  • In past BHOLD environments, at a minimum, I have set up the following export flows for OrgUnits:

    1. bholdDescription
    2. Parent

    During Provisioning all I set is the DN for the OrgUnit.  I hope that helps!

    Thursday, August 29, 2013 8:19 PM
  • Yes , i have set up those as my export flows.Can you elaborate on the "setting DN for the Orgunit" in the provisioning code


    Friday, August 30, 2013 4:51 AM
  • Can you also elaborate on the provisioning code as it will be helpful in comparing with my provisioning code.


    Friday, August 30, 2013 4:56 AM
  • Friday, August 30, 2013 7:33 AM
  • Yes, i have created my management agents and metaverse rules extension from Microsoft guides.




    Friday, August 30, 2013 9:38 AM
  • Do you use BHOLD SP1? I can confirm that organizational units are exported without errors when deployment follows those guides.
    Friday, August 30, 2013 12:17 PM
  • Yes we are using BHOLD sp1.But facing the issue on exporting OU objects.


    Friday, August 30, 2013 12:55 PM
  • Does your Metaverse object look something like this (you probably don't need orgID)?

    Can you export other object types (users)?

    Are you able to create OUs manully in the BHOLD Core?

    Friday, August 30, 2013 1:17 PM
  • Here is my provisioning code, which I believe is straight from the lab:

                Dim numberofConnectors As Integer
                Dim myMA As ConnectedMA = mventry.ConnectedMAs("BHOLD Orgunits")
                numberofConnectors = myMA.Connectors.Count
                If 0 = numberofConnectors Then
                    Dim obCS As CSEntry
                    obCS = myMA.Connectors.StartNewConnector("OrganizationalUnit")
                    Dim DN As ReferenceValue
                    DN = myMA.EscapeDNComponent(System.Guid.NewGuid().ToString)
                    obCS.DN = DN
                End If
            Catch ex As Exception
                Throw ex
            End Try
    Friday, August 30, 2013 10:50 PM
  • Yes , i am able to export other object types.

    Yes, i am able to manually create OUs in BHOLD core.

    And my metaverse object is exactly like the flow mentioned above.


    Monday, September 2, 2013 5:07 AM
  • Yes my provisioning code is exactly the same.


    Monday, September 2, 2013 5:08 AM
  • but still i am getting the error "cd error required attribute object identifier missing"


    Monday, September 2, 2013 5:13 AM
  • I am using C# for writing my provisioning code.


    Monday, September 2, 2013 5:25 AM
  • If you're using c# your code can't be _exactly_ same, because that is vb (you probably knew that, but just in case you didn't). Maybe you could just try to use the code above.

    Are you sure you have deployed the right dll? Are you able to debug (e.g. add a breakpoint and see that your code execute)?

    Monday, September 2, 2013 8:25 AM
  • yes i know C# code can't be exactly same with the vb.

    Yes i have tried on everything but in vain.

    Please suggest alternatives.


    Monday, September 2, 2013 9:29 AM
  • Do you have any other environment where you could test this? If not, you can try deconstruct your current BHOLD implementation and recreate it. Maybe even better idea would be to install an another test enviroment (you can use just one virtual machine). Whatever you choose, use test lab guides line by line and try to avoid any customizations.

    Test Lab Guide: Installing Forefront Identity Manager 2010 R2

    Test Lab Guide: BHOLD Access Management Connector

    Monday, September 9, 2013 6:52 AM
  • I'm seeing the same thing.  have you resolved it and if so can you share here?

    Paul N Smith

    Friday, October 11, 2013 6:09 PM
  • So I've been playing around and got the same issue. Had a issue that the bhold account needed full SQL access and local admin rights. Not 100% sure if this is required but the MS Lab is using administrator account for everything which is domain admins and Full SQL.

    Would be nice to get proper documentation.

    Going to play around and see what is required to make it work. only speculation at the moment.

    I also figured out there are required fields to create a user in BHOLD like displayname make sure you look at what fields are required.

    Again documentation would be nice here.

    Thursday, October 17, 2013 12:56 PM
  • Anyone ever figure this out?  I see two posts relevant to this error and neither one have an answer.  I tried to set the ObjectIdentifier in the attribute flow, but it comes back that the value is read only.  I haven't tried to set it in the MV extension code.  I suspect that's not going to work, either.


    Wednesday, February 18, 2015 7:49 PM
  • Ok.  I figured this out (as least for my implementation - who knows if this will work for someone else).

    I ended up throwing out the MV extension code and building the attribute flow as a sync rule in the FIM portal.  I mapped the OrgUnitName to the MV displayName, OrgUnitParent to a newly created ParentOU (reference) attribute in the MV.  Yes, I had to create the ParentOU attribute for the organization object in the MV.  And, I had to change the attribute in the MA for the parent ou from a string to a reference DN. 

    After those changes, I ran into the same "missing ObjectIdentifier" error.  So, I added an additional attribute mapping in the sync rule for dn to csObjectID.  After I did that, I was able to import the OU structure into the MV.

    The sync service recognized the BHOLD MA and the exports that were required.  An export of the BHOLD MA pushed the OUs out to BHOLD.  A subsequent BHOLD MA sync and import cleaned everything up. 

    I'm puzzled that the MV extension didn't set the csObjectId.  But, the documentation on this is scant and riddled with voodoo.  I have my suspicions that the code isn't complete.  Eventually, I'll figure that out.

    I based my solution on perusing through the configurations in the BHOLD virtual lab at:

    The lab is way too high level to be of much use, but it is good for looking at a somewhat functional environment.

    I hope this helps someone out.

    • Proposed as answer by Greg Wilkerson Thursday, February 19, 2015 9:32 PM
    Thursday, February 19, 2015 9:32 PM