none
BHOLD core install fails: Error 1720 CA_CoreProductGetWebsiteExists script error RRS feed

  • Question

  • Getting the following error after running the core install procedures.  I've confirmed each pre-requisite.  Installing as the BHOLD service account which has local admin and domain admin membership, also has sqladmin rights on the SQL server DB. 

    Product: Microsoft BHOLD Suite - Core -- Error 1720. There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor.  Custom action CA_CoreProductGetWebsiteExists script error -2147217389, :  Line 70, Column 1, 

    Some additional information.

    • Running latest version of Silverlight 5.1 (version 4 is mentioned in the guide)
    • I'm installing on the same server where FIM Portal/Service and the Sync engine reside, we have a SQL server on another machine that I'm pointing to during install.
    • Windows Internal DB (for portal) and FIM services are running.
    • I noticed Windows Installer keeps shutting off, but have run through the install attempt while it was running.  Same failed result.  I ran the Microsoft Fixit Utility to see if something broke with the installed, it reported that it did not find anything....perhaps that tool shut it off?

    Anyway, have the same result. Install fails with a Core Setup window stating.  There is a problem with this Windows Installer package.  A script required for this install to complete could not be run.  Call Bill, er Steve, for help.

    • Edited by Osho27 Tuesday, March 26, 2013 6:45 PM
    Tuesday, March 26, 2013 6:17 PM

All replies

  • Osho,

    Did you run this with verbose installer logging? If not run this command for next install attempt from elevated cmd prompt:

    MSIEXEC /install <BholdCore.MSI> /l*v <logfilename.log>

    This will hopefull show some additional details. Also, I would look at app log for this server as well.

    • Marked as answer by Osho27 Thursday, March 28, 2013 12:02 PM
    • Unmarked as answer by Osho27 Thursday, March 28, 2013 12:02 PM
    Wednesday, March 27, 2013 12:28 AM
  • Thanks Glenn.

    After I tried to running the install per your suggested method it installed without issue.  I'm sort of lost on what the issue was/is, I have not gone back to try it again.  But I'll call this a win for now.  Thanks for you help.

    Thursday, March 28, 2013 7:14 PM
  • Hey Osho,

    I have the same issue; Were you able to solve it?

    - Ronin


    I appreciate it very much if you vote my Replies as Helpful or Mark as Answer if I could help you out. Thanks!

    Tuesday, June 18, 2013 2:50 PM
  • Ronin,

    Do you have the same stack trace from MSI logfile? It would seem from function name that it is looking for IIS website, perhaps either service is not started or website has been secured with SSL?

    Wednesday, June 19, 2013 5:07 AM
  • HI

    I am getting this error too? Any idea what is the problem. I am installing BHOLD to an individual server. SQL and FIM are on the different server.

    Friday, September 18, 2015 11:02 AM
  • I resolved the problem installing all modules to IIS.
    • Proposed as answer by 2xTsei Monday, September 21, 2015 9:52 AM
    Monday, September 21, 2015 5:46 AM
  • A little late now, but in case anyone else gets this in future, I resolved by setting the PowerShell execution policy to Unrestricted
    Monday, January 30, 2017 11:48 AM