locked
External Email Disclaimer rule not working RRS feed

  • Question

  • I created a new Rule in my exchange server. The Disclaimer is just plain text thought I might pretty it up later with some HTML, but when I <g class="gr_ gr_135 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="135" id="135">recieve</g> emails from the outside the disclaimer is not being appended.
    Could someone tell me why the rule is not being applied?

    Jeremy Robertson Network Admin

    Friday, August 9, 2019 1:59 PM

Answers

All replies

  • Hi hotrodjeremy,

    Use the Get-TransportRule command to check the state and priority of transport rules. 

    Here is an article tells the detailed steps about HOW TO APPLY DISCLAIMER FOR THE EXTERNAL MAILS, check the steps in your configuration with this article.

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Regards,

    Joyce Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, August 12, 2019 3:13 AM
  • As you can see from the <g class="gr_ gr_42 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del" data-gr-id="42" id="42">screen shot</g> the priority is 0, But here is the output from the Get-TransportRule command.


    Jeremy Robertson Network Admin

    Monday, August 12, 2019 12:47 PM
  • Hi hotrodjeremy, 

    I have tried the same transport rule in my environment and it can work properly.

    So I want to confirm that whether the issue is related to the disclaimer text:

    Try to set the [sender is located inside the organization] or [change the disclaimer text] and verify the results.

    Regards,

    Joyce Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, August 13, 2019 8:10 AM
  • I have tried simple plain text "CAUTION: This E-mail originated outside of our organization. DO NOT click ANY links or open ANY attachments, unless you know the sender, and know the sender is safe. "

    I changed the rule from outside to inside <g class="gr_ gr_63 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar only-ins replaceWithoutSep" data-gr-id="63" id="63">organization</g> and still no luck.

    I even tried a single word disclaimer "CAUTION"


    Jeremy Robertson Network Admin

    Tuesday, August 13, 2019 12:53 PM
  • Hi hotrodjeremy, 

    Whether other transport rules in your environment take effect? 

    Check the transport agent in your environment with get-TransportAgent

    Also, try to restart “Microsoft exchange transport service”

    Regards,

    Joyce Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, August 14, 2019 5:49 AM
  • The create <g class="gr_ gr_13 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="13" id="13">helpdestticket</g> rule and large <g class="gr_ gr_27 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="27" id="27">attacment</g> rule seem to be working. 

    <g class="gr_ gr_80 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="80" id="80">Restrated</g> the transport service


    Jeremy Robertson Network Admin

    Wednesday, August 14, 2019 12:57 PM
  • Hi hotrodjeremy,

    According to the screenshot you provided above, the issue seems to be related to the BarExAv agent.

    Try to disable it or change the priority and verify the result again.

    Regards,

    Joyce Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Thursday, August 15, 2019 9:37 AM
  • I believe that is the baracudda Anti-Virus. How do I change the priority the transport agent to test?

    Jeremy Robertson Network Admin


    Thursday, August 15, 2019 12:55 PM
  • I was able to move the transport rule priority to 1 above the AV and still the disclaimer is not working.

    Jeremy Robertson Network Admin

    Thursday, August 15, 2019 2:39 PM
  • Hi hotrodjeremy,

    Try disabling the Barracuda Anti-virus and verify whether the issue is caused by this.

    Here is a similar case for your reference:

    Mailflow rule, outside of organization, going through a baracuda email filter

    Regards,

    Joyce Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Marked as answer by hotrodjeremy Friday, August 16, 2019 1:54 PM
    Friday, August 16, 2019 7:30 AM
  • You got it. Turns out that email since the email is passed through the spam filter to the exchange server, The exchange server thinks it is coming from inside the organization so the rule is never applied.

    If you have the barracuda cloud control, you can go to the inbound settings and the anti-phishing tab and turn on External Sender Warning. This will attach a warning to emails originating outside of the organization.

    It's not as customizable as exchange and HTML formatting is not possible but it does give you the disclaimer.

    Jeremy Robertson Network Admin

    Friday, August 16, 2019 1:54 PM