locked
Customizing the Portal Trunks RRS feed

  • Question

  • I'm trying to customize my UAG portal with company name and logos where applicable.

    I found this blog entry:
    http://blogs.technet.com/edgeaccessblog/archive/2009/11/26/customizing-the-portal.aspx
    and it has been VERY helpful.

    I have a total of 7 portal trunks configured on my UAG install and when you log into any one of them you get the customized "PortalHomePage".

    The problem is that only the FIRST trunk gets the customized "InternalSite" login page.

    The only changes I need to make are to the "Languages" folder and the en-US file, but doing this in a seemingly public location only affects my first trunk.

    If anyone could offer some assistance on getting the other login pages to use this custom config, or where to change their individual config files that would be great!  Thanks!

    Monday, January 25, 2010 3:37 PM

Answers

  • Hi Kfyhr
    When a bug is discovered, it might be fixed and included with a hotfix, an update, a service pack or a new release. The development teams decide on this based on various factors and considerations, none of which are public info. Please follow up on future UAG updates, hotfixes, SPs and releases - each would be accompanied with a release-notes document, and that would indicate which issues have been addressed with it.
    Ben Ari
    Microsoft CSS IAG Support
    Sammamish, WA
    • Marked as answer by Erez Benari Thursday, January 28, 2010 9:51 PM
    Thursday, January 28, 2010 9:51 PM

All replies

  • Has no one started to customize that has multiple portal trunks running?
    Wednesday, January 27, 2010 3:10 PM
  • Hello kfyhr--

    If you have multiple trunks then you need to name your files in a different format.  The following applies to .CSS, INC and even graphics.

    [TrunkName][0 or 1][FileName].[FileExtension]

    0 = Non SSL Trunk
    1 = SSL Trunk

    Lets say i have two SSL trunks called PortalOne and PortalTwo.  The file i want to make custom is office.css so that both trunks have a different color scheme.  I would name my files as follows:

    PortalOne1Office.css
    PortalTwo1Office.css

    Then activate your configuration for the first time and see the difference!.

    Thank you
    Dennis
    Wednesday, January 27, 2010 7:55 PM
  • kfyhr,

    I think you are on to something :)

    I was intrigued by the issue you encountered and gave it a test for myself, and indeed, the behavior is as you described. I’ll submit a bug for it.

    Thanks for discovering it!

    -Ran

    • Proposed as answer by superNaraen Tuesday, May 18, 2010 8:30 PM
    Thursday, January 28, 2010 2:33 PM
  • kfyhr,

    I think you are on to something :)

    I was intrigued by the issue you encountered and gave it a test for myself, and indeed, the behavior is as you described. I’ll submit a bug for it.

    Thanks for discovering it!

    -Ran


    Thanks, I was driving myself crazy looking for other language files that would specifiy to the other trunks ... how/when does a bug fix happen, as they occur? or fixes saved up and released as a service pack?
    Thursday, January 28, 2010 3:53 PM
  • Hi Kfyhr
    When a bug is discovered, it might be fixed and included with a hotfix, an update, a service pack or a new release. The development teams decide on this based on various factors and considerations, none of which are public info. Please follow up on future UAG updates, hotfixes, SPs and releases - each would be accompanied with a release-notes document, and that would indicate which issues have been addressed with it.
    Ben Ari
    Microsoft CSS IAG Support
    Sammamish, WA
    • Marked as answer by Erez Benari Thursday, January 28, 2010 9:51 PM
    Thursday, January 28, 2010 9:51 PM
  • Hi,

    Any progress on this issue - we are facing plenty UAG portal customization problems...the CustomUpdate folders and the Technet recommendations do not work, or they partly work. Even overwriting the original files has intermittent results between different trunks.

    Thanks

    Wednesday, June 9, 2010 5:14 PM
  • Has anyone tried to customize the images for multiple trunks, i cant find this to work?

    all the best

    Wednesday, July 7, 2010 8:05 AM
  • We hit the same problem - what is weird is that even if we overwrite the original files, it sometimes renders odd results.

    The inc files with custom text work like 70% of the time only across different trunks.

    Wednesday, July 7, 2010 10:02 AM
  • Yes, we got the same problem, the UpdateFOlder for Images, on the InternalSite, doesnt event work, we have to edit the original picture, if we put it in the update folder it doesnt work. Im starting to think that we are suppsed to edit a file in INC or something else.

    Wednesday, July 7, 2010 10:44 AM
  • Has this been fixed?  Using SP1 and it's not working.
    Tuesday, May 24, 2011 6:24 PM
  •  

    I'm also interested if there is a fix. In current case i have three portals translated in two languages and most of the time language files are working fine. And when they are not working i may get portal page different language than login page.

    -teemu


    br -teemu
    Thursday, September 22, 2011 5:51 PM
    • Proposed as answer by ZarkoC Thursday, September 22, 2011 6:51 PM
    Thursday, September 22, 2011 6:51 PM
  •  

    I think i've red that thread. I've customized images, logos and css files succesfully and they are working fine per logon page and portal page. My problem is language files which i have name like they should be named, portal1en-us.xml.

     

    Just wondering about this because most of the times language customizations are working fine. Then for some reason language customization is not working. Have you done language file customizations?

     

    -teemu

     

     


    br -teemu
    Thursday, September 22, 2011 7:59 PM