locked
Disable Proofing for Word 2013 via GPO RRS feed

  • Question

  • Hello All,

    First time posting a question here, found every answer to my questions for the past 7 years until now :)

    So, as mentioned in the Question line above I need to disable proofing for some network accounts in our domain. I work in a college and some of the students will need to take an exam under exam conditions using Word 2013. 

    We need all the Proofing options disabled (no spellcheck, auto-capitalisation etc.) - then the Proofing option has to be blocked (or greyed out) on the PC (incase they go to File>Options>Proofing and enable everything). 

    So, what have a I done so far? 

    1. Dowloaded the necessary ADM/ADMX files and imported them to GP Management
    2. Disabled all options under User Configuration>Policies>Administrative Templates>Microsoft Word 2013>Word Options>Proofing and >Autocorrect
    3. Then added loads of values to Disable Commands and Disable Shortcut Keys under User Configuration>Policies>Administrative Templates>Microsoft Word 2013>Disable Items in User Interface>Custom

    Disable Commands:
    2566 
    15780 
    9056 
    6111 
    12842 
    14453 
    4025 
    3997 
    3958 
    790 

    3217 
    2349 
    329 
    3219 
    2469 
    2788 
    11323 
    7343 
    7387 

    Disable shortcut keys:
    118 
    118,16 
    118,4 
    254 
    79,12 

    This works well with Office 2007 and 2010 - but not so much with 2013, so those using Office 2007 and Office 2010 this should be okay for you guys.

    Any help with getting this to work with Office 2013 will be very VERY appreciated.

    Many thanks in advance.

    Mehmet

    PS. Just incase, I'm trying to get this working within a Server 2012 R2 based environment with Windows 7 Pro x64 client machines.

        


    Wednesday, May 14, 2014 2:54 PM

Answers

  • Hi there Ethan,

    Thanks for your reply. The fault was with the GPO, I was testing it with a laptop (which has offline files enabled) so it would't apply the GPO properly. But now testing it with a PC and the GPO is applying, the options for spellcheck, define, thesaurus etc are all greyed out (they can't even go to file>options>proofing anymore on Word either)... 

    However, we still get the red squiggly line when a word is mis-spelt where they can right click and select the correct spelling. Although I disabled it all through User Configuration>Policies>Administrative Templates>Microsoft Word 2013>Word Options>Proofing and >Autocorrect. 

    Puzzled :-/

    Many thanks Ethan.
    Mehmet
    Friday, May 16, 2014 7:47 AM
  • Hi Mehmet,

    To stop that red squiggly line, you will need to uncheck the option of Check spelling as you type under FILE->Options->Proofing->When correcting spelling and grammar in Word

    However, seems this item is missing in Office Administrator Template, you might need to find out related registry key of that option, then disable it via GPO.

    Hope this helps.

    Thanks,

    Ethan Hua CHN
    TechNet Community Support

    Friday, May 23, 2014 10:10 AM
  • Hi Ethan,

    I blocked the Proofing options on the GPO, so I can't really go on File>Options>Proofing but I did create a registry key on the GPO and that just worked fine...

    For those who may need this in the future under User Configuration>Preferences>Windows Settings you'll find Registry, create a New Registry Item:

    Action: Create

    Hive: HKEY_CURRENT_USER

    Key Path: Software\Microsoft\Shared Tools\Proofing Tools\1.0\Office 

    Value Name: WordSpellingOptions

    Value Type: REG_DWORD

    Value Data: 0

    That does the trick.

    Many thanks again Ethan,

    Mehmet


    Friday, May 23, 2014 12:33 PM

All replies

  • Hi Mehmet,

    When you say "but not so much with 2013", do you mean the policy does not take effect at all on any client manchines, or just some of the commands didn't get disabled?

    I just tried few control IDs in you list, and they got disabled successfully in my Office 2013.

    If just some of the commands didn't get disabled, I would suggest to check in the latest control ID spreadsheet of Office 2013 to see if there is any update, though most of the Control IDs are the same in all versions of Office: http://www.microsoft.com/en-us/download/details.aspx?id=36798

    If the policy didn't take effect at all, then I would suggest you to check if you have deployed it correctly. Check if you have linked the policy to the correct OU.

    Hope this helps.

    Thanks,

    Ethan Hua CHN
    TechNet Community Support


    Thursday, May 15, 2014 7:28 AM
  • Hi there Ethan,

    Thanks for your reply. The fault was with the GPO, I was testing it with a laptop (which has offline files enabled) so it would't apply the GPO properly. But now testing it with a PC and the GPO is applying, the options for spellcheck, define, thesaurus etc are all greyed out (they can't even go to file>options>proofing anymore on Word either)... 

    However, we still get the red squiggly line when a word is mis-spelt where they can right click and select the correct spelling. Although I disabled it all through User Configuration>Policies>Administrative Templates>Microsoft Word 2013>Word Options>Proofing and >Autocorrect. 

    Puzzled :-/

    Many thanks Ethan.
    Mehmet
    Friday, May 16, 2014 7:47 AM
  • Hi Mehmet,

    To stop that red squiggly line, you will need to uncheck the option of Check spelling as you type under FILE->Options->Proofing->When correcting spelling and grammar in Word

    However, seems this item is missing in Office Administrator Template, you might need to find out related registry key of that option, then disable it via GPO.

    Hope this helps.

    Thanks,

    Ethan Hua CHN
    TechNet Community Support

    Friday, May 23, 2014 10:10 AM
  • Hi Ethan,

    I blocked the Proofing options on the GPO, so I can't really go on File>Options>Proofing but I did create a registry key on the GPO and that just worked fine...

    For those who may need this in the future under User Configuration>Preferences>Windows Settings you'll find Registry, create a New Registry Item:

    Action: Create

    Hive: HKEY_CURRENT_USER

    Key Path: Software\Microsoft\Shared Tools\Proofing Tools\1.0\Office 

    Value Name: WordSpellingOptions

    Value Type: REG_DWORD

    Value Data: 0

    That does the trick.

    Many thanks again Ethan,

    Mehmet


    Friday, May 23, 2014 12:33 PM