none
DPM doesn't free un-allocated space RRS feed

  • Question

  • Hello,

     I am using DPM2012 but having issue related to Storage pool. 18 TB DAS attached with DPM server but all space are full and now 1% unallocated space available. To reclaim space, I stop protection for all VM's under 1 protection group which size was around 1.5 TB and created new PG and added all those VM's in this new PG but now the method of backup this protection group directly going to tape and not using disk space. Once full backup done on tape by using this new PG, I tried to delete those VM's which were sitting on inactive protection but after deletion few VM's from there still no change on unallocated space.

    Kindly let me know any relevant solution for it as I am running out of space and I really need to add few more servers.

    Thanks

    Asim J

    Tuesday, May 6, 2014 5:47 PM

All replies

  • Hi,

    The Issue is that the VM's were most likely co-located on one or more replica volumes.  Each VM would be in a separate folder on the replica.  If you had multiple replica volume some VM's would be on one replica and other VM's on a different replica.  By deleting "some" VM's, DPM is just deleting the space on the replica for the VM's you deleted. If just one VM is on a replica, then DPM cannot free that replica and recovery point volumes.   You will need remove all VM's that are co-located on the same replica before DPM will delete the volumes and have it show up as available space I the storage pool.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.


    Tuesday, May 6, 2014 9:03 PM
    Moderator