none
CNAME an alias to a DNS that should resolve via wildcard does not work on Windows RRS feed

  • Question

  • We have a few subdomains: abc.dev and a.dev

    We have a wildcard *.abc.dev

    A CNAME was created as test.a.dev => test.abc.dev

    A DNS lookup against test.abc.dev will resolve just fine however, trying to resolve test.a.dev will not resolve. Linux/Mac will resolve test.a.dev but not on the Windows platform. Keep in mind test.abc.dev is resolving simply due to the wildcard DNS we have configured.

    Any thoughts on creating an alias to a DNS that is not hard coded into Microsoft DNS but should be resolvable due to the wildcard DNS?



    • Edited by mgpspr Thursday, February 4, 2016 4:49 PM
    Thursday, February 4, 2016 4:32 PM

Answers

  • Hi mgpspr ,

     

                 Can you post the  environment or configuration of your WINDOWS platform, it can help us to analyze the issue. Or you could run NSlookup to  test.a.dev  in debug mode, see where the chain breaks down.

                

               By the way, are you using AD-integrated Zone? I did run into this sort of case  , you should set the first DNS server to primary non-active directory, set the second DNS server to secondary non-active directory. Then after syncing the domain/GC controllers, after that I enabled Active directory stored zones on the first DNS server and then the second DNS server.

     

     

              Best Regards,

    Cartman


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, February 5, 2016 5:20 AM