locked
Error accessing page in book through Web Standard RRS feed

  • Question

  • I get the following error while I click on the Book name in web standard. I am a member of PAS with admin role.

     

    Error:

     

    Event Type: Error
    Event Source: ProClarity Server
    Event Category: None
    Event ID: 4
    Date:  8/29/2008
    Time:  9:49:07 AM
    User:  domain\user
    Computer: <XXXXX>
    Description:
    Error when accessing page "Detail Report" ({F695084C-9DEE-4862-8424-0847C037E3B2})
    from book "Cube Book" ({A1BEB439-F455-404F-A2D2-31B71FDE26D9})

    Cache File Name:  (unknown)

    Call Stack:

    Location: line #1195 of file PRepository.cpp
     - Error-code: (0x18), Error-number: 0x80070005
     - Error opening file for writing

    Location: line #448 of file PRepository.cpp
     - Error-code: (0x18), Error-number: 0x80070005
     - ResolveBookAndPage()


     

     

    Friday, August 29, 2008 5:16 PM

All replies

  • Try adding the Everyone group and your specific user account to NTFS permissions on wwwroot\PAS.  Give full permissions and push them down to the child objects and retest.

    Please let us know the results of this NTFS test.

     

    Thanks,

     

    -Joey

    Friday, August 29, 2008 9:14 PM
  • Trying Everyone worked.

    But how do I setup  a permission model. I don't want Everyone seeing this information.

     

    • Proposed as answer by elenat Friday, September 18, 2009 2:39 PM
    Tuesday, September 2, 2008 5:47 PM
  • I would now try removing the everyone group and check if it still works.  If so, problem solved.  If not, you could consider making a group of PAS users and assigning that group NTFS permissions to the folder.

     

    Also, since there is no network share permissions to this folder, it should be safe to allow NTFS permissions since users cannot access without network share permissions.

     

    This should secure your PAS cache files.  Make sure you use PAS security in the Admin Tool and cube security in SSAS to security your data.

     

    -Joey

     

    Wednesday, September 3, 2008 4:55 PM
  • Hi Joey,

    Here are the steps I followed and did iisrest generously,

    • Removed Everyone from wwwroot/PAS and child nodes
    • Tested and found the issue is back again
    • MyComputer --> Manage --> Local Users and Groups --> Groups
    • Created a group - PAS Users
    • Added myself to the newly created PAS Users
    • Added PAS Users to wwwroot/PAS and child nodes
    • Tested and found the issue is not resolved
    • If I try Everyone, then the issue is resolved

    Let me know if I am missing something.

    Thanks

    modaz

    Wednesday, September 3, 2008 8:56 PM
  • This post lists the NTFS permissions needed for PAS users on the web server.

     

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3242820&SiteID=17

     

    The only other step you could take is to be sure users are being authenticated to the web server with their windows account.  For instance, is the PAS virtual directory set to anonymous authentication perhaps?  At the PAS home page, do you see the correct windows account in the left hand pane?

    Friday, September 5, 2008 12:06 AM
  • Hi Guys,

    I have similar issue. I am (Admin) able to access the book but other users (Read Permission) not able to acess the book and getting below error (Which I found from ProClarity Server Event viewer).

    Error when accessing page "ProClarity_Book1" ({98CBBA81-2838-48AC-9F85-7CCB51BDDC03})
    from book "{AAAC0822-3302-4c01-8ADD-1FBA1C0CCF6C}S-1-5-21-665406565-2853157457-2341909388-899017" ({7B7253EB-3476-4C8C-90BE-6D3F8B7A1FA9})

    Cache File Name:  (unknown)

    Call Stack:

    Location: line #14830 of file QueryImpl.cpp
     - Error-code: (0x1a), Error-number: 0x80130006
     - 
    ** The maximum size of the message buffer (32K) has been exceeded.

    Could you please guide me in resolving this.


    Thanks Shiven:) If Answer is Helpful, Please Vote

    Tuesday, April 8, 2014 11:38 PM