locked
Unable to deploy client RRS feed

  • Question

  • Afternoon, 

    I have recently built SCCM2012r2 and done a migration from our current 2007 deployment.  All Status components are checked and OK however when deploying the client from SCCM2012r2 I recive the following error in the ccm.log "---> Mobile client on the target machine has a newer version. Not processing this CCR~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:26.118-60><thread=5672 (0x1628)>"

    If I use the ccmclean.exe tool and then install the client it works but this isn't practical to run on each PC. When deploying the client I have selected the "Always install the client software" & "Uninstall existing Configuration Manager client before the client is installed"

     ccm.log:

    Execute query exec [sp_CP_GetNewPushMachines] N'DHS'~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.669-60><thread=2264 (0x8D8)>
    Execute query exec [sp_CP_SetPushRequestMachineStatus] 2097152332, 1~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.671-60><thread=2264 (0x8D8)>
    Execute query exec [sp_CP_GetPushRequestMachine] 2097152332~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.794-60><thread=2264 (0x8D8)>
    Successfully retrieved information for machine ICT-SI from DB  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.795-60><thread=2264 (0x8D8)>
    Execute query exec [sp_CP_GetPushRequestMachineIP] 2097152332~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.795-60><thread=2264 (0x8D8)>
    Execute query exec [sp_CP_GetPushRequestMachineResource] 2097152332~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.803-60><thread=2264 (0x8D8)>
    Execute query exec [sp_CP_GetPushMachineName] 2097152332~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.804-60><thread=2264 (0x8D8)>
    Received request: "2097152332" for machine name: "ICT-SI" on queue: "Incoming".  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.804-60><thread=2264 (0x8D8)>
    Stored request "2097152332", machine name "ICT-SI", in queue "Processing".  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.804-60><thread=2264 (0x8D8)>
    Execute query exec [sp_CP_SetPushRequestMachineStatus] 2097152332, 1~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.805-60><thread=2264 (0x8D8)>
    ======>Begin Processing request: "2097152332", machine name: "ICT-SI"  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.807-60><thread=5672 (0x1628)>
    Execute query exec [sp_IsMPAvailable] N'DHS'~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.808-60><thread=5672 (0x1628)>
    ---> Trying each entry in the SMS Client Remote Installation account list~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.808-60><thread=5672 (0x1628)>
    ---> Attempting to connect to administrative share '\\ICT-SI\admin$' using account 'CLASS\sccmadmin'~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.808-60><thread=5672 (0x1628)>
    ---> Connected to administrative share on machine ICT-SI using account 'CLASS\sccmadmin'~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.862-60><thread=5672 (0x1628)>
    ---> Attempting to make IPC connection to share <\\ICT-SI\IPC$> ~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.863-60><thread=5672 (0x1628)>
    ---> Searching for SMSClientInstall.* under '\\ICT-SI\admin$\'~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:25.866-60><thread=5672 (0x1628)>
    ---> System OS version string "10.0.10586" converted to 10.00  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:26.088-60><thread=5672 (0x1628)>
    ---> Mobile client on the target machine has a newer version. Not processing this CCR~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:26.118-60><thread=5672 (0x1628)>
    ---> Deleting SMS Client Install Lock File '\\ICT-SI\admin$\SMSClientInstall.DHS'~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:26.118-60><thread=5672 (0x1628)>
    Execute query exec [sp_CP_SetLastErrorCode] 2097152332, 120~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:26.124-60><thread=5672 (0x1628)>
    ---> Skipped request "2097152332", machine name "ICT-SI".  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:26.126-60><thread=5672 (0x1628)>
    Deleted request "2097152332", machine name "ICT-SI"  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:26.126-60><thread=5672 (0x1628)>
    Execute query exec [sp_CP_SetPushRequestMachineStatus] 2097152332, 3~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:26.127-60><thread=5672 (0x1628)>
    Execute query exec [sp_CP_SetLatest] 2097152332, N'07/31/2017 14:13:26', 1~  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:26.129-60><thread=5672 (0x1628)>
    <======End request: "2097152332", machine name: "ICT-SI".  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:26.131-60><thread=5672 (0x1628)>
    Submitted request successfully  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:27.830-60><thread=2264 (0x8D8)>
    Getting a new request from queue "Incoming" after 100 millisecond delay.  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:27.831-60><thread=2264 (0x8D8)>
    Waiting for change in directory "E:\SCCM files\inboxes\ccr.box" for queue "Incoming", (30 minute backup timeout).  $$<SMS_CLIENT_CONFIG_MANAGER><07-31-2017 15:13:27.831-60><thread=2264 (0x8D8)>



    • Edited by JamesSalmond Monday, July 31, 2017 2:47 PM added ccm.log
    Monday, July 31, 2017 2:33 PM

Answers

  • First note that ConfigMgr 2012R2 doesn't support Windows 10 so what you are doing above is not supported anyway. If this is a brand new site, you really should be running ConfigMgr Current Branch.

    What client version exactly is the system running and how did it get there though?

    Are you using manual push or automatic push?


    Jason | http://blog.configmgrftw.com | @jasonsandys

    • Marked as answer by JamesSalmond Monday, July 31, 2017 8:04 PM
    Monday, July 31, 2017 3:56 PM

All replies

  • First note that ConfigMgr 2012R2 doesn't support Windows 10 so what you are doing above is not supported anyway. If this is a brand new site, you really should be running ConfigMgr Current Branch.

    What client version exactly is the system running and how did it get there though?

    Are you using manual push or automatic push?


    Jason | http://blog.configmgrftw.com | @jasonsandys

    • Marked as answer by JamesSalmond Monday, July 31, 2017 8:04 PM
    Monday, July 31, 2017 3:56 PM
  • I'm fairly new to SCCM so thank you Jason for the information and quick response . 

    As our environment is fully windows 10 Education and server 2012r2 I will follow your recommendation and move to ConfigMgr Current Branch which is available under our software assurance. 

    Regards

    James 

    Monday, July 31, 2017 8:04 PM