none
Windows Server 2008 Proxy settings issue

    Question

  • Background. 

    The company I work for has several Branches with different Proxy settings. The company has employees travel between branches for one reason or another, usually just for a day or so. Normally we would have to manually set the IE settings for each user whenever they moved from branch to branch. Each branch has its own OU where the users and computers are stored.

    I am looking to set up an Automatic Proxy setting based on computer rather than user, through group policy.

    What I have found in research and tried to do:

    Using this site and others as a guide:

    http://wiki.ledhed.net/index.php?title=Set_Proxy_Server_with_Group_Policy

    Through some research I found the easiest way to do this is with a GP registry edit, created a new GPO, computer configuration-> preferences->registry:

    Action: Update
    Hive: HKEY_LOCAL_MACHINE
    Key Path: SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    Value Name: ProxyEnable
    Default: Unchecked
    Value Type: REG_DWORD
    Value Data: 00000001
    Base: Hexadecimal

    Now we will create 2 more registry items.

    Action: Create
    Hive: HKEY_LOCAL_MACHINE
    Key Path: SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    Value Name: ProxyOverride
    Default: Unchecked
    Value Type: REG_SZ
    Value Data: <local> our sites

    and

    Action: Update
    Hive: HKEY_LOCAL_MACHINE
    Key Path: SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    Value Name: ProxyServer
    Default: Unchecked
    Value Type: REG_SZ
    Value Data: our info

    I Then went to policies-> admin templetes-> windows Components-> IE ->Make proxy settings per-machine (rather than per-user) set enable

    The ISSUE im having is the proxy settings will not change on the target computer. I can go through the regedit and see them in there, but it won’t take effect. It is the only GPO “link Enabled” in the OU that effect the IE settings.

    Idk if it will matter the server IE is IE 9 and the client is IE 11

    Server info

    Windows server 2008 64bit

    Client info

    Windows 7 pro 64bit

    if you need any more information let me know ill try to provide what i can 

    Thursday, May 28, 2015 4:31 PM

Answers

All replies

  • so to summarise you can see the proxy settings in the registry but not when you open inetcpl.cpl?
    Thursday, May 28, 2015 5:00 PM
  • yeah thats correct, i do not see any changes inetcpl.cpl

    in regedit i am looking in:  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    Thursday, May 28, 2015 5:19 PM
  • can you post a gpresult?

    Thursday, May 28, 2015 6:01 PM
  • I have to wait for my account o be verified before I can post the image. if you have an email I can send it that would be great other wise I just have to wait
    Thursday, May 28, 2015 6:53 PM
  • don't worry just tested this those settings above dont work, i have only ever done this per user.
    Thursday, May 28, 2015 7:35 PM
  • humm ok, is there any way to do it by computer. the one issue is the domain controller doesnt use the proxy server, so i cant just replicate that and push it out
    Thursday, May 28, 2015 8:12 PM
  • for a split second i though this might have something to do with wow6342 turns out it doesn't .. hmmmmmmm
    Thursday, May 28, 2015 8:51 PM
  • I don't know if this is just a graphical oddity I could of sworn I'd set this in the registry prior and it showed in Internet options. Sure one of the MVPS will clear this up.
    Thursday, May 28, 2015 9:21 PM
  • > I Then went to policies-> admin templetes-> windows Components-> IE
    > ->Make proxy settings per-machine (rather than per-user) set enable
     
    This is a setting that does NOT work as you would think...
     
     

    Greetings/Grüße, Martin

    Mal ein gutes Buch über GPOs lesen?
    Good or bad GPOs? - my blog…
    And if IT bothers me - coke bottle design refreshment (-:
    Friday, May 29, 2015 9:46 AM
  • I knew it was possible per user the thing that bugged me was that their is a setting which doesnt seem to do anything. Not that i need it but whats all this about martin >Make proxy settings per-machine (rather than per-user) set enable

    should it just be disregarded?

    Thanks

    Friday, May 29, 2015 10:06 AM