none
Guidance on Post OS Task Sequence on Windows 8.1 with reboots? RRS feed

  • Question

  • Hello,

    We are trying to come up with a deployment solution for our Surface Pro devices, and would like to utilize the Post OS task sequence templates in MDT 2013.

    We have plenty of experience with bare metal deployments, but none with these Post OS task sequences, and there are a few questions we have.

    1. MDT is designed to be used with the built in Administrator account. This appears to be disabled in Windows 8.1. Do we just re-enable it so MDT will work?
    2. Along those same lines, we noticed that if the task sequence reboots (because of a Recover from Domain step), it will not auto login as Administrator and finish the task sequence. Do we have to make the Administrator account auto login ourselves via a script or something?

    What is the "right way" to run these Post OS Task Sequences on Windows 8.1? Specifically to run a domain join and resume after reboot?

    Thanks!

    Tuesday, April 21, 2015 6:27 PM

Answers

  • 1. Enable the built in Administrator account.

    2. Autologin is configured via the unattend which is why it works in bare metal. However you can configure autologon by editing the registry.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, April 21, 2015 8:23 PM
    Moderator
  • Thanks for the reply, Ty.

    Here is how I solved this particular issue. This is just one way of doing it, not saying it's the best way.

    1. Made a copy of ZTIDomainJoin.wsf and named it MyDomainJoinNoReboots.wsf
    2. Commented out lines 189 and 190 (I think!) that called for the reboot
    3. Disabled the 'recover from domain' step and inserted a new 'Run Command Line' step that references my new MyDomainJoinNoReboots.wsf file

    This doesn't solve the issue of auto logging in the administrator accout, but doing it this way means I don't have to, since my TS never reboots, until the deployment is complete and the FinishAction reboots the system.

    • Marked as answer by David Bloomer Wednesday, April 22, 2015 9:57 PM
    Wednesday, April 22, 2015 9:57 PM

All replies

  • 1. Enable the built in Administrator account.

    2. Autologin is configured via the unattend which is why it works in bare metal. However you can configure autologon by editing the registry.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, April 21, 2015 8:23 PM
    Moderator
  • Thanks for the reply, Ty.

    Here is how I solved this particular issue. This is just one way of doing it, not saying it's the best way.

    1. Made a copy of ZTIDomainJoin.wsf and named it MyDomainJoinNoReboots.wsf
    2. Commented out lines 189 and 190 (I think!) that called for the reboot
    3. Disabled the 'recover from domain' step and inserted a new 'Run Command Line' step that references my new MyDomainJoinNoReboots.wsf file

    This doesn't solve the issue of auto logging in the administrator accout, but doing it this way means I don't have to, since my TS never reboots, until the deployment is complete and the FinishAction reboots the system.

    • Marked as answer by David Bloomer Wednesday, April 22, 2015 9:57 PM
    Wednesday, April 22, 2015 9:57 PM