locked
Powershell script to add users/mailbox doesn't set proper permissions RRS feed

  • Question

  • I am using a ps script very similar to the one found here

    Simply, I am setting this up so our helpdesk users can create accounts through a prompted script. The script works perfectly, except for one thing. It sets the permissions on the mailbox ONLY for:

    NT AUTHORITY\SELF

    The mailbox permissions should be set with the following instead:

    DOMAIN\Exchange Domain Servers

    DOMAIN\Exchange Servers

    DOMAIN\Exchange Services

    DOMAIN\Exchange Trusted Subsystem

    NT AUTHORITY\SELF

    NT AUTHORITY\SYSTEM

    I am running the script in the EMS as an exchange administrator. Any ideas on why this script won't set the full permissions on new mailboxes? Any help would be greatly appreciated.

    Thank You,

    David

    Thursday, July 17, 2014 2:24 PM

Answers

All replies

  • Hi David,

    Actually, we have a dedicated support team regarding the Microsoft Scripts. I recommend you ask your question on our Microsoft Scripts forum which is staffed by more experts specializing in this kind of problems. Thanks for your understanding.

    For your convenience:

    http://social.technet.microsoft.com/Forums/scriptcenter/en-US/home?forum=ITCG

    Hope it helps.

    Best regards,

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Amy Wang
    TechNet Community Support

    Friday, July 18, 2014 2:48 AM
    Moderator
  • Hi David,

    Have you asked your issue on our Script forum?

    Is there any update with your issue?

    Best regards,

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Amy Wang
    TechNet Community Support

    Monday, July 21, 2014 1:46 AM
    Moderator
  • I've posted this in the scripting forum instead. You can remove this post from here. Thanks Amy.
    Tuesday, July 22, 2014 10:21 PM