locked
svchost.exe(netsvcs) causes disk endless running... RRS feed

  • Question

  • Yesterday my HDD was busy running for 20 or more minutes. So I took a look at Resource Moniter, it show "svchost.exe(netsvcs)" is keep writing something and I wait for another 10 minutes but no luck.

    After reboot it not happen again. I guess this related to Windows Update (Patch Tuesday?), any suggestions?
    Thursday, September 10, 2009 3:26 AM

Answers

  • Hi,

    Have you checked in Event Viewer? Is there any error message related in the event of service crashing? If the issue occurs again, please try to use Resource Monitor to suspend svchost.exe(netsvcs) and manually stop Windows Update Service, then resume svchost.exe(netsvcs) to see if it works. This would help us identify if it is related to Windows Update.

    Best Regards.
    Dale Qiao
    Friday, September 11, 2009 7:37 AM

All replies

  • Hi,

    Have you checked in Event Viewer? Is there any error message related in the event of service crashing? If the issue occurs again, please try to use Resource Monitor to suspend svchost.exe(netsvcs) and manually stop Windows Update Service, then resume svchost.exe(netsvcs) to see if it works. This would help us identify if it is related to Windows Update.

    Best Regards.
    Dale Qiao
    Friday, September 11, 2009 7:37 AM
  • Dale, thanks for your reply.

    I checked Event Viewer and found a WindowsUpdateFailure event about download failure.

    The event was send to MS via Windows Error Reporting, here is some info
    P1: 7.3.7600.16385
    P2: 80246002
    P3: 06C812C5-2087-4EB6-907A-01B0CC6BA828
    P4: Download
    P5: 101
    P6: Unmanaged
    P7:
    P8:
    P9:
    P10:

    I'll try to re-start Windows Update Service if it happen again.

    Friday, September 11, 2009 5:22 PM
  • Hi,

    What is the name of the failed downloading update? Please look into "View update history" to see the failed update and note its KB number, if there is any failed update, you can perform a System Restore to the previous time before installing updates then manually download the update from Microsoft Update Catalog.

    Best Regards.
    Dale Qiao
    Monday, September 14, 2009 2:11 AM
  • Hi,

    What is the name of the failed downloading update? Please look into "View update history" to see the failed update and note its KB number, if there is any failed update, you can perform a System Restore to the previous time before installing updates then manually download the update from Microsoft Update Catalog.

    Best Regards.
    Dale Qiao

    The failed downloading update is KB890830, Malicious Software Removal Tool.
    It was downloaded and installed successfully after reboot, so I think this case was accidental.
    Monday, September 14, 2009 2:59 PM
  • Hi,

    So the issue isn't occuring now, is it right? If the issue appears again, please respond back and let us know.

    Best Regards.
    Dale Qiao
    Tuesday, September 15, 2009 2:47 AM
  • Its the "Background Intelligent Transfer Service" (svchost.exe -k netsvcs) which is eating up your bandwidth. In order to sort your bug just

    1.Go to the "Services"

    2.Right Click on "Background Intelligent Transfer Service" and select "Properties".

    3.you can "Stop" the Service from there. 

    4.And in order to prevent this service from starting again, you can select "Manual" as its "Startup type"

    In order to open "Services"....Right Click on "My Computer"....then Select "Manage".....then click on "Services and Applications" displayed on left-hand side list......then select "Services".

    This was all,I think this is gonna help u. Good Luck!!

    • Proposed as answer by atul.21j Sunday, August 19, 2012 6:28 AM
    Sunday, August 19, 2012 6:28 AM
  • Yesterday my HDD was busy running for 20 or more minutes. So I took a look at Resource Moniter, it show "svchost.exe(netsvcs)" is keep writing something and I wait for another 10 minutes but no luck.

    After reboot it not happen again. I guess this related to Windows Update (Patch Tuesday?), any suggestions?

    I have been getting this since I got my computer since 2011. But I had this happen the year after I got my computer.

    Tuesday, January 26, 2016 1:26 PM
  • Hi, just so you can be aware, this problem is an ongoing one for me as well, the only difference is I am running win10 as the OS.

    To me, as of today, 23/9/2019 Microsoft has not "fixed" this issue on a permanent basis.

    I believe this: svhost-diskdefragmenter CONSTANTLY RUNNING!!! on my computer is caused by a corrupted file/code (?) and even doing a "re-install" of win10 DOES NOT SOLVE THIS ISSUE !!! High cpu/memory/disk results from this and also  inability to "change the settings" from weekly to monthly cannot be performed!!!

    This, to me, is a problem created by Microsoft and foisted on the everyday home computer user!!!BTW, Microsoft "Remote" Support cannot fix this either, I know this for fact, because a complete re-install was performed AFTER I allowed the "Microsoft Remote Support" "person (?)" access to my computer , who then performed a "variety of checks (?)" to ensure there was no "virus infection" causing this issue.

    I have tried to "report' this issue to Microsoft at least 2-3 x and to this day, September 23, 2019, have gotten absolutely no feedback "Inquiry" whatsoever, but, I did get an email asking about the "Microsoft Support Experience" and I did give credit to the agent who "helped" me with this issue, sadly, as the saying goes, "The More Things Change, The More They Remain The same"....how true. BTW, Microsoft, your latest CU states "it does address the issue of high cpu usage" But in my case, you are Wrong!! I am open to hearing from you Microsoft, btw, but my faith in this is low. Have a lovely day. Signed: R.G. ….23/9/19 @ 3.25 Pm  EST

    Monday, September 23, 2019 7:25 PM