none
FIM2010 - Adding more values to the "EmployeeType" dropdown RRS feed

  • Question

  • Hi,

    I have a requirement to add around 20 values to the EmployeeType dropdown. Because the number is quite large, I couldn't provide the values in the validation part of the attribute. Any pointers on how to add these values to the dropdown.

    Regards

    Sai

    Tuesday, October 2, 2012 1:25 PM

Answers

  • There are a couple of options, including hard-coding values in the RCDC xml itself (see the guide), however the best one by far is to create a custom resource type of "EmployeeType", create your 20 values as instances of this resource type, and then use a UocIdentityPicker with a Filter property referencing your custom attribute.

    If you don't like the look-and-feel of this control type, maybe try a UocListView control instead with EnableSelection set to true.


    Bob Bradley (FIMBob @ TheFIMTeam.com) ... now using Event Broker 3.0 for just-in-time delivery of FIM 2010 policy via the sync engine, and continuous compliance for FIM


    • Edited by UNIFYBobMVP Tuesday, October 2, 2012 1:56 PM
    • Marked as answer by saikiran159 Thursday, October 4, 2012 4:07 AM
    Tuesday, October 2, 2012 1:54 PM
  • Looks OK - have you done an IISRESET on your FIM web server?  All UI-related changes will only appear after you do this.

    Bob Bradley (FIMBob @ TheFIMTeam.com) ... now using Event Broker 3.0 for just-in-time delivery of FIM 2010 policy via the sync engine, and continuous compliance for FIM

    • Marked as answer by saikiran159 Thursday, October 4, 2012 4:07 AM
    Thursday, October 4, 2012 3:45 AM

All replies

  • There are a couple of options, including hard-coding values in the RCDC xml itself (see the guide), however the best one by far is to create a custom resource type of "EmployeeType", create your 20 values as instances of this resource type, and then use a UocIdentityPicker with a Filter property referencing your custom attribute.

    If you don't like the look-and-feel of this control type, maybe try a UocListView control instead with EnableSelection set to true.


    Bob Bradley (FIMBob @ TheFIMTeam.com) ... now using Event Broker 3.0 for just-in-time delivery of FIM 2010 policy via the sync engine, and continuous compliance for FIM


    • Edited by UNIFYBobMVP Tuesday, October 2, 2012 1:56 PM
    • Marked as answer by saikiran159 Thursday, October 4, 2012 4:07 AM
    Tuesday, October 2, 2012 1:54 PM
  • I'll second Bob recomndation of a custom Resource type. I've used this in most every production project I've done. It's even more compelling if there's an authorative source of EmployeeType values you can use the sync service to keep your list of Employee Types current. And if the list needs to be manually maintained, you can create MPRs that can be used to delegate admin rights to that resource to someone else who can maintain the list for you.

    Frank C. Drewes III - Architect - Oxford Computer Group

    Wednesday, October 3, 2012 4:32 AM
  • Hi, 

    Thanks for your responses.

    I chose to add "Xmldatasource" in the rcdc config file and did the modifications, but I couldnt see the values in the "EmployeeType" tab.

    Not sure, where I am doing the mistake. Correct me if I have done any thing wrong.

    Here is my rcdc for creation of users.

    Added "Xmldatasource" before the panel node.

    <my:XmlDataSource my:Name="EmployeeTypeValues">
    <EmployeeTypeValues>
    <EmployeeTypeCode Code="" Name="" />
    <EmployeeTypeCode Code="US Employee" Name="US Employee" />
    <EmployeeTypeCode Code="LCN Employee" Name="LCN Employee" />
    <EmployeeTypeCode Code="Contractor" Name="Contractor" />
    <EmployeeTypeCode Code="US Employee Telecommuter" Name="US Employee Telecommuter" />
    </EmployeeTypeValues>
    </my:XmlDataSource>

    And modified the "EmployeeType" node to the following.

    <my:Control my:Name="EmployeeType" my:TypeName="UocDropDownList" my:Caption="{Binding Source=schema, Path=EmployeeType.DisplayName}" my:Description="{Binding Source=schema, Path=EmployeeType.Description}">
            <my:Properties>
              <my:Property my:Name="Required" my:Value="{Binding Source=schema, Path=EmployeeType.Required}"/>
              <my:Property my:Name="ValuePath" my:Value="@Name"/>
              <my:Property my:Name="CaptionPath" my:Value="@Code"/>
              <my:Property my:Name="HintPath" my:Value="@Name"/>
              <my:Property my:Name="ItemSource" my:Value="{Binding Source=EmployeeTypeValues, Path=/EmployeeTypeValues/*}"/>
              <my:Property my:Name="SelectedValue" my:Value="{Binding Source=object, Path=EmployeeType, Mode=TwoWay}"/>
            </my:Properties>
          </my:Control>

    After doing the changes, I have bounced both FIM and FIMSynch services.

    Regards

    Sai

    Thursday, October 4, 2012 3:01 AM
  • Nope - you need to have another look at http://technet.microsoft.com/en-us/library/ee534918(WS.10).aspx and search for the section starting with "This code segment generates the drop-down list:".  In there you will see how you need to have your xml nodeset declared using <my:Options>...</my:Options> and your ItemSource property node declared instead as <my:Property my:Name="ItemSource" my:Value="Custom" />.

    Bob Bradley (FIMBob @ TheFIMTeam.com) ... now using Event Broker 3.0 for just-in-time delivery of FIM 2010 policy via the sync engine, and continuous compliance for FIM

    • Proposed as answer by UNIFYBobMVP Thursday, October 4, 2012 3:12 AM
    Thursday, October 4, 2012 3:12 AM
  • I have followed the one I have mentioned , based on how country is setup in FIM portal.

    Will give a try with the "Options" approach aswell.

    Regards

    Sai

    Thursday, October 4, 2012 3:21 AM
  • Hi,

    I have removed  the "XmlDatasource" and modified EmployeeType control to the below mentioned. But still, I am getting a blank dropdown.

     <my:Control my:Name="EmployeeType" my:TypeName="UocDropDownList" my:Caption="{Binding Source=schema, Path=EmployeeType.DisplayName}" my:Description="{Binding Source=schema, Path=EmployeeType.Description}">
     <my:Options>
    <my:Option my:Value="US Employee" my:Caption="US Employee" my:Hint="US Employee"/>
    <my:Option my:Value="LCN Employee" my:Caption="LCN Employee" my:Hint="LCN Employee"/>
    <my:Option my:Value="Contractor" my:Caption="Contractor" my:Hint="Contractor"/>
    </my:Options>
            <my:Properties>
              <my:Property my:Name="Required" my:Value="{Binding Source=schema, Path=EmployeeType.Required}"/>
              <my:Property my:Name="ValuePath" my:Value="Value"/>
              <my:Property my:Name="CaptionPath" my:Value="Caption"/>
              <my:Property my:Name="HintPath" my:Value="Hint"/>
              <my:Property my:Name="ItemSource" my:Value="Custom"/>
              <my:Property my:Name="SelectedValue" my:Value="{Binding Source=object, Path=EmployeeType, Mode=TwoWay}"/>
            </my:Properties>
          </my:Control>

    Regards

    Sai

    Thursday, October 4, 2012 3:29 AM
  • Looks OK - have you done an IISRESET on your FIM web server?  All UI-related changes will only appear after you do this.

    Bob Bradley (FIMBob @ TheFIMTeam.com) ... now using Event Broker 3.0 for just-in-time delivery of FIM 2010 policy via the sync engine, and continuous compliance for FIM

    • Marked as answer by saikiran159 Thursday, October 4, 2012 4:07 AM
    Thursday, October 4, 2012 3:45 AM
  • Yes, I have restarted the IIS server. Let me clean all the temp folders if anything is taking up the cached files.

    Regards

    Sai

    Thursday, October 4, 2012 3:54 AM
  • Hi Bob,

    After stopping the IIS server, I have deleted the Windows temp folder and started the IIS server. Now, I can see the values.

    BTW, both the options are working. But, I had to delete temp folder before starting IIS server. 

    Thanks for your help.

    Regards

    Sai

    Thursday, October 4, 2012 4:06 AM