locked
No databases discovered, skipping Install-CsDatabase during Prepare First Standard Server in Skype for Business 2015 RRS feed

  • Question

  • Installing Skype for Business 2015 - Goal is a single stand alone server internally and a single edge server

    Started with a fully patched Windows 2012R2 VM server on Hyper-V

    Ran through all the prerequisites - numerous blogs/wikis to assist

    Prepare Active Directory - Checklist complete, verified objects with ADSI Edit

    Install Administrative Tools - Checklist complete

    Now the fun began - ran the "Prepare First Standard Server" in deployment wizard and got the following error:

    No databases discovered, skipping Install-CsDatabase...
    No roles discovered, skipping Enable-CsComputer...

    Looked at the server and the RTC instance is installed. The lis and xds databases are installed. I have been working on this for several days. Have had numerous issues but have managed to resolve them one by one but no luck with this one.


    eburch@lasertel.com

    Tuesday, May 10, 2016 11:02 PM

Answers

  • Still doesn't show the checkmark next to "Prepare First Standard Edition Server" but it does seem to be installed. I was able to add users, services are up, I can sign in, etc. Still a lot to learn but we beat it. Thanks for all the help.

    Regards


    eburch@lasertel.com

    • Marked as answer by EWB_2 Friday, May 20, 2016 10:34 PM
    Friday, May 20, 2016 10:34 PM

All replies

  • Do you have backend server defined in your topology for database or using local ?

    Please check your topology and confirm.

    I have a guide using local database: https://gallery.technet.microsoft.com/Installing-Skype-for-78703118


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Wednesday, May 11, 2016 7:30 AM
  • I am using local. I thought the process of the "First Standard Server" was to create the databases and the initial topology. As a side note, after I could not get the First Standard Server to succeed, I ran the topology builder and published the topology to the rtc instance of the database and the process indicated it succeeded but the First Standard Server doesn't have the check mark. The tables in the instance have data. Should I just try to move on and install the the server system?

    Thx


    eburch@lasertel.com

    Wednesday, May 11, 2016 3:01 PM

  • Hi,


    yes it is correct that the process of the "First Standard server" should create local store.Before this step you will have to create Lyncfilestore(which also will host some databases).

    can you confirm that LyncFileStorehas correct permisisons? You can refer to the guide in my link above.

    Then try to run Firststandard serverand see if it still fails.Be sure you are member of local admin on the server.


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Wednesday, May 11, 2016 3:48 PM
  • Share has correct NTFS and SharePermissions although system assigned change not full to share. Changed to full on both share and NTFS. I am a member of local adm on server and sysadm on both rtc and rtclocal instances as well as dbo on rtc databases; there are no databases in rtcloacl. I tried to run the "Prepare First Standard Server" again but no difference. I tried to run the "Install Local Configuration Store" but received an error "Cannot open database "xds" requested by the login, login failed. Login failed for user XXXX\ADMXXX. Don't know where else I can be an admin.

    Thx


    eburch@lasertel.com

    Wednesday, May 11, 2016 4:26 PM
  • Then we are one step closer. Here it is certain that this is permission issue.

    On the server, open computer management - expand users and groups - groups and add your admxx account as member.

    Log out of the server and log back in.

    try re-run prepare first standard server and see if it helped.

    if not, then this link might help you : http://lyncuc.blogspot.no/2013/01/cannot-open-database-xds-requested-by.html


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Wednesday, May 11, 2016 4:31 PM
  • So I added my adm account everywhere that seemed even marginally appropriate including the folder permissions of the Sql instances and rebooted the server. Ran  "Prepare First Standard Server" same error. Ran "Install Local Configuration Store" and got same error: Import-CSConfiguration -FileName "C:\Users\ADMXXXX\AppData\Local\Temp\CSConfigData-2016_05_11-10_15_39.zip" -Verbose -LocalStore
    Cannot open database "xds" requested by the login. The login failed.
    Login failed for user 'LASERTEL\ADMXXXX'. The fileshare is now populated but the rtclocal databases xds and lis are not there.

    eburch@lasertel.com

    Wednesday, May 11, 2016 8:12 PM
  • can you confirm if your admin account is member of the following groups:

    • RTCUniversalServerAdmins
      CSAdministrator
      RTCUniversalUserAdmins

    and also confirm this:

    Before running the Install-CsDatabase cmdlet you should make sure that the RTCUniversalServerAdmins groups has not been assigned as the database owner. If that group is listed as the owner the group could possibly be deleted when you call the Install-CsDatabase cmdlet.

    https://technet.microsoft.com/en-us/library/gg399044.aspx?f=255&MSPPError=-2147217396

    If still fails, try uninstall-csdatabase

    https://technet.microsoft.com/en-us/library/gg412922.aspx


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work


    • Edited by Off2work Wednesday, May 11, 2016 9:02 PM edit
    Wednesday, May 11, 2016 8:46 PM
  • Yes, I am in all those groups. RTCUniversalServerAdmins is AdminRole membership on lis and publisher role on xds.

    eburch@lasertel.com

    Wednesday, May 11, 2016 9:13 PM
  • I ran the Install-CsDatabase -ConfiguredDatabases command as suggested above and the rtc and rtcdyn databases showed up in the rtclocal instance but still generated errors. This time though the errors indicated:

    Trying to connect to Sql Server xxxconf01.xxxx.com\lynclocal. using windows
    authentication...
    Exception Stack:
    Type: System.Reflection.TargetInvocationException, Message: Exception has been t
    hrown by the target of an invocation.
    Type: Microsoft.Rtc.Common.Data.DbSetupSqlServiceNotInstalledException, Message:
     Failed to find SQL Service. Make sure that SQL Server service (instance name ly
    nclocal) is installed in machine xxxconf01.xxxxl.com

    Install-CsDatabase : Failed to connect to the SQL server
    xxxconf01.xxxx.com\lynclocal.

    I have the total log but it is rather lengthy

    There is no instance named lynclocal and it is not a required dns alias as best as I can tell.

    Thx


    eburch@lasertel.com

    Wednesday, May 11, 2016 9:32 PM
  • Hi, can you please confirm on the server xxxconf01.xxxx.com that it has sql service name lynclocal running?

    and is it correct computer name? xxxconf01.xxxx.com ?

    This doesn't seem like local instance, but standalone backend. Please open your topology and check configuration of your sql.


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Thursday, May 12, 2016 6:31 AM
  • No, that is the weird part - nothing has lynclocal in it. The Sql installation has 2 instances - rtc (named instance) with databases lis and xds, and rtclocal (named instance) with databases rtc and rtcdyn. The topology shows the rtc instance on xxxconf01.xxxxx.xxx as the Central Management Server and the standard edition front end server. I don't know where it is getting the lynclocal from.

    Thx


    eburch@lasertel.com

    Thursday, May 12, 2016 3:12 PM
  • Hi,

    please open your topology and confirm what is stated here under SQL server store


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Thursday, May 12, 2016 8:39 PM
  • Under Skype for Business Server 2015 > Standard Edition Front End Server > Associations > Sql server Store > xxxconf1.xxxx.com\rtc

    Under Shared Components > SQL Server Stores > xxxconf01.xxxx.com\rtc

    FQDN: xxxconf01.xxxx.com

    SQL Instance: rtc

    Dependent pools: xxxconf01.xxxx.com



    • Edited by EWB_2 Thursday, May 12, 2016 10:12 PM
    Thursday, May 12, 2016 9:56 PM
  • Hi,

    1. Please make sure SQL services started, try to restart SQL service.

    2. Make sure the SQL port TCP 1433 inbound to SQL Server, UDP 1434 inbound open.

    3. If the issue persists, you can try to uninstall the SQL Server, restart Standard Edition Server and then rerun "Prepare first Standard Edition" step.

    Best Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Eason Huang
    TechNet Community Support

    • Proposed as answer by Liinus Monday, May 16, 2016 3:12 PM
    Monday, May 16, 2016 8:04 AM
  • Yes , I had similar issue in which i had to manually install SQL server , then by running the install-csdatabase it was able to recognize and DB got created. Can go ahead with Easons Suggestion. 


    Linus

    Monday, May 16, 2016 3:13 PM
  • Is it possible that somewhere during schema, forest, and domain prep the reference to lynclocal got created? I ran the schema, forest, and domain prep portions on my schema master a 2008R2 domain controller versus the 2012R2 VM that will host my Skype server. I am currently removing any trace of SQL and Skype from the 2012 image.

    Thx


    eburch@lasertel.com

    Monday, May 16, 2016 3:48 PM
  • Giant 360. I uninstalled everything SQL, rebooted the server, removed the old sql folders in programs files and program file (x86), and reran first standard server, and same error as in the beginning.

    No databases discovered, skipping Install-CsDatabase...
    No roles discovered, skipping Enable-CsComputer...

    The installed instance is rtc - no databases other than system databases.


    eburch@lasertel.com

    Monday, May 16, 2016 5:22 PM
  • I ran install-csdatabase -central managementdatabase and this time it ran with no issues.

    I ran enable-cscomputer and it failed with the following error:

    Error: An error occurred: "Microsoft.Rtc.Common.Data.SqlConnectionException" "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)"

    The instance is up, lis and xds databases are there and I can see tables, etc.

    Is it always this painful...


    eburch@lasertel.com

    Monday, May 16, 2016 5:59 PM
  • Just for S&Gs I thought I would see if the topology would publish to the central store and it did with no errors so we are closer than before. Still get the same errors though trying to "Prepare First Standard Server" and get no check mark. Do I need the check mark to move on?

    eburch@lasertel.com

    Monday, May 16, 2016 8:19 PM
  • Hi 

    I know its real confusing when you have everything for SQL in the SFB version ISO itself , but in case if you could try one more step--- After removing all components and starting the fresh installation , could you install SQL std edition server initially and then run the SFB setup for STD edition..


    Linus

    Tuesday, May 17, 2016 4:25 AM
  • HI

    Please make sure you use FQDN of the Front End Server other than the host name in Topology


    Whenever you see a helpful reply, click on Vote As Helpful & click on Mark As Answer if a post answers your question.

    Tuesday, May 17, 2016 6:34 AM
  • Not sure I understand. I plan to have 1 Skype for business internal server and one edge server. We are a small company and should not have more than 2 or 3 conferences at a time. I named the FQDN of the pool the same as the FQDN of the virtual server since we have only one swimmer in the pool. Is that not correct? 

    eburch@lasertel.com

    Tuesday, May 17, 2016 3:23 PM
  • Yes that is correct. 


    Linus

    Tuesday, May 17, 2016 6:19 PM
  • So, this install has been one loop after another. back to the same error:

    Import-CSConfiguration -FileName "C:\Users\ADMXXXX\AppData\Local\Temp\CSConfigData-2016_05_17-12_25_39.zip" -Verbose -LocalStore
    Cannot open database "xds" requested by the login. The login failed.

    Which is BS since SQL Management Studio on the same machine connecting to the same database with the same admin account opens the database and reads its contents with no issues. I don't understand why MS programs have to be so complex and so hard to get working. It was not always this way. I remember when people liked MS programs because they were easy to setup and configure but that was 20+ years ago. I was able to get Polycom Real Connect up in about 10 minutes with no issues but I digress.

    Why in the world can management studio know my security context correctly and allow me into the xds database but the Skype Deployment Wizard and the Skype Management Shell not know my security context even though I started both as administrator.


    eburch@lasertel.com

    Tuesday, May 17, 2016 7:19 PM
  • Quick update

    I dumped the effort and started with a fresh image of 2012R2

    Followed the steps as outlined before in "Installing Skype for Business Step by Step.pdf - have the rtc instance installed and the toplogy deployed still can't get the checkmark for "Prepare First Standard Edition Server"

    Ran the "Install or Update Skype for Business Server system" > "Install Local Configuration Store" even though I didn't have the checkbox and it ran with no issues.

    Got some issues with patches missing but when I run the patch the system indicates patch isn't needed so I'll pound that one out tomorrow.

    Regards


    • Edited by EWB_2 Friday, May 20, 2016 12:24 AM
    Friday, May 20, 2016 12:23 AM
  • Still doesn't show the checkmark next to "Prepare First Standard Edition Server" but I was able to run though all the steps in "Install or Update Skype for Business Server system"  once I got the order of patches correct. After a reboot it shows more patches are yet still needed so I will install and reboot and see if it works. Thanks for all the help will let you know.

    eburch@lasertel.com

    Friday, May 20, 2016 3:03 PM
  • Still doesn't show the checkmark next to "Prepare First Standard Edition Server" but it does seem to be installed. I was able to add users, services are up, I can sign in, etc. Still a lot to learn but we beat it. Thanks for all the help.

    Regards


    eburch@lasertel.com

    • Marked as answer by EWB_2 Friday, May 20, 2016 10:34 PM
    Friday, May 20, 2016 10:34 PM
  • Thanks for sharing the info, might be that the clean install might have cleared all issues.


    Linus

    Saturday, May 21, 2016 1:43 AM
  • Fortunately, with Hyper-V it only takes a few minutes to dump a VM and create a new one. Still don't know why the prepare first standard server doesn't show a green checkmark but I guess it doesn't matter. Definitely have to learn powershell; can't do much without it in SFB.

    Thanks again


    eburch@lasertel.com

    Monday, May 23, 2016 4:44 PM
  • it will not show the green check mark for Frist standard edition.

    Whenever you see a helpful reply, click on Vote As Helpful & click on Mark As Answer if a post answers your question.

    Tuesday, May 24, 2016 4:10 AM