locked
Login required in Professional RRS feed

  • Question

  •  

    Hi, I have ProClarity 6.3.133.402 in the same server that SQL Sever 2000 with Windows Server Standard 2003.

     

    Users and I can connect and view the views perfectly from Proclarity Standard.

    When we open Proclarity Professional apparently everything is ok until we click on one view that access to a different cube of SQL, then User and Password are required to go on. If you type them everything continues fine.

     

    I think books only have one string connection to one cube of the server.

     

    Temporarily, I have created books with views with conection to only one cube, but this is can not be the final solution.

     

    Any one can help me?

     

    Thanks in advance.

     

     

    Thursday, February 14, 2008 12:46 PM

Answers

  • It sounds like the currently logged in credentials are not being sent to the HTTP-enabled cubes.  I assume that the reason you're running the msolap.asp in the same directory as PAS is an attempt to get past this prompt?  Take a look at this knowledge base article on connecting to HTTP enabled cubes to see if the use of connection strings may provide some relief: http://support.microsoft.com/kb/279489.

    I think you are correct in your thinking that IIS is the culprit in this situation as it is most certainly what is prompting for the credentials.  Here is a fantastic technical article on the architecture of this solution: http://technet.microsoft.com/en-us/library/aa902670(sql.80).aspx.  It may help you identify a workaround or alternate solution for the mulitple prompt situation.

    Please let us know if you find a solution, or a workaround, so that other forum contributors may benefit.

     

    Best regards,

     

    Bob

    Monday, March 10, 2008 8:48 PM

All replies

  • Hi Raul,

    This sounds like interesting behavior, can you clarify that the other cube is on the same SQL 2000 instance or is it on a different server?  When you see this issue, is the book being retrieved from the PAS or opened locally on the machine?  Is the Desktop Professional being used, or the Web Professional?  Can you list the steps taken so that we can get an idea of exactly when the prompt occurs?  Which authentication method(s) are in place on the PAS virtual directory?  Is the SQL/PAS server in the same domain as the Professional clients?  Can you describe the security that is in place on the cubes, are the cube roles identical on each cube?  Do the users have membership in more than one role?  Are the users prompted going either way between the views that connect to these two cubes?  Are the users prompted for their initial connection to either cube, or just when the view is accessed that points at the second cube?  It may be worth installing the Analysis Services MDX Sample Application on one or two of the Professional client workstations to see if the user is prompted when you change cubes to narrow down whether this is a ProClarity client issue or an issue with the OLAP provider.  On that note, if from within the Professional client, you click File > Options and click the OLAP Provider tab, what version is specified there?

     

    Thanks,

     

    Bob

     

    Thursday, February 14, 2008 6:36 PM
  • Hi Bob,

    I have two cubes on the same database of SQL 2000 (version 8.00.2039) instance and on the same server. There is no restriction to access to the cubes, the membership is everyone and enforce on Server in each cube.

    This issue occurs in both Web Professional and Desktop Professional.

     

    The authentication methods on the PAS virtual directory are Windows Integrated and Basic authentication with Anonymous access disabled (If I enabled this option I also lose the connection but It runs with Anonymous user although this can not be the definitely configuration).

     

    My clients are in the same domain that the server.

     

    My clients are prompted by an external web, but I tried to connect (with different users even with the administrator account) directly typing windows user and password and the result is the same.

     

    I checked to connect with the cubes through MDX Sample Application in client workstations and it worked fine.

     

    The version of OLAP Provider is 8.0

     

    Thanks again.

    Friday, February 15, 2008 10:38 AM
  • Thanks for the additional information.  Given that this happens only with the Professional clients, we can rule out the PAS virtual directory's security settings as being a factor.  The Pro clients connect directly from client to SSAS to execute queries, so PAS does not come into play after the Pro client retrieves the briefing book information.

     

    If you open the Desktop Professional and choose to view a cube (or go to File|Open Cube), are you able to access this cube without being prompted?  That is, are you prompted only when accessing the cube via the page you have saved in the briefing book?  If so, you will want to have a look at the connection information for that particular book and be sure the server name listed for the AS server in particular is correct.

     

    Friday, February 15, 2008 9:38 PM
  •  

    Hi,

    If I try to open a cube from Professional after receiving a book (I was already prompted because I come from Standard)

    a message windows tells me 'Unauthorized', then I accepted and user windows and password are required, if I type them I can access all cubes from the OLAP Database and all views run properly.

    If I open a book from the AS server with Professional, credentials are required twice, the first to connect to AS Server and the second when I click into a view.

    If I open a book saved in local (name.bbk) with Professional that It access to the Server, credentials are prompted only once. After typing them, I can access to any views and to any cube from the Server and login and password are not required anymore.

     

    I have checked the connection information and It was always correct.

     

    Thank you very much.

    Monday, February 18, 2008 9:38 AM
  • Daniel mentioned in some seperate posts that updating PAS to the latest version resolved some of his issues with being prompted multiple times.  Have you seen any changes in this behavior since the server was updated?

     

    Thursday, March 6, 2008 1:05 AM
  • Hello, my problem has not resolved yet.

     

    I have installed Fiddler software and It shows, when I change of view that access to a different cube so credentials are prompted again, that it is trying to access to /pas/msolap.asp and failed.

    This software says that my web explorer is sending a field of WWW-Authenticate head and the web server is not configured to accept it.

     

    So I don't know if there is any configuration, apart from IIS,  of in my server I have to check.

     

    Any help?

     

    Thank you.

    Thursday, March 6, 2008 2:09 PM
  • It sounds like the currently logged in credentials are not being sent to the HTTP-enabled cubes.  I assume that the reason you're running the msolap.asp in the same directory as PAS is an attempt to get past this prompt?  Take a look at this knowledge base article on connecting to HTTP enabled cubes to see if the use of connection strings may provide some relief: http://support.microsoft.com/kb/279489.

    I think you are correct in your thinking that IIS is the culprit in this situation as it is most certainly what is prompting for the credentials.  Here is a fantastic technical article on the architecture of this solution: http://technet.microsoft.com/en-us/library/aa902670(sql.80).aspx.  It may help you identify a workaround or alternate solution for the mulitple prompt situation.

    Please let us know if you find a solution, or a workaround, so that other forum contributors may benefit.

     

    Best regards,

     

    Bob

    Monday, March 10, 2008 8:48 PM
  • Hello,

    We have installed a server with a similiar environment but with SQL Server 2005.

    The connection from the client to the server must be via http.

    If we connect through msolap.asp and msmdpump.dll we have the same result.

     

    Anyone can help us in order to connect avoiding those files?

    Or, are there any good documentation on the internet?

     

    Thank you again.

    Thursday, March 13, 2008 6:18 PM
  • If it's a requirement that you connect to the cubes via HTTP, you must use either msolap.asp or msmdpump.dll (AS 2000 or SSAS 2005) or your own version of these files to initiate the connection from IIS through the provider to the cube and back to the client.  The links Bob provided in his last post are excellent articles on how this works.

     

    If you're not restricted by HTTP connectivity, then there would be some other options.

     

    Friday, March 14, 2008 11:30 PM