locked
Sharepoint 2013 find a file returning no results RRS feed

  • Question

  • Hello,

    I have a SharePoint 2013 site with enterprise search enabled and it is returning results as expected (including the document library in question), however when I use "find a file" in a document library I do not get any results, I think it is because the "find a file" is using the osssearchresults page instead of the enterprise search. Am I missing something in the setup to enable searching just this document library?

    My Site Collection Administration Search Settings are set to the Search Center URL http://site/search/e-search/pages and I have selected send queries to a custom results page url http://site/search/e-search/pages/results.aspx

    My site settings, search settings are set to "Use the same results page as my parent" which I believe should just use the site collection search settings.

    Thanks

    Wednesday, February 26, 2014 10:48 PM

All replies

  • Hi,

    According to your description, my understanding is that you got no results when searching files in the Find a file search box in the library page.

    Did this issue only occur with the Find a file search box in the library page?

    I recommend to verify the things below:

    1. Check the permission of the user to see if the user has permission to view the documents.
    2. Do a full crawl in Search Service Application to see if the issue still occurs.
    3. Check the Advanced settings of the library to see if the items from this document library are allowed to appear in search results. If it is set to No, change it to Yes and click Reindex Document Library, then do a full crawl in Search Service Application.
    4. Check if the Search Service Application is started in Central Administration and check if the URL of the site is added to the Content Source.

    If the issue still occurs, I recommend to check the ULS log to get detailed error message.

    Thanks,

    Victoria

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Victoria Xia
    TechNet Community Support

    Thursday, February 27, 2014 9:23 AM
  • The issue only occurs in "find a file", enterprise search, finds the files correctly.

    1. Permissions ok

    2. After full crawl, issue still occurs

    3. Yes library is searchable (Enterprise search finds the items correctly, this only happens when using the built in "find a file")

    4. Search service is started and the content source is set to crawl everything under the host name for each starting address and the URL is in the start addresses.

    5. Logs just say no results found when using "find a file"

    Every document library in the entire site has this issue, when using "find a file", enterprise search finds all documents correctly across the entire site. This also is the case, when you use "find an item" in a list, where it returns no results, but enterprise search finds the items correctly.

    I still think it is because the "find a file" is using the osssearchresults page and not enterprise search

    Thursday, February 27, 2014 1:59 PM
  • Hi,

    This issue may be due to the unsuitable default result source.

    When a library search is executed, the library path is automatically prepended to the query text entered. So if the user types the query india meeting(for example), the resulting query will be something like the following: path:"HTTP://INTRANET.SOMEDOMAIN.COM/SITES/ABC/DOCUMENTS" AND india meeting.

    The above query is then further combined with the default result source of the site since result sources cannot be set at library level. If that result source contains tokens such as {Site.URL} then the library search fails silently because such tokens are not recognized from within library context. Perhaps a future update will change this behaviour, but until then always ensure that the default result source of the site does not contain tokens such as {Site.URL} or {SiteCollection.URL}.

    More information are provided in the link below:

    http://softlanding.ca/blog/library-search-fails-to-return-results

    Best regards.

    Thanks


    Victoria Xia
    TechNet Community Support

    • Marked as answer by JasonGuo Sunday, March 9, 2014 9:41 AM
    • Unmarked as answer by Davidatek Monday, March 10, 2014 12:35 AM
    • Proposed as answer by Hans Sissing Wednesday, August 23, 2017 1:37 PM
    Monday, March 3, 2014 2:34 AM
  • Sorry for the delay in answering, but this is still unresolved.

    The URL is correct while searching.

    Any other ideas? 

    Monday, March 10, 2014 12:37 AM
  • I'm have the exact same situation and the proposed solutions haven't worked for me either.

    the problem occurs on every list and library in the site. I agree with the idea that its somehow related  osssearchresults.aspx . i have configured a search centre, but the Search this site is using osssearchresults.aspx and also finds no results, the same query (including the url parameter) does produce results in the enterprise search.

    any suggestions?

    Wednesday, March 26, 2014 12:31 AM
  • I still have not found a solution, so I just turned off the "find a file" option by editing the web part, under miscellaneous, uncheck "display search box" so that end users are not seeing the blank results.

    Wednesday, March 26, 2014 1:48 PM
  • I agree.  Just removing it for me worked, however, I do have some users that want that functionality.
    Thursday, April 3, 2014 3:33 PM
  • If anyone finds a solution for this please post it as I would like to enable that functionality.

    Tuesday, April 8, 2014 6:09 PM
  • Having exact same issue in all sites and web applications.

    The Search This Site and enterprise Search Center both return results. However the "Find a File" search box for lists and libraries returns no results whatsoever.

    As a test, I performed a fresh farm install on a different server and it still doesn't function.


    If at first you don't succeed, ask an MVP.

    Wednesday, May 14, 2014 3:08 AM
  • I too am having the exact same issue and am hoping for a response.
    Tuesday, June 3, 2014 3:28 PM
  • I don't know why but researching the search index seems to work. You'd think Enterprise search uses the same index, no?

    Try on the affected library before resetting entire search index in Central Admin.

    See: http://social.technet.microsoft.com/Forums/sharepoint/en-US/3fb8a75e-0815-4026-bf39-5f5aa6326c85/sharepoint-2013-inplace-find-a-file-isnt-working?forum=sharepointadmin#cb4a0d5e-9407-4e8f-bb68-dd2ec1940477


    If at first you don't succeed, ask an MVP.

    Saturday, June 7, 2014 12:24 AM
  • Do you have any special characters on the path to your document library? E.g. é, è, ï, etc.?

    This caused our "Find a file" functionality to throw errors and return no results.

    Friday, August 29, 2014 1:51 PM
  • The only special characters are spaces.

    I just created a new library in a path with no spaces, let it index, and I was able to use find a file.

    So now I know "spaces" are causing the issue, any idea on how to resolve without removing all of the spaces in the paths?

    Thursday, September 4, 2014 9:19 PM
  • I found an old sharepoint issue with spaces in the path and it appears this was a bug in prior versions of sharepoint.

    http://support.microsoft.com/kb/968476/en-us

    Basically it talks about changing the metadata property mappings and setting the mapping to managed properties = path(text)

    Maybe someone with search expertise could shed some light on what the fix might be for SharePoint 2013?

    Tuesday, September 9, 2014 1:36 PM
  • I don't believe spaces are the issue. Have you tried creating a new library with spaces in the title?

    My findings are that it's just completely random. And very, very frsutrating.


    If at first you don't succeed, ask an MVP.

    Saturday, September 13, 2014 12:33 AM
  • I am also having this problem and would like a solution.
    Wednesday, October 15, 2014 9:37 PM
  • Could this have something to do with indexed columns under library settings.

    Wednesday, October 15, 2014 9:43 PM
  • @Ctrunk514 Yes it does, as only indexed columns will be searchable. But there are other factors.

    I've also discovered that Draft Item security will affect this in the same manner as it affects search indexing.

    These items are not indexed until a major version exists when the library setting "Only people who can edit" is checked.

    What is so very annoying is that there is simply no documentation or forthcoming answers from MS regarding just how this new and much-enforced in-place search actually works.

    Why it doesn't simply filter the current list view is quite beyond me.

    I've written my own solution using JSOM ClientContext class which works every time by simply appending a filter to the view based on a search in any field of type Text.


    If at first you don't succeed, ask an MVP.

    Wednesday, October 15, 2014 11:37 PM
  • We are experiencing this as well, and disabling is not really an option as it is a really useful feature that users want.

    PANoone, would you be able to share your JSOM solution to see if it would be suitable for us to use.

    Thanks in advance.


    Regards, Daniel

    Thursday, October 16, 2014 1:30 AM
  • The problem for me might be that the name field of this document library is not being index.  Name is the actual name of the document (IE: file.docx).  What is really odd is that name is not an available option for indexing.  We do not require our users to enter a title, as they want the document name to be the title.  If I manually copy the document name to then title field, which is indexed by default, and run a re-index the search works.  This however is not an ideal solution, I would think document name would be index by default as well as title. 

    Thursday, October 16, 2014 3:26 PM
  • Sorry, Daniel. No can do. It was developed under contract.

    But you can achieve very much the same thing using connected web parts. [wink wink] ;)


    If at first you don't succeed, ask an MVP.

    Thursday, October 16, 2014 10:19 PM
  • Hi,

    We had the same issue and found it was due to a custom result source set as the default. When we set the default back to Local SharePoint Results it started to work again.

    Tuesday, November 4, 2014 8:49 AM
  • I had the same problem as topick starter.

    I solved it: in CA in Search Administration in name mapping server I had the mapping, i deleted it, then run full crawl and search began to work everywere!!!


    Wednesday, November 19, 2014 10:57 AM
  • Hi

    I am having the same issues. There isn't a lot of info readily available on this. I have checked search crawls and checked the URLs which is all fine, however, I cannot see any results when searching on list/library or even on site level. It is only when I select 'Everything' that I get results, however this is only so useful as I want to search on list level.

    One thing I have read is how the link in the Content Source must match that in the Alternate Access Mappings, however, it must be set to 'Default'. Can anyone confirm this works? At the moment the URL for that, is set to HTTP = Default, but the HTTPS is Internet (in the Content Source, it is referencing the HTTPS). Hope that makes sense...  

    • Proposed as answer by Red_Nation Monday, April 27, 2015 3:33 PM
    Thursday, February 26, 2015 9:15 AM
  • I was having the same problem and so I tried Колтышев Евгений's solution. I removed the server mapping (hostname to FQDN for search results) from search and modified the AAM to use the FQDN mapping in the default zone, instead of the hostname. And now it works!!!

    Thank you everyone for your input.


    Matthew Barrett Concept Interactive Inc.

    Tuesday, March 17, 2015 7:22 PM
  • We chose to edit the search URL so that it matched what was in the Default zone in AAM.  It seems like the search URL has to match the default zone otherwise it wont work.
    Monday, April 27, 2015 3:41 PM
  • So if HTTP is your default AAM, try changing your search URL to HTTP rather than HTTPS. 
    Monday, April 27, 2015 3:46 PM
  • Hi,

    we had the same behaviour, Enterprise search found documents but local library search did not.

    We found that for one site Collection the default search source had been misstakenly changed from "Local Sharepoint Results" to one of the custom ones in our site.

    To change : https://technet.microsoft.com/en-us/library/jj683115.aspx#BKMK_Default

    Now our local library searches work again.

    Wednesday, May 20, 2015 11:39 AM
  • I had the same issue: search was finding documents except when done from a library.

    to troubleshoot this: i got two hints...one from this blog

    1-

    1. the search within a library appends the library path to the query string

    so i needed to find a way to see that query. I clicked on "include" at the bottom of the empty result and clicked again on "entire site" and got something like this:

    https://share.contoso.com/crm/_layouts/15/osssearchresults.aspx?u=share.contoso.com/subsite-name&k=programmer

    got my query string...and used this PS script to run it directly against the service. this way eliminates any other cause that might be related to the search webpart...

    2. the powershell found here : http://www.dotnetmafia.com/blogs/dotnettipoftheday/archive/2014/01/08/how-to-query-sharepoint-search-with-powershell.aspx

    powershell search with the same url in the query...returned an error saying it can't connect to the site. i used then the machine name and it worked.

    So that was my problem...

    - AAM wasn't set right, was missing internal mapping for both https and http.

    - Also changed all the content sources URLs from the public to the internal one and run a full crawl.

    it worked...good luck!! 

       

    -  




    Saturday, June 13, 2015 2:41 PM
  • I realize that this is an old post, but I had trouble finding a solution, and none of the proposed solutions in this thread worked in my case.  Instead, the issue in my case had to do with the List View Threshold.  The number of documents in the library exceeded the list view threshold, which effectively "disabled" this searching feature.  Once I increased the list view threshold, the search started to work again.

    Hopefully that helps someone in the future.


    Information Systems Manager, Tallan, Inc.

    Wednesday, January 6, 2016 5:34 PM
  • I have a similar problem. On some sites it works on others not. It seems to have something to do with the site naming:

    http://<root>/sites/ueber => ok

    http://<root>/sites/über => no results in find a file (site search and search center are okay)

    Is this a known bug with special characters in site names?

    Monday, February 1, 2016 1:47 PM
  • Were you able to resolve this?  I also have an https enable doc library

    I have the same issue where the Find a File doesn't find any files and then I click on "Include these in your search" other link and that gives me "Still didn't find it? Try searching the entire site." takes me to myURL/osssearchresults.aspx?u=http   this doesn't return any results.

    if I make it: myURL/osssearchresults.aspx?u=https it doesn't work.

    but if I remove u=http(s) then it works.  

    What do you think the issue could be?


    Yo Portals

    Friday, April 29, 2016 9:51 PM
  • Hello, please, be sure you have the AAM in SharePoint configured according your public or frecuently used url by default.

    Search engine use the default zone to get the information as well.

    I had the same problem. I did checked my AAM configuration for the web application and found multiples http/https urls. I leaved the https url by defautl in AAM and IIS too, and the "find a file" works perfectly. Now it is returning the information.

    Some cases the AAM should be configured according you need.

    Is not necessary run any PS or another thing, just check your AAM

    I hope help you.

    Andres Rojas

    MVP Office Server and Services


    Ing. Andres Rojas | MVP SharePoint Server | MCITP, MCPD, MCTS | http://arojaspa.blogspot.com | twitter: arojaspa


    Wednesday, November 9, 2016 9:55 AM
  • I just went to the Library Settings - Advanced Settings - click on "Reindex List", and all of the items in the list arenow in the List Search results and the Site Search results.

    I had zero Zero results before running the "Reindex List", and I had over 10 results after the Reindex.
    Monday, November 28, 2016 7:32 PM
  • We had the same issue and found it was due to a custom result source set as the default. When we set the default back to Local SharePoint Results it started to work again.

    Jim Poindexter

    Wednesday, November 29, 2017 12:06 AM
  • Perfect Work for me !
    I change for Sharepoint Local Results , work fine
    Wednesday, June 26, 2019 2:18 PM