none
Primary DPM and Secondary DPM replica sizes different RRS feed

  • General discussion

  • This is just more of a piece of mind questions.

    should the replica for a server being protected by my primary dpm, be the same size as the repica for the protected server on the secondary dpm

    for example.

    the protected servers are my file1 and file2 servers. For file1 on the primary DPM, the disk allocation is 1051 GB and the disk use is 609 GB

    when protecting the same data through the Secondary dpm, the disk allocation is 1049 GB and the disk use is 599 GB

    i know it is a small amount but they are different.

    now, lets take file2 on the primary dpm,  the disk allocation is 644 GB and the disk use is 417 GB

    for file2 on the secondary dpm, the disk allocation is 336 GB and the disk use is 238 GB.

    these just seem way off.  am i missing something?

    Thanks

     


    Ian
    Wednesday, November 24, 2010 4:16 PM

All replies

  • Hi Ian,

    If the changes were minimal this could be due to a diferent block size on the disk that you are using for DPM storage but given the differences......

    Two things you can look at that may explain this.
    1. There may actually be a problem with the volumes - so I'd suggest running a consistency check if you haven't already done so. This will be time consuming given the amount of data and dependent on the speed of disk and bandwidth between the primary and secondary. E.g. we have done consitency checks on a 400GB file volume which takes about 2-3 hours on DPM 2010 with a reasonably fast virtual environment.
    2. Single instance storage? Is there a situation where the primary DPM would not be handling SIS well but the secondary would see a lot of duplication? When you refer to file2 are you referring to a single volume or a number of volumes - be sure that the same data is selected on the secondary as the primary.

    Those are about the only reasons I can think of.

    Tuesday, November 30, 2010 11:24 AM
  • i checked the disk usage from both my primary and secondary DPM servers today.  all server seems to be very close now.  The secondary DPM server seems to be just a GB or two less than the primary.  that seems much better.

    The data for file1 seems very close.  maybe a difference of 5GB.  the data for file2 is off. it has a much larger difference. about 100 GB i ran a consistency check on file two only.  it did not change (i was in the protection tab, right clicked on the file2 data and selected perform a consistency check)

     

    I am not sure where to check the SIS.  some instruction would be greatly appreciated.

    Ian


    Ian
    Tuesday, November 30, 2010 9:21 PM
  • Hi Ian,

    When you created protection on the secondary did you let DPM do the initial sync or did you manually copy the data from the primary to the secondary. It may be worthwhile having a look at the data structure on the c:\program files\microsoft dpm\dpm\volumes\replica folder for the file2 data to see if you can see any differences in structure or number of the files on each replica volume for file2 - this might give you some clues as to what is happening.

    With SIS and DPM - unfortunately the management tools are not available in the limited SIS installation that DPM uses - so I don't know of a way to get any statistics or other information on how well it's doing.

    Tuesday, November 30, 2010 10:13 PM
  • Thank you for the response Danny.

     

    when i initially created the secondary protect of File2, i told it to create the replica and copy over immediatly.  i did not copy to an external device and then import into the secondary DPM server. 

     

    for checking the relica folder at  c:\program files\microsoft dpm\dpm\volumes\replica, i have looked into this, but i only see folder (such as Files system, MS Hyper-v VSS writer, Non vss datasource writes and sqlserver writer.)  i expand File System.  i see a bunch of links to the replica, labeled vol_xyz...  i have found the link to what is file2.  but there is no data other than a folder labeled c4e65f0a-... and a file with the same label.  if i expand that folder i then see three xml documents.  DatasetContextInformatiion, DatasourceProtectionIntent, and DatasourceVolumeMapping. 

    Am I missing anything? 

     


    Ian
    Wednesday, December 1, 2010 3:09 PM
  • If running under 2008 or 2008 R2 you will have to be running this as the administrator user (not member of local administrators) or disable UAC to be able to see the content of the replica volumes.

    Thursday, December 2, 2010 12:06 AM
  • Danny and all, I must apologize,;I still am not seeing any other items.  I am currently logged into the box as the domain administrator. I have also tried the local admin account.  I only see the entities I specified above.  Any more details that you could provide would be appreciated.

     

    Ian


    Ian
    Thursday, December 2, 2010 2:04 PM
  • i was actually looking at another post you made Danny, in the SQL and DPM section of the forums.  you mentioned to someone about mounting the volume with the CMD prompt.  It may benefit you to know that I was using explorer to view the details of c:\program files\Microsoft DPM\DPM\Volumes.

     

    Will I need to look at the replica via CMD?

     

    thanks

    Ian


    Ian
    Thursday, December 2, 2010 2:54 PM
  • The mount points for the replica volumes are under the c:\program files\microsoft dpm\dpm\volumes\replica\file server name\GIUD\Full folder. An administrator on that computer should be able to look at the replica volume (we've done this previously). Otherwise you can run a dpmbackup.exe -replica from the c:\program files\microsoft dpm\dpm\bin folder (http://technet.microsoft.com/en-us/library/bb795753.aspx) and this will create a vss snap for the data in the c:\program files\microsoft dpm\dpm\volumes\shadow copy folder. You can use this to get a view of the data and compare.

    Not sure why you aren't able to see the replica data - might be UAC related.

    Thursday, December 2, 2010 9:44 PM
  • just wanted to give you a heads up.  we had lost our primary dpm server. 

    we had to rebuild the primary, and we decided to start from scratch.  we then added all new protection groups and new repicas.  we will then most likely erase and redo all protection on the secondary server.

     

    Ian


    Ian
    Friday, January 28, 2011 9:48 PM