Exchange 2007 SP3 RU4 Users experienced issues in logging on to mailbox already logged on users unable to perform send/receive functions RRS feed

  • Question

  • I had recently come across an issue where the Users were Unable to send and receive emails on MS outlook/OWA/Mobile Devices. The server was available to connect we observed that Microsoft Exchange Active Directory Topology Services were connecting to Global Catalog Server available on the WAN Link instead of local Global Catalog. There were intermittent loss of connectivity while the server was trying collect information from Remote Global Catalog Server on the WAN link. The Exchange Management Console snap-in was not responsive and used to crash. Hence it was then decided to restart the Microsoft Exchange Active Directory Topology Service. The service failed to come up when restarted. The next action performed was to reboot the server so that the Exchange Server communicates with any other available Global Catalog Server in the AD Site. We check the Global Catalog Server on local site and found replication issues and the server was recovering from Journal wrap error hence it is not advertising as a Domain Controller or Global Catalog Server, untill the server has replicated the SYSVOL share. Till then the exchange server was contacting the Global Catalog Server on the WAN Link and any GC's or DC's that responds to the request will act as the Global Catalog Server for the same.

    Is it possible to specify in Exchange 2007 (although we believe its AD Topology Service again) to point to a specific Global Catalog Server. I am basically looking toward the feasilbility or is this option ruled out completely. 

    Regards Sandeep Swarup S

    Tuesday, February 7, 2012 7:56 PM


  • Hi,

    You can try to use set-exchangeserver with -StaticDomainControllers to specify the DCs that you want.

    Xiu Zhang

    TechNet Community Support

    • Proposed as answer by Ajith Kumar R Thursday, February 9, 2012 11:33 AM
    • Marked as answer by Sandeep Swarup S Thursday, February 9, 2012 1:41 PM
    Thursday, February 9, 2012 9:01 AM