none
"Assignment owner" not available at PS and PWA RRS feed

  • Question

  • Dear Colleagues,<o:p></o:p>

    We face problem serious for us but I assume trivial for you. On our corporate PS
    installation (2010) we like to start the use of the "assignment
    owner" facility for the reason it is provided: to assign tasks to external
    consultants and as 'assignment owners" to team leaders for the approval purposes. <o:p></o:p>

    The problem is that our PS does not "see" the assignment owners at all. I can
    make the entry in Project Pro and they are stored (?) I guess since if I am
    reopening the PS file again in my Project Pro I see the changes. However the PS
    and PWA seems to not be affected by the changes even after publishing, in fact PS has no column “Assignment
    owner” at all, team members do not receive the mails that they are “assignment owners” and do not see these tasks in "Tasks” view.<o:p></o:p>

    Our PS administrators are not able to find why it is not working.<o:p></o:p>

    Thank you in advance and best regards

    Waldek

    Thursday, April 3, 2014 9:06 AM

Answers

  • Hi Waldemar,

    In case it is occasional, I'd recommend to let the resource as his default assignment owner in PWA and change the assignment owner in MS Project Pro.

    • Go to the task usage view,
    • Insert the "assignment owner" column
    • Select the drop-down menu next to the resource name under the task name
    • Choose the new assignment owner
    • Save and PUBLISH the project
    • Check the queue in order to see if the publish job has been successfully processed

    It should work, please come back to us with the detail steps so we can helps you.

    Hope this helps.


    Guillaume Rouyre - MBA, MCP, MCTS

    Thursday, April 3, 2014 2:00 PM
    Moderator
  • Hi Waldemar,

    I've tested your scenario on my demo machine where I have changed the Assignment Owner in Project Pro. After that I have published the project schedule. In PWA | Project Center in the view "Assignment Summary" we have the column "Assignment Owner" and - in my case - I see the changed Resource in it. In the view "Task Summary" you should see the original resource in the column "Resource Name" - this is absolutely OK because in this view you can't see assignments - it's the task Level.

    A look into the My Task view of the new Assignment Owner shows me also the new task.

    Basically the process for this scenario works fine.

    Therfore what's the hotfix Level on your Project Server? The actual SP is SP2 and the last CU for Project Server 2010 is from February with the build No 14.0.7116.5000.

    I remember we had some issues with assignments and changed assignment owners in the past. Therefore check your hotfix level please.

    Best Regards

    Bernhard Fischer


    Bernhard Fischer [MVP] | www.wodey.de

    Friday, April 4, 2014 6:51 AM

All replies

  • Hello Waldek,

    in PWA you can't change the assignment owner at the task level but you can change it per default.

    Go to PWA | Resource Center and mark a resource you want. On the Ribbon Bar klick "Edit Resource". Now scroll down to the line "Default Assignment Owner" and over the button "Browse" you can change the assignment Owner to that person who should get the assignments in future in delegation of the external consultant. But consider that you may delete and reassign the original resource because changes from assignment owners are not always handled transparently in Project Server. I Hope, this helps.


    Bernhard Fischer [MVP] | www.wodey.de

    Thursday, April 3, 2014 9:55 AM
  • Bernhard,

    Vielen Dank! But it does not help unfortunately.

    First I do not like to change the "assignment owner" from PWA but from Project Proffesional. It works but only on the Proffesional and does not affect the Project Server.

    I tried to do like you recommended by changing in PWA the "default assignment owner" and it works (I see the changed assignment owner from Proj. Professional later) but still the assigned owner don't see the tasks of the person to whom is assigned as "default assignment owner" and receives no notification too.

    Probably you will have another ideas about this interesting functionality?

    CheersWaldek

    Thursday, April 3, 2014 1:46 PM
  • Hi Waldemar,

    In case it is occasional, I'd recommend to let the resource as his default assignment owner in PWA and change the assignment owner in MS Project Pro.

    • Go to the task usage view,
    • Insert the "assignment owner" column
    • Select the drop-down menu next to the resource name under the task name
    • Choose the new assignment owner
    • Save and PUBLISH the project
    • Check the queue in order to see if the publish job has been successfully processed

    It should work, please come back to us with the detail steps so we can helps you.

    Hope this helps.


    Guillaume Rouyre - MBA, MCP, MCTS

    Thursday, April 3, 2014 2:00 PM
    Moderator
  • Hi Waldemar,

    I've tested your scenario on my demo machine where I have changed the Assignment Owner in Project Pro. After that I have published the project schedule. In PWA | Project Center in the view "Assignment Summary" we have the column "Assignment Owner" and - in my case - I see the changed Resource in it. In the view "Task Summary" you should see the original resource in the column "Resource Name" - this is absolutely OK because in this view you can't see assignments - it's the task Level.

    A look into the My Task view of the new Assignment Owner shows me also the new task.

    Basically the process for this scenario works fine.

    Therfore what's the hotfix Level on your Project Server? The actual SP is SP2 and the last CU for Project Server 2010 is from February with the build No 14.0.7116.5000.

    I remember we had some issues with assignments and changed assignment owners in the past. Therefore check your hotfix level please.

    Best Regards

    Bernhard Fischer


    Bernhard Fischer [MVP] | www.wodey.de

    Friday, April 4, 2014 6:51 AM
  • Hi Waldemar,

    I've tested your scenario on my demo machine where I have changed the Assignment Owner in Project Pro. After that I have published the project schedule. In PWA | Project Center in the view "Assignment Summary" we have the column "Assignment Owner" and - in my case - I see the changed Resource in it. In the view "Task Summary" you should see the original resource in the column "Resource Name" - this is absolutely OK because in this view you can't see assignments - it's the task Level.

    A look into the My Task view of the new Assignment Owner shows me also the new task.

    Basically the process for this scenario works fine.

    Therfore what's the hotfix Level on your Project Server? The actual SP is SP2 and the last CU for Project Server 2010 is from February with the build No 14.0.7116.5000.

    I remember we had some issues with assignments and changed assignment owners in the past. Therefore check your hotfix level please.

    Best Regards

    Bernhard Fischer


    Bernhard Fischer [MVP] | www.wodey.de

    Thank you Bernhard, indeed we do not have the actual level as I checked. Now I have to wait for the activation. Best regards
    Friday, April 4, 2014 12:05 PM