none
Unable to Publish Master Project. RRS feed

  • Question

  • Hi Experts,

    I have a situation here where I am not able to publish the master projects. I was thinking there might some corruption or some issue with respect to the sub projects and when I try to remove sub project and try to save/publish Master Project, it again wont work.

    How do I move all these sub projects to another project and remove this Master project?

    Thanks

    Sakthi.

    Wednesday, April 15, 2015 5:40 PM

Answers

  • Sakthi --

    If you are the Project Server administrator, then you can delete the entire master project using the PWA user interface for administrators (Clean Up Enterprise Objects).  Doing this WILL NOT delete the subprojects; it will only delete the master project which is a "container" for the other subprojects.

    Then, using Microsoft Project Professional, create the master project from scratch by adding one subproject at a time and then saving/publishing.  If you run into a publishing problem again, you will know that the last subproject you added was the troublesome project, which might be a corrupted project, for example.

    Just a thought.  Hope this helps.


    Dale A. Howard [MVP]

    Thursday, April 16, 2015 2:17 PM
    Moderator

All replies

  • Please try following steps:

    1. As best practice, clean-up cache before opening and publishing work plan.
    2. Usually Master plan is not being edited directly (editing is done in the actual plan (sub-plan)), but if in case this is necessary, please only click “Yes” only to the work plan edited when prompted with message below and do not click “Yes to All” as this will create items for each sub-plan in local cache leading huge bulk data in the cache which may impede work plan publishing. This may also cause filling jobs in your instance queue which slows down the processing. Then, if no part of the Master Plan is edited during the session, you may just click “No to All”.
    3. Also, if possible you can limit to smaller number plans (breakdown of master plan). This is “Yes to all” if necessary for your work plan publishing.
    4. Try to publish again by considering above points.
    5. If issue still persist, try removing all of the sub projects, save and publish this plan as before. Now delete this project (the master project) from the published database only (remember to check the published database only option!), then open project again in Project Professional, add in the sub projects and publish again.

    Hope this will fix the issue.

    -------------------------------------------------------------------------

    Raushan Kumar |LinkedIn


    • Edited by Raushan_kumar Wednesday, April 15, 2015 7:58 PM Update
    Wednesday, April 15, 2015 7:57 PM
  • Thanks Raushan for the response.,

    I have deleted couple of projects as per the point 5 and when I try to save and publish, it did only save. now the problem is I dont see the deleted sub project in the master project when I reopen it. But at the same time, I cant add those deleted sub project in any other project. I have followed the unlink and remove for delinking process.

    If I proceed as per the point 5, I doubt whether I will be able to re-add the sub projects again :(.

    Thanks

    Sakthi.

    Wednesday, April 15, 2015 8:53 PM
  • Sakthi --

    There is actually a permission in Project Server that prevents PMs from saving and/or publishing master projects.  Have you actually confirmed that you are allowed to publish master projects in your Project Server system.  You would need to ask your Project Server administrator about this.  At my previous employer, PMs were not allowed to save or publish master projects, so those permissions were disabled in our Project Server 2010 system.  Please let us know and we will try to help you.


    Dale A. Howard [MVP]

    Wednesday, April 15, 2015 9:24 PM
    Moderator
  • hi Dale,

    I am the PS Admin and I am not able to publish them too. Its not a permission issue as they were able to publish the same projects earlier.

    Thanks

    Sakthi.

    Thursday, April 16, 2015 1:35 PM
  • Hi Sakthi,

    Please allow me to jump in since your issue seems to be quite tricky..

    Have you tried to publish every single project not from the master project? It could indeed be a corruption issue from 1 project. Another question: do you have any tasks/assignments in the master project? Or does it just contain the subprojects? Did you insert blank rows in your master project, in between the projects? Resources or dependencies on summary tasks? Try also to check the messages in the PWA queue and potential error messages in the ULS logs.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Thursday, April 16, 2015 2:15 PM
    Moderator
  • Sakthi --

    If you are the Project Server administrator, then you can delete the entire master project using the PWA user interface for administrators (Clean Up Enterprise Objects).  Doing this WILL NOT delete the subprojects; it will only delete the master project which is a "container" for the other subprojects.

    Then, using Microsoft Project Professional, create the master project from scratch by adding one subproject at a time and then saving/publishing.  If you run into a publishing problem again, you will know that the last subproject you added was the troublesome project, which might be a corrupted project, for example.

    Just a thought.  Hope this helps.


    Dale A. Howard [MVP]

    Thursday, April 16, 2015 2:17 PM
    Moderator
  • Thanks Guillaume and Dale.

    Apparently clearing out the logs folder helped and dont know whether its coincidence. The Sharepoint timer service was holding all the log files and it was not able to be deleted by the maintenance process and it was piling up. Restarted the timer service did the trick.

    Later able to publish all the projects.

    Also  for one project which was not publishing, as Dale told we have deleted the master project and created another one and published successfully.

    Thank you guys.

    Sakthi.

    Thursday, April 16, 2015 8:39 PM