locked
Cannot change active network from public to home in Windows 7 RRS feed

  • Question

  • Hello. I have a home network connected through an Ethernet switch, which uses ICS through one of the computers (host - 192.168.0.1) via a wireless broadband card.  Until recently the host computer was running XP and all was well.  (Two of PCs on the network are W7.)  I have upgraded the host computer to W7 and things are not so happy.  My home network is now showing as a public network and W7 will not allow me to change it.  I have read in the forums that W7 sees it as an unidentified network, seemingly because there is no default gateway set.  I have tried to set the default gateway to 192.168.0.1, but it ignores my input (doesn't save) and I end with a default gateway of 0.0.0.0.  I have tried a couple of things from this thread:

    http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/878f7c4f-f287-4c75-a708-a2097f931435

    I tried this from Reckless Dane:

    1. DISABLE ALL NETWORK ADAPTERS
    2. ENABLE THE ADAPTER THAT'S ONLY SHOWING UP THE UNCHANGEABLE PUBLIC NETWORK
    3. IN THE NETWORK AND SHARING CENTER, SELECT "CHOOSE HOMEGROUP AND SHARING OPTIONS"
    4. CLICK ON "WHAT IS THIS LOCATION?"
    5. SELECT HOME/WORK
    6. RE-ENABLE ALL OTHER ADAPTERS

    When I select "CHOOSE HOMEGROUP AND SHARING OPTIONS" there is no option or button that says "WHAT IS THIS LOCATION?"  It just says "The Homegroup is not available because you're not connected to the home network."

    I also tried:

    Run secpol.msc
    Select Network List Manager Policies
    Set Unidentified network policies to "user can change location" and the location to "private"

    And this did change the Network type to "Work," but if still says I'm not connected to home network and it still won't let me change the default gateway.

    Below is my IPCONFIG.  Any help would be greatly appreciated (as frustration level is high.  I was really hoping that W7 would actually let me control my PC after struggling with Vista.)

    Microsoft Windows [Version 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : 
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    PPP adapter CDMA:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : CDMA
       Physical Address. . . . . . . . . :
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 173.139.144.177(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.255
       Default Gateway . . . . . . . . . : 0.0.0.0
       DNS Servers . . . . . . . . . . . : 68.28.178.91
                                           68.28.186.91
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connection
       Physical Address. . . . . . . . . : 00-1B-FC-B5-0E-47
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.0.1(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 0.0.0.0
       DNS Servers . . . . . . . . . . . : 192.168.0.1
                                           68.94.156.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter Reusable Microsoft 6To4 Adapter:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft 6to4 Adapter #3
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2002:ad8b:90b1::ad8b:90b1(Preferred)
       Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301
       DNS Servers . . . . . . . . . . . : 68.28.178.91
                                           68.28.186.91
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e74:2092:2574:5274:6f4e(Pref
    erred)
       Link-local IPv6 Address . . . . . : fe80::2092:2574:5274:6f4e%12(Preferred)
       Default Gateway . . . . . . . . . :
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter 6TO4 Adapter:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft 6to4 Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 8:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft 6to4 Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{3DE5F941-A9BE-4DAA-910E-1A71D0913E2B}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{CF3C1854-45D0-4159-BEDB-854A6B6995EC}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tuesday, May 18, 2010 12:52 AM

Answers

  •    If you manually configured your local network while you were using ICS on XP, that explains the 192.168.0.0/24 subnet. Windows 7 ICS uses 192.168.137.0/24. I am a bit surprised that it works at all with 192.168.0.0

      Why don''t you buy a simple ADSL NAT "router"? ICS is a pain at the best of times.

      I don't know why the secpol changes did not set your internal network to private.

        You can't configure a default gateway on the internal NIC of the host because this interface is itself the default gateway for your home network. 

     


    Bill
    • Marked as answer by Novak Wu Monday, May 24, 2010 1:48 AM
    Friday, May 21, 2010 4:55 AM

All replies

  • All those Windows gurus out there and no one is going to even attempt to help me?
    Wednesday, May 19, 2010 12:52 AM
  •   That does not make any sense. Win 7 does not use 192.168.0.0/24 for ICS. It uses 192.168.137.0/24  The subnet was changed to avoid conflict with ADSL routers which use 192.168.0.0   .  How did you enable ICS?

     

       


    Bill
    Wednesday, May 19, 2010 2:06 AM
  • Hi Bill.  Thanks for the response.

    To enable ICS I just went into Change Adapter Settings for my broadband adapter, went to the Sharing tab and selected allow other computers to access the internet through this computer.  I believe it then gave the standard message that it was resetting the IP address of my LAN adapter; I don't recall what specific address it said or if it gave one.   I do know that I checked the LAN address after this and it was set to the typical 192.168.0.1/255.255.255.0 address.  All the IP addresses on my network at static - manually set.  Should I reset the address on the host to something other than what is shown above.  Don't know that it makes any difference but all the PCs on my network can access the internet through the host, but the host still says there is no home network.

    btw - it sounds like networking in W7 has changed a bit; is there a good primer somewhere?

    Wednesday, May 19, 2010 12:55 PM
  • Well sometimes I stump my IT department but I'm surprised I can stump this august body.  No one has any suggestions?
    Thursday, May 20, 2010 2:13 PM
  •    If you manually configured your local network while you were using ICS on XP, that explains the 192.168.0.0/24 subnet. Windows 7 ICS uses 192.168.137.0/24. I am a bit surprised that it works at all with 192.168.0.0

      Why don''t you buy a simple ADSL NAT "router"? ICS is a pain at the best of times.

      I don't know why the secpol changes did not set your internal network to private.

        You can't configure a default gateway on the internal NIC of the host because this interface is itself the default gateway for your home network. 

     


    Bill
    • Marked as answer by Novak Wu Monday, May 24, 2010 1:48 AM
    Friday, May 21, 2010 4:55 AM
  • Thanks Bill.  I'm going to try to delete everything; see if I can get the home network going; and then try to add the broadband connection back in. If all fails I will look into a router.
    Friday, May 21, 2010 3:45 PM
  • This annoying "feature" is also present in Windows Server 2008 and needs to be fixed pronto.

    I'm was trying to configure a RRAS router on my Hyper-V server and the stupid piece of crap was insisting that the local area connection is an "unidentified network" because it has a fixed IP (10.1.1.x/24) with no default gateway.

    My PPPoE connection to the big bad Internet is fine though because it is "identified" so I can set it to private...wonderful.

    My initial work around was to set public interfaces as "Private" and import the settings as rules from the existing "Public" interfaces and then turn off the public firewall rules.

    The other (better) option is to attach the interface to an el cheapo home router with DHCP etc... let it identify change the network type to private then disconnect it and revert the IP settings to what they should be.

    There should be some other way of doing this even if it's from a command line.

     


    Steve Buckley

    "Network" seems to be entirely based on "Default Gateway" setting.

    As soon as you remove or change it then the adaptor drops out of your allocated group.

    This feature REALLY sux if you are building a Windows based router.

    • Edited by MrNecros Monday, April 25, 2011 9:00 PM Additional Info
    Monday, April 25, 2011 8:49 PM
  • Although this might be answered i would like to share my experience too.. 

    If the text public network is not a link and you cannot change it there is another way..

    Go to run type gpedi.msc

    2.Computer configuration

    3.Windows settings - security settings

    4.Network List manager policies

    and there from the list of network Names you can go for the properties and select the Location type and even assign user permissions to change the location.


    Thanks and Regards Mohamed


    Thanks and Regards Mohamed

    Monday, October 22, 2012 5:58 AM
  • What you have written is the same as secpol.msc. I followed all the instruction you can only change the Network Name but nothing else nomatter what you set Public or if you give permission to anybody nothing gets changed. Do you have any other ways. I do not know if I have to re-start my comp or not I have not done it yet. But I changed Network Name "Network 2 to my choice" it worked.

    Needed Help and Knowledge.

    Sunday, November 18, 2012 4:16 PM