Basic Data Mining Tutorial - Lesson 6 Problem


  • I was working through the Basic Data Mining tutorial for SQL Server 2008 R2, and everything seemed to be working fine up through Lesson 5.  I encountered a problem in Lesson 6, however (

    In Step 9 of the Mapping the Columns section of Lesson 6, I'm unable to find the calcAge column in the Table Column dropdown in the Modify Connections window accessed via the Mining Model Prediction tab under the Targeted Mailing.dmm [Design] tab.  When in the Targeted Mailing.dsv [Design]* tab, the ProspectiveBuyer DataTable appears with the calcAge field listed as the final one (and with what must indicate a calculated field icon), so it appears as though I'd been able to successfully add that field in Step 7.

    Does anyone have any ideas?  I'm afraid that I'm stuck in the water in the meantime.


    Wednesday, January 12, 2011 10:39 AM

All replies

  • Just in case it might be of further help:

    • vTargetMail and ProspectiveBuyer appear as DataTables in in the Targeted Mailing.dsv [Design]* tab.  calcAge is the last field shown in ProspectiveBuyer.
    • TM_Decision_Tree appears in the Mining Model box, while ProspectiveBuyer appears in the Select Input Table(s) box in the Mining Model Prediction tab of the Targeted Mailing.dmm [Design] tab.  calcAge is not shown as a field in ProspectiveBuyer.

    I could well be overlooking or not understanding something, but haven't been able to figure out what it is.  As best as I can tell, I think that I've followed the tutorial steps properly.

    Wednesday, January 12, 2011 7:28 PM
  • In Step 4 of the previous section of Lesson 6 (Creating the Query section), Adventure Works DW2008R2 is given as the Data Source list item to select.  I wonder if the intent of the exercise was to have used Targeted Mailing, instead.  Both actually contain the ProspectiveBuyer (dbo) Table/View Name.

    I'm definitely just learning, so have at least some doubt since a number of people must've previously gone through this tutorial and I've not been able to find any similar reports on this issue after a cursory look, but it could be buried elsewhere.

    Do the tutorial authors read these forums?  If not, is there another way to reach them directly or another forum in which to post?  Community Content can be added to each tutorial page, but it's clearly stated in its FAQ that questions such as these are not to be included there and must instead be added on the "forums (", this being only one of a number listed.  It unfortunately makes it harder to flag the attention of people who might be in a convenient position to answer.  There's no direct link to follow between the two, which would be nice.  Just a future suggestion/wish for better integration between the tutorials and forums . . .

    Anyway, I'd be grateful if anyone were in a position to be able to confirm or deny the Targeted Mailing Data Source issue.  If a mistake was made, the tutorial writeup should also be corrected.

    Thanks very much.

    Thursday, January 13, 2011 1:45 AM
  • Finally, under the Designing the Prediction Query section, Step 3 under To run the query and review results simply indicates to "Click Save to save the results."  However, a Save Data Mining Query Result window opens, asking for information.  Guidance should be given for how to respond to Data Source, Table Name (including Overwrite if exists checkbox), and Add to DSV fields within it.

    I found that some of the data results obtained throughout the entire tutorial were sometimes a bit different than what was stated.  Is it possible that the tutorial for a previous SQL Server edition was attempted to be updated without fully going through the new release?

    Despite the several problems, the information provided within the tutorial was indeed helpful, but just needs to be reviewed step-by-step and cleaned up.

    Again, I'm posting questions/comments here, but don't know if they'll fall on deaf ears.  Just trying to be helpful with feedback and to obtain clarification from those more experienced in order to aid my understanding.

    Thursday, January 13, 2011 8:12 AM
  • I had the same problem,, just remove the ProspectiveBuyer table from the "Select Input Table(s)" box, and add the ProspectiveBuyer table again...

    Regarding the difference between expected results and what was stated in the tutorial, I did not find any.


    Wednesday, May 25, 2011 10:30 PM
  • Thanks for the detailed feedback! Writers do review the forum comments, though often we are not in a position to update the content right away, because of competing priorities.

    And you are correct that the writing team did *not* rework the tutorials for 2008 R2 release, simply because there were no new data mining features that should have affected the tutorial.

    However, I'll take a look at the procedures and see if they can be improved.

    BTW, I think if you are finding an issue with the content it is fair to add it in the Community Content, so that others can see the solution.

    But forums are good too.

    Thanks again for calling this to our attention and sorry for the inconvenience.

    SQL Server UE, Data Mining
    Tuesday, June 28, 2011 9:20 PM
  • So, I'm not able to see 'calcAge' even after removing and adding the ProspectiveBuyer table in Select Input Table ... this is not good, and somebody needs to change this in the tutorial asap.
    Thursday, July 14, 2011 2:18 PM
  • Great feedback -- thanks!

    In BI Dev Studio for 2008 and 2008R2, if you open a data mining project, then make changes to a data source view (like adding a calculated column), the changes in the data source view are not automatically reloaded. This is an issue that seems to have been fixed for SQL Server 2012. Sorry about that -- I find it inconvenient too...

    I've updated the tutorial for SQL Server 2008 R2 to include the workaround on refreshing the data source view, and also described the procedure for using the Save to Data Source option, including some gotchas and requirements.

    BTW, the data has changed somewhat in the data warehouse included with AdventureWorksDW 2012. Another writer discovered that several months of data were missing and updated the sample. Unfortunately that changed the results for several models, so there *really* are differences in the tutorials for 2008 R2 and 2012.

    Just be aware of this and use the sample database and tutorial that matches your version of SQL Server.

    SQL Server UE, Data Mining

    Tuesday, May 08, 2012 6:23 PM
  • So where exactly is this fixed quoted below

    "I've updated the tutorial for SQL Server 2008 R2 to include the workaround on refreshing the data source view, and also described the procedure for using the Save to Data Source option, including some gotchas and requirements."

    I am using SQL Server 2008 R2 and facing the view calAge after trying every possible fix. help

    Thursday, June 07, 2012 10:12 PM
  • Ack! You're right. For now, you can view the tutorial for 2012.

    In general, BOL updates are delayed for older versions. So while I try to make changes to all versions that it applies to, for 2008 R2 the actual update on documentation on MSDN might not happen until there are other significant changes, such as a patch. (Yes, we are trying to get the ability to update topics one-off but don't have that yet. Sorry!)

    So in this case to get the updated description, use the latest tutorial. I added a link in Community Content for the 2008 R2 topic, to the 2012 topic.

    Essentially, the answer is that changes in the DSV are not propagated as one would like and expect; you have to close and reopen the project to get the updated list.

    SQL Server UE, Data Mining

    Friday, June 22, 2012 5:14 PM
  • Hello,  I have tried the process outlined here:  Yet, I am still not seeing the calcAge column.  Below are the details of what I am working on:

    • Tutorial:
    • Database: SQL Server 2012
    • Visual Studio: 2010 Shell

    Is this issue resolved somewhere?

    Thanks - Brett

    Sunday, January 13, 2013 10:23 PM
  • Hi, Brett. I saw your post a few days ago and wanted to assure you that we are not ignoring you!

    I want to clarify before I try to repro:

    1. You downloaded the 2012 sample databases, using the environment described above.
    2. You created the CalcAge column using the Data Source Designer.
    3. You saved the project and closed it.
    4. You reopened the solution ....but CalcAge is still not available.

    Is that right?



    (And now I see a typo: mode for model. Gotta fix that too!)

    SQL Server UE, Data Mining

    Friday, January 18, 2013 9:07 PM
  • Good Morning,

    Thank you for getting back to me!  Yes, that is correct.  I also noticed that when I add the calcAge column, the DB table is not updated even after I rebuild.

    Brett L. Baloun
    Saturday, January 19, 2013 4:52 PM
  • Brett:

    I walked through it on a fresh machine. I'm not sure what's going on with your setup, but I am able to see calcAge, if I refresh the project by closing Visual Studio and then reopening it. Note that CalcAge should be in the Input table side, not the model side.

    If closing and reopening doesn't work, also try removing the input table by clicking Remove Table, and then re-adding it.

    Then let me know what happens.



    P.S. I might alter the tutorial so that all the columns used for prediction are ready *before*you start building the prediction query. Having to close and reopen the solution is annoying at any time, but right in the middle of a procedure is not good.

    SQL Server UE, Data Mining

    Wednesday, January 23, 2013 4:34 PM
  • Hi Jeannine,

    Thank you for your continued support.  Unfortunately, I am still having issues.  Would you be willing to do a screenshare so you can explain what I am doing wrong?

    Thanks - Brett

    Sunday, January 27, 2013 8:09 PM
  • Sure, Brett. Send me email at ( -- **) and we will set up a time.

    SQL Server UE, Data Mining

    Monday, January 28, 2013 9:59 PM
  • I was having this problem as well. 

    In instruction #9 where it says to re-open the Modify Connections window - In the Select Table dialog box, in the Data Source list, the Data Source should be the "Targeted Mailing" mining structure, not Adventure Works DW Multidimensional 2012.  Then In Table/View Name, select the ProspectiveBuyer (dbo) table.  Since this is from the mining structure, it contains calcAge. 

    Wednesday, June 12, 2013 3:30 AM
  • Thanks Laura!  Unfortunately, I cannot validate this because my 2012 trial license expired, but I do appreciate your response!
    Tuesday, June 18, 2013 2:47 PM