none
Remote Desktop Focus RRS feed

  • Question

  • I recently discovered, while in a full-screen RDP session, Ctrl+Alt+Home snaps the focus back to the local machine. I usually have multiple RDP sessions open at once. With Win10, I've found that Ctrl+Alt+Home brings the focus back to my local machine, but when I Alt+Tab to another RDP session and use WinKey+R to open the "Run" box on the remote machine, the "Run" box opens on my local machine, not the remote machine.
    Wednesday, August 26, 2015 3:24 AM

Answers

  • Hi RonaldGould,

    Apologize for the late reply.

    I think the Alt + Tab may cycle to the RDP session with no full screen mode, that might cause the Win + R only work at host.

    The issue here also traps me, as I can't reproduce this at my side.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, September 7, 2015 9:52 AM
    Moderator

All replies

  • Hi RonaldGould,

    Thanks for your sharing.

    For me it seems to be a normal behavior, as we have already bring the focus out of the RDC session.

    To make it focus back, we need to take a click in the Remote desktop.

    I will do some tests on Windows 8.1 and the Windows 10 machines, if any update, I will update here.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, August 27, 2015 9:39 AM
    Moderator
  • Nope.

    I can recall on Win 8 and 7 using Ctrl+Alt+Home to snap the focus back to my local machine, then Alt+Tab to cycle to another RDP session and let go of the keys with the focus being in the other RDP session. This was all done without touching the mouse.

    Monday, August 31, 2015 1:09 AM
  • Hi RonaldGould,

    I tested under Windows 8.1, the symptom is Win + R (or the other shortcuts) would work in remote connection only when the session is full screen mode. This is the same for both Windows 8.1 and Windows 10.

    Did we make any configuration settings under the RDC for Windows 10, like redirect or something else?

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, September 1, 2015 8:01 AM
    Moderator
  • No, standard configuration.

    Going back to the original post, Win+R works in a full screen RDP session. When I Ctrl+Alt+Home to bring focus back to the local machine, then Alt+Tab to cycle to another RDP session, the focus isn't on the remote session, it's still on the local machine.

    Think of it like this. Ignore the fact that I'm using remote desktop. I'm using one instance of program A. I Alt+Tab to another instance of program A. However, any keyboard shortcut I use isn't hooked to the active window, rather to the OS. If I use the mouse and click inside program A, I can then use keyboard shortcuts.

    Tuesday, September 1, 2015 7:24 PM
  • Hi RonaldGould,

    Apologize for the late reply.

    I think the Alt + Tab may cycle to the RDP session with no full screen mode, that might cause the Win + R only work at host.

    The issue here also traps me, as I can't reproduce this at my side.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, September 7, 2015 9:52 AM
    Moderator
  • Sorry, but the marked Answer is not correct.

    After Ctrl+Alt+Home, the focus is never returned to a full screen mstsc session.  That is the problem.

    Sunday, July 29, 2018 4:38 PM
  • If Ctrl Alt Home takes you out of RDP, then using deductive reasoning, Dun Dun Dun Duuuun (trumpet sound)  

    then Ctrl Alt Tab , takes you back into RDP!  (with an additional enter key press, lol)


    Thursday, July 11, 2019 6:27 AM