Attachment size limit with exchange 2007 RRS feed

  • Question



    How do I increase the 10 mg limit of an email message in exchange 2007?

    Thanks in advanced.

    Tuesday, May 1, 2007 9:29 PM


All replies

  • Have a look at the following Technet article on managing message size limits.



    At a minimum, I believe that you will need to modify the values in Active Directory, on the Transport Config, and on the Receive/Send Connectors.

    Wednesday, May 2, 2007 6:41 PM

    Great !!!


    Thanks a lot.

    Thursday, May 3, 2007 6:22 PM
  • I have been tackling this issue ever since I upgraded from Exchgange 2003 to 2007. I searched everywhere and all that I came up with was that I needed to modify the settings through ADSI Edit on my active directory under configuration/Services/Microsoft Exchange/Company/Global Settings/Message Delivery and modify delivContLength and submissionContLength to my desired value. I have done that. And at the shell if I type the get command it shows 150MB. I have no limits on my individual mailboxes. A collegue made the above changes and his works. The only difference was his installation was a new exchange environment whereas mine was an upgrade fromm 2003. Any ideas where else I need to make a modification.





    Thursday, June 28, 2007 3:07 PM
  • Sam, in your case, the exchange 2007 install, recognized that there was no limit on your transport sizes and set them to 10Mb. If you still have your exchange 2003 server around, you can use ESM to set the size limits back to unlimited.


    Global Settings ->Message Delivery->Properties->Defaults Tab.


    If no exchange 2003 server exists, you have to Use ADSI Edit.


    Configuration->CN=Configuration..., CN=Services, CN=Microsoft Exchange, CN=(org name), CN=Global Setings->Message Delivery properties->Attribute Editor Tab.


    delivContLength - which is incoming message size limit(MaxReceiveSize)

    submissionContLength - which is receiving message limit(MaxSendSize)

    msExchRecipLimit - which is the max number of recipients(MaxReceiveEnvelopeLimit)


    Here's a doc that explains it better than I can.




    Hope this helps.





    Friday, September 28, 2007 5:02 PM
  • I actually resolved my issue by calling Microsoft. Apparently there was one place in the Power Shell which I hadn't changed and Exchange always defaults to the lowest setting.





    Monday, October 1, 2007 1:30 PM
  • I'm having the same problem as you had Sam, but can not figure it out. Could you please tell me the command you had to enter to make it work?




    Monday, October 8, 2007 10:01 AM
  • I can't remember which one of these I had left out, but if you make sure each of these is set to your max, it should work.


    Please find the below links for your reference


    Exchange 2007

    Managing Message Size Limits



    How to Modify the Configuration of a Send Connector




    How to Modify the Configuration of a Receive Connector




    Monday, October 8, 2007 1:28 PM
  • You need to increase the send and receive connectors.
    • Proposed as answer by IkbalKoca Thursday, January 6, 2011 4:05 PM
    Monday, September 13, 2010 9:08 PM
  • First,  increase send and receive connectors

    Set-TransportConfig -MaxSendSize 50MB
    Set-TransportConfig -MaxReceiveSize 50MB than

    edit  web.config file  where  program files->microsoft->exchange server->clientaccess->owa

    <httpruntime maxrequestlenght="size your attachment"> save file and restart exchange server . It should work.

    Thursday, January 6, 2011 4:14 PM
  • I know this is an old thread but can anyone assist me with this issue.

    I have changed

    SendConnector - 51200kb

    ReceiveConnector - 51200kb

    Using ADSI i changed

    DelivContLength - 51200kb

    SubmissionContLength - 51200kb

    I also set

    Set-TransportConfig -MaxSendSize 50MB
    Set-TransportConfig -MaxReceiveSize 50MB than


    Still when i try to attach message in Outlook 2007 or 2010. I get the message "the attachment size exceeds the allowable limit"


    What am i missing? I don't know what else to do to get this working. Any help will be greatly appreciated

    • Proposed as answer by T350Z Friday, May 11, 2012 5:31 PM
    • Unproposed as answer by T350Z Friday, May 11, 2012 5:31 PM
    Thursday, August 18, 2011 6:48 PM
  • Did you make sure the user doesn't also have a limit being enforced on their mailbox? Check Mail Flow Settings tab > Message Size Restrictions. Instead of leaving it blank (use defaults), set it to 0 (unlimited).
    Friday, May 11, 2012 5:37 PM