locked
SQL server management pack, Event 7703 login failed error RRS feed

  • Question

  • I have these 4 error each 5 minutes.

    First & second:

    Managegement Group: <MyGroup>. Script: Main : 

    Exception calling "Fill" with "1" argument(s): "Login failed for user '<SCOM admin user>'."Error occured during CPU Usage for SQL Instances data source executing.
    Computer:<MySCOM Server> 
    Reason: Exception calling "Fill" with "1" argument(s): "Login failed for user '<SCOM admin user>'."

    Third & fourth

    Exception calling "Fill" with "1" argument(s): "Login failed for user '<SCOM admin user>'."Error occured during CPU Usage for SQL Instances data source executing.
    Computer:<MySCOM Server> 

    Reason: Exception calling "Fill" with "1" argument(s): "Login failed for user '<SCOM admin user>'."

    Exception calling "Fill" with "1" argument(s): "Login failed for user '<SCOM admin user>'."Error occured during CPU Usage for SQL Instances data source executing.

    Computer:<MySCOM Server> 

    Reason: Exception calling "Fill" with "1" argument(s): "Login failed for user '<SCOM admin user>'."
    Exception calling "Fill" with "1" argument(s): "Login failed for user '<SCOM admin user>'."Error occured during CPU Usage for SQL Instances data source executing.

    Computer:<MySCOM Server> 

    Reason: Exception calling "Fill" with "1" argument(s): "Login failed for user '<SCOM admin user>'."


    I have SCOM 2012 SP1 with CU3 and SQL Server MP 6.4.1.

    I had same errors when used SQL Server MP 6.4, updating it to 6.4.1 didn't fix the problem.

    Any help would be appreciated! Thanks in advance.

    GA

    Thursday, October 17, 2013 6:13 AM

Answers

  • Have you tried to configure SQL Run AS?

    Login failed looks like permission issue.

    You may follow these instructions and try to configure privileges.

    • Marked as answer by Niki Han Monday, November 4, 2013 10:52 AM
    Thursday, October 31, 2013 2:12 PM

All replies

  • I'm not attempting to hijack this thread, but I thought it would be useful  to add that I'm experiencing close to the same problem, in the same configuration - SCOM 2012 SP1 CU3; SQP Mgmt Pack 6.4.1.0 - just getting a different message. (Typos are left intact because I kinda think they're funny. "Managegement"?)

    Event Type: Error
    Event Source: Health Service Script
    Event Category: None
    Event ID: 7703
    Date:  10/18/2013
    Time:  3:23:48 PM
    User:  N/A
    Computer: [Computer Hosting SQL]
    Description:
    Managegement Group: [My Group]. Script: Main :

    Cannot index into a null array.Error occured during CPU Usage for SQL Instances data source executing.
    Computer: [Computer Hosting SQL] 
    Reason: Cannot index into a null array.

    What's interesting is that I have two installations of SCOM 2012 - one "mostly" upgraded (SP1, CU1, MP 6.4.0.0), and a second one (the one noted in this post) in a completely different environment.  The latter is monitoring SQL 2008 databases running on Windows 2003 R2 (which is where these errors are being logged), and the former is hosting SQL 2008 databases running on Windows 2008 R2 SP1, where *no* errors are being logged.

    I'd be interested to hear if the target SQL servers for the thread owner are also running on Windows 2003 as there might be a connection.

    -Todd

    Friday, October 18, 2013 8:59 PM
  • My SQL Servers(2008) are running on Windows 2008 R2.
    Monday, October 21, 2013 3:00 AM
  • Hello

    I have the  4 same errors on Instances SQL2012 , instances on SQL2008/2008R2 didn't report the errors.
    This errors appears on our Systems since import of SQL MP 6.4.x.x

    For us SQL MP 6.4.1.0 and System Center Update Rollup 4 didn't fix the errors.

    Any sugestion or idea?

    cordially

    Wednesday, October 30, 2013 1:21 PM
  • Have you tried to configure SQL Run AS?

    Login failed looks like permission issue.

    You may follow these instructions and try to configure privileges.

    • Marked as answer by Niki Han Monday, November 4, 2013 10:52 AM
    Thursday, October 31, 2013 2:12 PM
  • Dear galeksei:

         have you solved your problem?how did it work? I meet the same quetion too .

    Thursday, May 11, 2017 7:11 AM