none
Novell Groupwise Version 7.0 RRS feed

  • Question

  • I'm working on a lab with about 20 computers and wanting to use steady/state to restrict some applications and settings within windows.  Everything seems to be working ok except Novell Groupwise.  When I try to open groupwise it tells me that it is restricted and I can't get into it at all.

     

    Access to C:\Novell\GroupWise\grpwise.exe has been restricted by your Administrator by the default software restriction policy level.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    What do I do to get access to this application?  Any ideas?

     

    Thanks!

    Thursday, July 19, 2007 2:26 PM

Answers

  • Hi Adam,

     

    What East-TN NSC said is right on the target. Please double check whether the “Allow only programs in the program files and windows folders to run” option is checked. Meanwhile, please check whether the software is in the SteadyState Block Programs list:

     

    1.     Open SteadyState.

    2.     Click your username and then click Block Programs tab.

    3.     Check if Novell Groupwise is in the Block Programs. If so, please remove it from the list.

     

    The restriction is implemented via Software Restriction policy registry keys. If this problem continues, please logon as the problematic user and check its policy:

     

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers]

     

    For each software restriction policy, there is a corresponding subkey, such as [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers\262144]. The Paths registry keys contain path allowed. If it exists, please backup and then delete the subkey, such as 262144, and then test this issue again.

     

     

    If this problem continues, please help us collect the following information:

     

    1.     Can you run Groupwise properly if you configure “No Restriction” in the “Windows Restriction” and “Feature Restriction” tabs? In this way, we can isolate SteadyState restriction issues.

    2.     Please export and save the [HKEY_CURRENT_USER\Software\Policies] registry key of a problematic user to a registry file.

    3.     Please logon as administrator and run the following command to collect group policy information:

     

    Gpresult /z >c:\gpresult.txt

     

    Please send the information to v-robeli@microsoft.com with subject: Novell Groupwise Version 7.0.

     

    I am looking forward to hear from you.

     

    If you need further assistance, please don’t hesitate to let me know.

    Monday, July 23, 2007 6:14 AM

All replies

  • By default I think that Groupwise is installed in a Novell folder off the the root directory.  SteadyState has a setting that will not allow programs to run unless it is in the Program Files Folder or Windows Folder.  There are two things you can do.

    1. Re-install Groupwise so that it installs in the Program Files folder

    2. Or allow programs to run outside of the Programs Files or Windows folder.  You can find this option under the Windows Restrictions tab in SteadyState.  Look under the General Restrictions section and uncheck the option ALLOW ONLY PROGRAMS IN THE PROGRAM FILES AND WINDOWS FOLDERS TO RUN.  This is not as secure as the first option as other programs can be run off CDs, USB drives, etc. 

     

    Hope this helps.

    Thursday, July 19, 2007 3:44 PM
  • Hi Adam,

     

    What East-TN NSC said is right on the target. Please double check whether the “Allow only programs in the program files and windows folders to run” option is checked. Meanwhile, please check whether the software is in the SteadyState Block Programs list:

     

    1.     Open SteadyState.

    2.     Click your username and then click Block Programs tab.

    3.     Check if Novell Groupwise is in the Block Programs. If so, please remove it from the list.

     

    The restriction is implemented via Software Restriction policy registry keys. If this problem continues, please logon as the problematic user and check its policy:

     

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers]

     

    For each software restriction policy, there is a corresponding subkey, such as [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers\262144]. The Paths registry keys contain path allowed. If it exists, please backup and then delete the subkey, such as 262144, and then test this issue again.

     

     

    If this problem continues, please help us collect the following information:

     

    1.     Can you run Groupwise properly if you configure “No Restriction” in the “Windows Restriction” and “Feature Restriction” tabs? In this way, we can isolate SteadyState restriction issues.

    2.     Please export and save the [HKEY_CURRENT_USER\Software\Policies] registry key of a problematic user to a registry file.

    3.     Please logon as administrator and run the following command to collect group policy information:

     

    Gpresult /z >c:\gpresult.txt

     

    Please send the information to v-robeli@microsoft.com with subject: Novell Groupwise Version 7.0.

     

    I am looking forward to hear from you.

     

    If you need further assistance, please don’t hesitate to let me know.

    Monday, July 23, 2007 6:14 AM