locked
UAG NLB never worked for me RRS feed

  • Question

  • I am setting a two node UAG cluster to publush SHarepoint.

    Below is my ENV.

    Tow nodes are phisical servers.

    both upgraded to UAG SP3.

    External NIC are facing internet(PUB IP)

    Internal NIC no default Gateway.

    use UAG Integrated NLB( no hardware NLB involved)

    Array setup was successful, and I can see two nodes in Web Monitor.

    but the second node status UNKNOWN.

    if I check this from WIndows NLB console, there is an error: second node RPC server is not available.

    obvously there is communication problem between the two nodes.

    pingable from each other though.

    first node is converged and Synched, and Sharepoint works fine through the portal truck.

    disjoined the Array and rejoined the Array just using the same Domain Netbios name only. but No luck.

    I have been trying to figure out by testing this in virtual environment (NIC set to detect VLAN) . just no luck.

    Any Idea?

    Thank you in advance,

    John


    Wednesday, May 22, 2013 5:34 PM

All replies

  • Hello,

    Which Hypervisor did you use ?

    Regards,


    Follow me on Twitter http://www.twitter.com/liontux | My Blog (French/English) : http://security.sakuranohana.fr/

    Thursday, May 23, 2013 9:56 AM
  • They are physical servers.
    Friday, May 24, 2013 7:11 PM
  • If there are any firewalls between the two nodes, make sure they are allowing everything. Also, when you establish NLB the NIC's MAC addresses are replaced with virtual MAC addresses. This can confuse many different types of switches. It is pretty common after establishing NLB that you lose connectivity because your switches are holding onto ARP cache for the old MAC address, but the devices are now trying to communicate using new MACs. So if your switch has an option to clear ARP cache, give that a try.

    Also make sure you are using Unicast as the NLB mode in the UAG settings, that is the only supported method for UAG trunk activity.

    Friday, May 24, 2013 7:50 PM
  • We tried that. No change.

    Thanks Jordan,

    John

    Tuesday, May 28, 2013 4:43 PM