locked
Store button missing/greyed in Outlook 2016 with Exchange 2013 on Server 2008 R2 RRS feed

  • Question

  • Hi there,

    I've done web searches for solutions to this problem, but so far I haven't found anything to help me resolve this. I've managed to get this working on Server 2016, but I'm hoping that isn't the only solution for this. Things I've tried are:

    1. Check GPOs for any policies hiding/disabling the Store button. There are none.
    2. Created key HKCU\Software\Microsoft\Office\16.0\Outlook\Options\Webext and DWORD StoreButtonInRibbonHomeTabAllowed with value for 1. Originally for Outlook 2013, but I thought I may as well try.
    3. Adding the button manually to the ribbon and quick access toolbar. The button appears but is greyed out.
    4. Fully updated the OS and Office.

    Any help is greatly appreciated.

    Thanks,

    Simon

    • Edited by Core Desktop Tuesday, April 24, 2018 12:11 AM Clarity
    • Moved by Manu Meng Tuesday, April 24, 2018 6:55 AM relocate
    Monday, April 23, 2018 12:28 AM

Answers

  • Hi Yuki,

    I've figured it out. With the above tests, I was connecting to a mailbox from my admin account by adding it as an account in Outlook. My admin account does not have a mailbox. With this setup, the Store button doesn't appear at all.

    If open up a mailbox within the mailbox owner's session, the Store button does appear, but not immediately (or automatically). I add the Store button manually via the Customize Ribbon feature. Upon doing that, one of two things will happen.

    1. The "actual" Store button appears straight away alongside the manually added one.
    2. The "actual" Store button does not appear, and the manually added button is greyed out. After letting it site for several minutes (around 10 or more) I interact with Outlook at the "actual" Store button appears and the manually added button is coloured in.

    So the Store button does work, but it is extremely flaky.

    Hope this helps someone.

    Cheers,
    Simon
    • Marked as answer by Core Desktop Monday, April 30, 2018 1:16 AM
    Monday, April 30, 2018 1:16 AM

All replies

  • Have you checked GPO for Outlook 2016?

    I found a link below that might help you.

    https://answers.microsoft.com/en-us/msoffice/forum/msoffice_outlook-mso_win10-mso_o365b/outlook-desktop-2016-store-button-missing-cant-get/29e50958-5270-4137-aeb9-a05b9fc44880?auth=1

    Monday, April 23, 2018 11:57 AM
  • Hi Michael,

    I've updated my original post with steps I've tried. I should have done this from the start, but was frustrated after troubleshooting at that point. Sorry about that.

    Regards,

    Simon

    Tuesday, April 24, 2018 12:13 AM
  • Hi Simon, 

    From Exchange server side, there is not a global solution to make the store button display normally, it should be controlled by a registry key or something else related to Outlook client. To better resolve your issue, I will move the thread to Outlook IT Pro Discussions forum. Hope you can get some clues here.

    Thanks for your understandings!

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, April 24, 2018 6:53 AM
  • Hi Simon,

    Basically, the Store add-in should work for Exchange accounts in Outlook 2013 or Outlook 2016. How about trying to test with another Exchange account like an outlook.com account or hotmail.com account and check the result? 

    Besides, please try to the following steps to check if any policies are applied to outlook:

    1. Press Win+R.
    2. Type "RSOP.msc", press Enter and wait for the results. 

    Any updates, please feel free to post back. 

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, April 24, 2018 9:35 AM
  • Hi Yuki,

    I've figured it out. With the above tests, I was connecting to a mailbox from my admin account by adding it as an account in Outlook. My admin account does not have a mailbox. With this setup, the Store button doesn't appear at all.

    If open up a mailbox within the mailbox owner's session, the Store button does appear, but not immediately (or automatically). I add the Store button manually via the Customize Ribbon feature. Upon doing that, one of two things will happen.

    1. The "actual" Store button appears straight away alongside the manually added one.
    2. The "actual" Store button does not appear, and the manually added button is greyed out. After letting it site for several minutes (around 10 or more) I interact with Outlook at the "actual" Store button appears and the manually added button is coloured in.

    So the Store button does work, but it is extremely flaky.

    Hope this helps someone.

    Cheers,
    Simon
    • Marked as answer by Core Desktop Monday, April 30, 2018 1:16 AM
    Monday, April 30, 2018 1:16 AM
  • Hi Simon,

    Great to see that the issue has been resolved and thanks so much for sharing with us!!

    Have a good day :)

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, April 30, 2018 1:47 AM