Microsoft .NET Framework 4 breaks Windows Update with error code 0x8024402F RRS feed

  • Question

  • Hi guys, been using Technet as an invaluable source of knowledge for a while now and looking forward to finally using it!

    This is quite a strange one that I can't quite fathom... I recently did a format and re-install of XP Professional, activated, and started running Windows Updates. To cut a long story short, Windows Update broke and began giving me the error code: 0x8024402F whenever I tried to do a manual update. After tracing my steps, I found it was the .NET Framework 4 is responsible. This is replicable - if I uninstall the update, Windows Update runs fine. If I then re-install it, it once again breaks.

    The update that is causing this through Windows Update is actually the .NET Framework 4 Client Profile (KB982670), although I have tried installing the full .NET Framework standalone installer as well (http://www.microsoft.com/en-us/download/details.aspx?id=17718) and both have the same result. I have tried updating the Windows Update Agent, updating Internet Explorer, using Microsoft Update instead, but all leave me exactly where I started. The thing that bugs me is that I can't find anyone else having the same issue. I have searched online and tried pretty much all the suggestions, including the Microsoft support article for 0x8024402F with no success. I'm here as a last resort hoping someone will have some idea as to how to fix it. For the record, this issue isn't critical, it's more a case of wanting to know what's wrong for knowledge and experience :) The .NET Framework 4 is not needed for anything on that PC (yet), but I would also like to know the solution in case this issue arises in future. I've done full updates on fresh installs on different PCs since then and haven't had the issue come up. Very strange.

    I doubt it's of any relevance, but recently installed a WSUS server and that's where the XP machine is pulling it's updates from. The machine is a fresh install except for an installation of Firefox and full updates (.NET is the only remaining update). As a side note, I'm learning more about WSUS each day, but if you do a manual update of XP I notice IE navigates to Microsoft's update site... Does this mean that updates are being pulled from the internet rather than WSUS when updating manually? Just curious.

    Thanks in advance! Please let me know if you need any more information or need me to try anything.

    Friday, June 15, 2012 11:17 AM

All replies

  • Getting 0x8024402F (WU_E_PT_ECP_SUCCEEDED_WITH_ERRORS) from Windows Update; windowsupdate.log notes the following:

    WARNING: ECP: Failed to validate cab file digest downloaded from http://download.windowsupdate.com/msdownload/update/software/dflt/2012/02/4913552_4a5c9563d1f58c77f30d0d5c9999e4b8bff3ab21.cab with error 0x80091007

    This CAB file contains only one file, 4913552.txt; I don't understand what it all means, but "Microsoft .NET Framework 4 Client Profile" appears multiple times, so clearly whatever is wrong with this PC is closely related to whatever is wrong with yours.

    The issue is at error 0x8024402F is defined simply as "WU_E_PT_ECP_SUCCEEDED_WITH_ERRORS", but that itself is not defined, leaving me none the wiser as to what exactly has gone wrong, where, why, or how.

    PC is Win XP SP3 32-bit, clean installed from a Dell Windows XP SP3 CD in January, and .NET Framework 4 Client and Extended are both installed, probably for the sake of QuickBooks, which was installed earlier in the year, so there's no sense in me removing that: it's needed (it doesn't ship with XP, so I can guarantee you that it was installed for a reason).

    Updates have been working by the looks of it, with a whole batch being installed on the 13th, so I don't know what triggered this to stop working. I don't know that the Automatic Update service is even affected, but since there's no UI for it in XP, I can't tell.

    Monday, June 25, 2012 7:24 PM
  • Yep, now my PC does the same – I thought I'd check since I noticed that I, too, have .NET 4 Client and Extended installed. Error 0x8024402F when checking for updates using the Microsoft Update website. (I notice that it did prompt me for a replacement ActiveX component too.)

    I think it's safe to say this is a bug in Windows Update. It remains to be seen whether my PC detects any further updates automatically though!
    Thursday, June 28, 2012 9:31 AM
  • Still no resolution, still experiencing the same problem!

    @Trust Networks I can confirm that it likely will continue to receive updates automatically (it is in my case at least).

    The biggest pain with XP & Server 2003 is that checking for updates with Windows/Microsoft Update checks Microsoft for updates. As I have WSUS set up, I *DO NOT* want WU to search *Microsoft* for updates, however, unfortunately for these operating systems as opposed to Windows 7/Vista/Server 2008 it is impossible to tell it to check for updates for your configured service locations via the GUI, and the command prompt way to do it in all of the above is *@$%*# IMHO.

    However, if you want to manually trigger a detection cycle, from the command prompt, you can run "wuauclt.exe /checknow". And then depending on your AU settings, you will get a pop-up in your task bar (should be within +-10min) if there are updates available to download/install.

    My big gripe with this command, is that with whatever switches (or lack thereof) you use, it gives utterly no output as to whether it worked or not, and for that matter, whether you even typed it in correctly. It's a place to start though, and you can always check your WindowsUpdate.log for details. This can help you see if Automatic Update is working, which works perfectly for me, however, it would be nice to have some resolution as to what on earth is going on here - more for curiosity sake than anything else.


    Thursday, June 28, 2012 2:00 PM
  • The original issue looks to be fixed for me. Internet Explorer did prompt me with an ActiveX installation dialog, so either the client contained a bug and they've issued a replacement, or they've fixed the data on the server that was confusing the ActiveX control.
    Friday, July 20, 2012 9:46 AM
  • Sorry for the late reply, just saw your post now.

    Thanks for reporting back. Lucky you, issue still persists this end. After seeing your post I tried again and got the same ActiveX control installation prompt that you described, however, it did not solve the problem. I still get the same error message after installing the control.

    I would like to thank Microsoft for their timeous and helpful responses. <insert sarcasm here>
    Monday, July 23, 2012 2:49 PM
  • Don't know if the problem still persists for some people (I know the last post was a month ago), but using the fix here:


    I was able to solve the problem.

    Good luck,


    Wednesday, August 29, 2012 10:03 AM
  • Thanks for the post.

    Yes, still same problem (good thing I'm not relying on it working). I tried Method #1, ran the FixIt in the post you supplied and restarted... Still, same issue. Method #2 (Repair the .NET installation) was the first thing I tried originally with no results, so no dice there either. I'm running a repair as we speak of all .NET editions just in case, but I doubt it will make any difference. I'll post back if it does solve the issue.

    I'm at a stage now where unless someone has a bright idea on how to solve it, I'm going to leave it - it's not worth the headache. I appreciate the attempt though, thanks Frank. Just for clarification, which method worked for you, Method #1 or #2?

    Wednesday, August 29, 2012 11:57 AM
  • Hi,

    method 1 (the fixit solution) did the trick for me. My problem was caused by update KB2600017 (which is indeed for .NET 4). (That's the update that's also bugging "Trust Networks Ltd", I think). If you have a similar message in your windowsupdate.log (especially if the name of the cab file it fails to validate and "digest" is the same), maybe you could try installing this update manually, rerun the fixit and keep the fingers crossed ;).

    Good luck, Frank

    Friday, August 31, 2012 1:01 PM
  • Hi Pascal,

    I had the same issue as u said for Win 7 PCs. I first thought it would be the problem with the network in my office; because if i try to connect the PC to a mobile network...it works fine!

    I tried to check with network teams but they couldn't figure out the solution. Finally something struck my mind that it could be an issue with Microsoft .Net Framework ver 4. So here's what i did:

    I freshly prepared a Win 7 PC from DVD. Gave the 1st phase of update which consists of 127 important updates & 37 optional. I disabled the optional ones & updated. After restart, it showed the .net update. I ignored it & again checked for updates. Again some more important updates popped up. After that i installed MS-Office 2010 & again checked for updates. Again .net framework 4 showed up. I ignored it & again checked. It showed some wind,ows updates as well as Office updates. I continued like this ignoring .net framework 4 till it showed there are no more updates available except for .net 4.

    As u had said before, .net framework 4 is not tat necessary for PC, unless any application is running on its support. I have CA client application running on all PCs which requires .net framework the latest. So i installed it & then installed the application. After which i captured an image of it for deployment. But as soon as u installed the .net 4 even after all the other updates; it'll show the same error again. So my suggestion is just disable the .net framework 4 update if it's not that necessary.



    Monday, September 3, 2012 11:11 AM
  • Hi guys, sorry profusely for the (extremely) late reply.

    Still same issue, I agree with Mathew (rather grudgingly) on the fact that until (if ever - which I'm not so sure anymore) the bug with .NET FX 4 gets fixed on XP SP3, don't install if not needed. This is one of those things that I don't really need, so it doesn't make much difference, but would love to have a fix so I can know for future when experiencing the problem. Unfortunately it is not an isolated problem, but on the flip-side, it is also not a universal problem. I have worked on quite a few XP SP3 PCs since the OP, and several of them have had Windows Update broken from .Net 4, and several have carried on working quite peachy. I've seen both occur on very varied hardware and all on fresh installs done by myself with the same method, so it's a mystery to me as to the cause.

    Since said PC gets updates through WSUS (and therefore using WU kind of defeats the point), I've simply blocked the update from installing, which obviously fixes the problem, but I would be pretty ticked off if I did need it and wasn't on WSUS. I would love to see some brainiac work out some miraculous solution to the problem, but as the months go by I think the chances of that do dwindle somewhat.

    Once again, thanks to Trust Networks Ltd, fstue and Mathew Alex for your feedback - it's nice to know I'm not the only one looking for a solution. If any of you do find a solution, it would be much appreciated by me and I'm sure by anyone else who reads this post (sure there must be a few).

    Kind regards,


    Saturday, September 22, 2012 9:52 PM
  • Hi guys, 

    I updated my Vista PC to win7 and once I was done with the installation computer fully booted to the desktop. At this point a small window popped up stating to update .Net Framwork 4 as the previous version was not compatible with win7. So I clicked accept and it proceeded to update. When it was done it asked to reboot and so I did. Sadly I have not been able to get back on my laptop again. It turns on but there is NO ACTIVITY, complete black screen. 

    Wednesday, October 31, 2012 12:36 AM
  • Hi guys, 

    I updated my Vista PC to win7 and once I was done with the installation computer fully booted to the desktop. At this point a small window popped up stating to update .Net Framwork 4 as the previous version was not compatible with win7. So I clicked accept and it proceeded to update. When it was done it asked to reboot and so I did. Sadly I have not been able to get back on my laptop again. It turns on but there is NO ACTIVITY, complete black screen. 

    Well... Seeing as this is an XP SP3 topic, I sincerely doubt it's at all related, and from what it appears, Technet admins seems to like ignoring XP issues, so your question would probably be much better off in a Windows 7 thread. With that being said though...

    To confirm - did you perform an in-place upgrade from Vista to 7, or a fresh install? When you say you get a black screen - when does this occur: straight out of the bios, or after you've seen the windows loading screen? Or for that matter, do you see the bios checks at all?
    Wednesday, October 31, 2012 7:14 AM
  • Same issue on Windows 7 Ultimate 32-bit. I tried every possible solution, including the various Microsoft Fix-it wizards for Windows Update: no joy. I clean-reinstalled the entire OS. Again, at some late point in the update process, Windows Update makes you install the .NET Framework 4 Client, and, after that, either it checks for updates  forever, or it stops and displays Error 0x8024402F. The only workaround I have found is to uninstall each and every .NET Framework program and then hide all the .NET Framework updates in Windows Update until such time as Microsoft addresses this issue with a REAL fix.
    Saturday, August 3, 2013 9:38 AM
  • Tried cleaning dot net with MS dot net cleanup utility?

    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sunday, August 4, 2013 4:19 PM
  • Ive been searching ages for a thread like this as thought this bug only applied to me for some reason. Dont install windows live essentials either. It secretly installs the damn netframework4 in the background and broke my windows update again!! System is ok after system restore thank god. Just stay away from net4 until they fix!!

    Very annoying problem

    Im glad its not just me :p

    Monday, August 5, 2013 6:19 PM
  • Does cleaning works? I have seem win xp and 7 systems with this issue and I'm able to fix them after .net cleanup. 

    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, August 8, 2013 3:44 AM
  • Just piling on so hopefully some kind of resolution is released. I am currently trying build a new Win7 SP1 base image for our SCCM OSD set up.  With a fresh install of Win7 SP1 windows update online works and pulls down something like 130 updates. I then install .net 4 (client and extended) and windows update online just sits there "checking" forever. I also noticed on a fully built machine that checks into our WSUS server on site, checking online also does not work. I have emailed my TAM about it and hopefully MS is aware of these rumblings. Thanks.
    Thursday, August 15, 2013 2:42 PM

  • @axeshr3dder Just a hunch, but I encountered a similar issue a while ago.

    For starters, can you conclusively say it's .NET doing that? i.e. if you uninstall .NET 4 does it resolve itself?

    In my situation the 'Windows update stuck on checking for updates' and 25% CPU usage on Windows 7 ended up (weirdly enough) on 2 machines being caused by Microsoft Security Essentials... If you have MSE installed in the base image, I would suggest uninstalling it and trying again.

    Strange part is... With the PC with MSE checking for updates from Microsoft, it worked. However, with MSE and checking from the WSUS server, it produced this error. Makes no sense to me and I still don't understand the logic, but it worked nonetheless.

    Hope this helps

    Thursday, August 15, 2013 4:35 PM
  • I have not tried removing .net 4 to see if it returns to a working state on my base image but can try. Just seemed weird that it worked right before installing .net 4. I build base images a lot using this same process and have never had this happen until now. As an FYI, my CPU is sitting at 99% idle during the "checking". Also, I do not have MSE installed. The base image is literally Win7 SP1, Office, Visio, and Project 2010. I did notice on my fully built machine, checking online eventually finished but it took about 2 hours haha. I will follow up. Perhaps I'm just not being patient enough.

    Thursday, August 15, 2013 5:12 PM
  • I think I lied. On my base image it seems that online windows update checking breaks after I choose the "windows and other products" bit. Windows update works for just windows. When I add other MS products so that I can patch Office, it stops working.
    Monday, August 19, 2013 1:45 PM
  • Anyone tried cleaning up and then reinstalling .net?

    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, August 19, 2013 3:38 PM
  • @Arnav Sharma Not sure about the others, but I know I definitely tried it. Uninstall and re-install, The Microsoft .NET Cleanup tool, full on format and re-install (was a fresh install anyways), installing the .NETs and updates in different orders, the .NET troubleshooter FixIt... Pretty much everything I could think of with no luck. That being said, the PC that had this issue is no longer in existance and all PCs are now Windows 7 and not experiencing the issue, so I don't really need a fix. I'm surprised at how many people have experienced this same issue here on Windows 7 though :?

    @axeshr3dder To be honest with you, until I found my resolution with my Windows update not updating due to MSE, I had utterly no idea where the problem was. Now, to others experiencing the same issue, I'm tempted to point my crooked little finger at Microsoft products when this issue occurs. The fact that, from what it sounds like, that you only have Microsoft products on there is to me a sign... Maybe just give it a bash getting rid of a few microsoft products/updates 1 by 1 and see if the issue persists. If not - you're sorted, and if it does, then you can just re-install them and isolate the troublesome one - no harm no foul.
    Wednesday, August 21, 2013 2:52 PM
  • The same problem here. I need .NET Framework 4 for our CCTV software. It has been running for a couple of years now but we had to restore the system on one machine. After installing .NET Framework 4 it is not possible to have any updates. Windows Update web site returns 0x8024402F all the time. On old machines updates work OK with .NET Framework 4 installed. I replicated the problem on another PC. Fresh XP install, then drivers and updates. It ALWAYS fails. Windows XP should be supported till April 2014 but it appears that they want to get rid of it earlier :(

    Update: Now I have the same problem with Windows 7 Pro 32bit. However, I left some useless updates (NVidia, Logitech, browser choice) and I am able to download and install it. Checking for new updates fails with the above error.

    Last night I installed Windows 7 Pro 64bit on one machine. All updates and .NET Framework 4 included - no problems with updates - everything works as it should.

    • Edited by SmokWawelski Tuesday, September 10, 2013 2:53 PM update
    Monday, September 9, 2013 3:38 PM
  • Same here, having loads of trouble with .NET 4 Client Profile, as soon as I install it on various laptops/PC's, I can no longer access WU, it returns with the above error.

    In the end I have chosen to hide .NET 4 Client & install .NET 4.5 instead....

    Sunday, September 29, 2013 8:37 AM