locked
Com surrogate error network ethernet RRS feed

  • Question

  • Hi 

    Every time I try to edit my network ethernet card in windows 8.1 x64. Even if I set a manuel address or put it in dhcp mode. I received a error saying com surrogate has stop working. I tried putting dllhost.exe into dap and registering dll but I still get the error message and every stop functioning. Anyone have an idea on how to fix this ?

    Thanks

    Monday, January 6, 2014 11:37 PM

Answers

  • Hi,

    Regarding current information, this issue could be caused by driver conflict.

    I suggest installing the latest network adapter driver from manufacturer’s web site, and check the issue again.

    To avoid 3<sup>rd</sup> part conflict, please help to test the issue in Clean boot:

    How to perform a clean boot to troubleshoot a problem in Windows 8, Windows 7, or Windows Vista

    http://support.microsoft.com/kb/929135   

    If the issue doesn’t appear, you can determine which one can be the cause by using dichotomy in MSconfig. Checking on half of Non-Microsoft service and restart, determining which half of the services cause the issue and repeating to check half of the problematic half services.

    If the issue still persists in Clean boot mode, please try safe mode to see what’s going on:

    How to easily enter safe mode in windows 8? (One-click series)

    http://support.microsoft.com/kb/2809468

    For further research, please upload your event log into SkyDrive or similar ones and shared the public link with us.

    Keep post.


    Kate Li
    TechNet Community Support

    • Marked as answer by kelvin_hsu Tuesday, January 21, 2014 5:40 AM
    Wednesday, January 8, 2014 1:16 PM