none
The remote server returned an error: (500) Internal Server Error. An error occurred while processing this request RRS feed

  • Question

  • Hi Experts,

    I have a share point site with list and libraries.All list and libraries working fine in Power BI for reporting except one library.when i connect this library with Power BI then the below error occurred.

    DataSource.Error: OData: Request failed: The remote server returned an error: (500) Internal Server Error. (An error occurred while processing this request.)

    Details:
        DataSourceKind=OData
        DataSourcePath=http://xxx.xyz.edu.pk/_vti_bin/listdata.svc/ProjectDocuments
        SPRequestGuid=846c939f-118f-j9fd-cea5-0312cfd86f8
        Url=http://xxx.xyz.edu.pk/_vti_bin/listdata.svc/ProjectDocuments

    Tuesday, July 26, 2016 5:14 AM

Answers

All replies

  • Hi Najeeb. You'll probably need to collect a network trace using a tool like Fiddler and send us a Frown (with the trace attached).

    Thanks,

    Ehren

    Tuesday, July 26, 2016 11:19 PM
    Owner
  • Hi Ehren,

     Below is the result of fiddler.

    HTTP/1.1 500 Internal Server Error
    Cache-Control: no-cache
    Content-Length: 126
    Content-Type: application/json
    Server: Microsoft-IIS/7.5
    X-SharePointHealthScore: 0
    DataServiceVersion: 1.0;
    X-AspNet-Version: 4.0.30319
    SPRequestGuid: f7cf939d-f143-f0fd-cea5-9399248c6312
    request-id: f7cf939d-f143-f0fd-cea5-9399248c6312
    X-FRAME-OPTIONS: SAMEORIGIN
    SPRequestDuration: 213
    SPIisLatency: 0
    X-Powered-By: ASP.NET
    MicrosoftSharePointTeamServices: 15.0.0.4420
    X-Content-Type-Options: nosniff
    X-MS-InvokeApp: 1; RequireReadOnly
    Date: Wed, 27 Jul 2016 05:27:40 GMT

    {
    "error": {
    "code": "", "message": {
    "lang": "en-US", "value": "An error occurred while processing this request."
    }
    }
    }

    Wednesday, July 27, 2016 5:37 AM
  • Hi Najeeb. Please send a frown and attach the full Fiddler trace. We'd need to see more of the context (e.g. what we sent to the server which led to this response).

    Thanks,

    Ehren

    Wednesday, July 27, 2016 9:38 PM
    Owner
  • Hi Ehren,

    Thanks for your kind support. I have just deleted the calculated column from my share point site library  then the problem solved.

    Solution link

    http://sharepoint.stackexchange.com/questions/65902/listdata-svc-gives-a-500-error-when-querying-some-lists

    • Proposed as answer by PoojaDhamija Wednesday, May 3, 2017 8:12 AM
    Tuesday, August 2, 2016 8:41 AM