locked
nVIDIA driver installation is repeated infiniteley on VISTA SP1 x64 RRS feed

  • Question

  • Hello,

     

    I'm running VISTA SP1 x64 on my DELL XPS M1530.

     

    Windows Update downloaded the latest NVIDIA Driver for the 8600M GT. After the reboot, every time I logon

    the system prompts me to complete the driver install...and it does this every time I logon. So the install

    never finishes correctly...

     

    I had a look at the Log-File "C:\Windows\inf\setupapi.dev.log". Here's an excerpt - I marked the section with the

    error with RED color:

     

    >>>  [Finish Install Action - PCI\VEN_10DE&DEV_0407&SUBSYS_022E1028&REV_A1\4&233A497C&0&0008]
    >>>  Section start 2008/09/30 07:38:10.774
         dvi: {Build Driver List} 07:38:10.774
         dvi:      Searching for hardware ID(s):
         dvi:           pci\ven_10de&dev_0407&subsys_022e1028&rev_a1
         dvi:           pci\ven_10de&dev_0407&subsys_022e1028
         dvi:           pci\ven_10de&dev_0407&cc_030000
         dvi:           pci\ven_10de&dev_0407&cc_0300
         dvi:      Searching for compatible ID(s):
         dvi:           pci\ven_10de&dev_0407&rev_a1
         dvi:           pci\ven_10de&dev_0407
         dvi:           pci\ven_10de&cc_030000
         dvi:           pci\ven_10de&cc_0300
         dvi:           pci\ven_10de
         dvi:           pci\cc_030000
         dvi:           pci\cc_0300
         dvi:      Processing a single INF: 'C:\Windows\INF\oem5.inf'
         inf:      Opened PNF: 'C:\Windows\System32\DriverStore\FileRepository\nvdm.inf_6c11bcb0\nvdm.inf' ([strings] <src=drvstore>)
         dvi: {Build Driver List - exit(0x00000000)} 07:38:10.774
         dvi: Selected driver installs from section [nv_G8x] in 'c:\windows\system32\driverstore\filerepository\nvdm.inf_6c11bcb0\nvdm.inf'.
         dvi: Class GUID of device remains: {4d36e968-e325-11ce-bfc1-08002be10318}.
         dvi: Set selected driver complete.
         dvi: {DIF_FINISHINSTALL_ACTION} 07:38:10.774
         dvi:      Using exported function 'DisplayClassInstaller' in module 'C:\Windows\system32\DispCI.dll'.
         dvi:      Class installer == DispCI.dll,DisplayClassInstaller
         dvi:      Using exported function 'NVCoInstaller' in module 'C:\Windows\system32\nvcod100.dll'.
         dvi:      CoInstaller 1 == nvcod100.dll,NVCoInstaller
         dvi:      CoInstaller 1: Enter 07:38:10.774
         dvi:      CoInstaller 1: Exit
         dvi:      Class installer: Enter 07:38:10.790
         dvi:      Class installer: Exit
         dvi:      Default installer: Enter 07:38:10.790
    !!!  dvi:      Default installer: failed!
    !!!  dvi:      Error 2: The system cannot find the file specified.
         dvi: {DIF_FINISHINSTALL_ACTION - exit(0x00000002)} 07:38:10.790
    <<<  Section end 2008/09/30 07:38:10.790
    <<<  [Exit status: FAILURE(0x00000002)]

     

    Does anybody know how I can further investigate this problem or even fix it?

     

    I already uninstalled the driver and installed again - no success.

     

    Thank you!

    Christian

    Tuesday, September 30, 2008 5:50 AM

Answers

  • Hi Christian,

     

    I suggest you did a system restore to an early backup point, then download and install the latest NVIDIA Driver from Dell official website:

     

    http://support.us.dell.com/support/downloads/download.aspx?c=us&cs=19&l=en&s=dhs&releaseid=R194005&formatcnt=1&libid=0&fileid=267722

     

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    In addition, I found a resolved similar thread for you:

     

    Solution found: "Could not find the file specified" while installing drivers

    http://forums.techguy.org/windows-vista/723863-solution-found-could-not-find.html

     

    Hope it helps.

     

    Wednesday, October 1, 2008 7:02 AM
    Moderator

All replies

  • Hi Christian,

     

    I suggest you did a system restore to an early backup point, then download and install the latest NVIDIA Driver from Dell official website:

     

    http://support.us.dell.com/support/downloads/download.aspx?c=us&cs=19&l=en&s=dhs&releaseid=R194005&formatcnt=1&libid=0&fileid=267722

     

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    In addition, I found a resolved similar thread for you:

     

    Solution found: "Could not find the file specified" while installing drivers

    http://forums.techguy.org/windows-vista/723863-solution-found-could-not-find.html

     

    Hope it helps.

     

    Wednesday, October 1, 2008 7:02 AM
    Moderator
  • hey man, i had the same problem, but what i did is, i went to nVidia's drivers website, i reinstalled the latest version, and i restarted the pc...i have the same graphic card as yours, mine is 1GB dedicated.

    hope i helped.
    Thursday, October 2, 2008 10:08 AM