locked
Exchange 2010 coexist with 2016 Outlook profile issue RRS feed

  • Question

  • Hi all,

    I am encountering an issue in the Outlook profile for Exchange 2010 user with the Exchange 2010 & 2016 coexist setup.

    I opened a Premium Support Case for 1 week but still not fix. that's why I open this post for consulting here.

    thanks for your support in advance.

    Background:

    Activesync, OWA, mail traffic work as expected. However, there is 1 issue in Outlook profile setup for Exchange 2010 users. Existing Outlook profile is working fine for Exchange 2010 users. they just cannot create new profile. Exchange 2016 users don't have any Outlook issue.

    when using an Exchange 2010 user account to access the autodiscover link it shows below. Exchange 2016 user can access fine:

    the current setup:

    We deployed an Exchange 2016 CU11 to co-exist with current Exchange 2010 RU21 server.

    2 2016 mailbox servers. form a DAG group. behind a F5 Hardware NLB

    1 2010 frontend CAS server + 1 2010 mailbox server.

    DNS record:

    Name & Data:

    webmail.xxx.com  A            Exchange2016 F5 VirtualIP

    cas2010               A            Exchange2010 CAS IP

    autodiscover         CNAME    webmail.xxx.com

    Virtual directory setup:

    Get-OwaVirtualDirectory

    Server         ExternalUrl                             InternalUrl
    ------         -----------                             -----------
    2010           https://webmail.xxx.com/owa https://webmail.xxx.com/owa
    2016-1        https://webmail.xxx.com/owa https://webmail.xxx.com/owa
    2016-2        https://webmail.xxx.com/owa https://webmail.xxx.com/owa

    Get-EcpVirtualDirectory

    Server         ExternalUrl                             InternalUrl
    ------         -----------                             -----------
    2010           https://webmail.xxx.com/ecp https://2010.xxx.local/ecp
    2016-1        https://webmail.xxx.com/ecp https://webmail.xxx.com/ecp
    2016-2        https://webmail.xxx.com/ecp https://webmail.xxx.com/ecp

    Get-WebServicesVirtualDirectory

    Server         ExternalUrl                                           InternalUrl
    ------         -----------                                           -----------
    2010       https://webmail.xxx.com/ews/exchange.asmx https://webmail.xxx.com/ews/exchange.asmx
    2016-1                                                       https://webmail.xxx.com/ews/exchange.asmx
    2016-2                                                       https://webmail.xxx.com/ews/exchange.asmx

    Get-OabVirtualDirectory

    Server         ExternalUrl                             InternalUrl
    ------         -----------                             -----------
    2010            https://webmail.xxx.com/oab https://webmail.xxx.com/oab
    2016-1         https://webmail.xxx.com/oab https://webmail.xxx.com/oab
    2016-2         https://webmail.xxx.com/oab https://webmail.xxx.com/oab

    Get-MapiVirtualDirectory

    Server         ExternalUrl                              InternalUrl
    ------         -----------                              -----------
    2016-1        https://webmail.xxx.com/mapi https://webmail.xxx.com/mapi
    2016-2        https://webmail.xxx.com/mapi https://webmail.xxx.com/mapi

    Get-OutlookAnywhere

    Server         ExternalHostname            InternalHostname
    ------         ----------------                 ----------------
    2010          webmail.xxx.com
    2016-1       webmail.xxx.com          webmail.xxx.com
    2016-2       webmail.xxx.com          webmail.xxx.com

    Wednesday, September 11, 2019 7:43 AM

Answers

  • Just finished the migration. At the end it is confirmed there is problem that autodiscover app pool wont auto refresh sometimes. 

    there is a workaround provided:

    Reduce cache expiry time for the Autodiscover application pool on the Exchange 2013 or Exchange 2016 servers. To do this, add the following entry to the Autodiscover web.config file. The default location is “C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\autodiscover”

    <add key="HttpProxy.AnchorMailboxCache.InMemoryOnly.AbsoluteTimeout" value="20" />

    hope it helps someone in the future. 

    • Marked as answer by Freddy Lao Friday, October 25, 2019 9:24 AM
    Friday, October 25, 2019 9:24 AM

All replies

  • Hi

    First thing i would do is upgrade your Exchange 2016 and 2010 servers. Many fixes have been included in the latest ones. ensure you also install the security update for Exchange 2016 after you upgrade.

    Next, i see you using 1 namespace, did you point your F5 to Exchange 2016 as the frontend as Exchange 2016 will then redirect to exchange 2010 if the mailbox is there, this is including DNS?

    If you login to the OWA 2016 page with a 2010 mailbox it should take you to the 2010 owa page.


    Hope this helps. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, September 11, 2019 5:11 PM
  • thanks for the suggestions. however the Exchange 2016 version is limited by the support of the 3rd party apps.

    yes, we only use 1 single DNS entry which is the webmail.xxx.com and the IP is pointing to the F5 Virtual IP. Exchange 2016 servers are behind it.

    in fact, we just discovered that the real issue was about a very genius setting in the IIS which was done by the genius who configured the Exchange 2010 many years ago(clearly it was not me ) besides, the genius also configured all the Exchange service URL to something not exist in the DNS when I plan for the coexist setup. 

    I really hope people should get to know clearly how to do the right things or what they are doing before they really did take the actions. So that not leaving trouble for someone to pick up later on.

    I don't know what's the point to redirect the autodiscover to OWA url ....... or was that the recommend setting date back to Exchange 2010 time?

    after removing that the autodiscover redirection setting for Exchange 2010 user works as expect. 

    now it comes to another issue.

    I tired to do the migration. once i started the migration batch, the Exchange 2010 user Outlook will disconnect. it can't even connect back after the migration finish with a restart of the Outlook. however, the activesync client can send/receive emails during and after migration.

    anyone knows which part may be wrong?


    Thursday, September 12, 2019 3:26 AM
  • Hi,

    What about referring to this discussion case: Known issue - Outlook stays disconnected after migrating mailbox from Exchange 2010 to Exchange 2013 SP1

    And this kb: Outlook logon fails after mailbox moves from Exchange 2010 to Exchange 2013 or Exchange 2016

    To resolve this issue, restart the Autodiscover Application Pool on the Exchange Server 2013 or Exchange Server 2016 servers.

    Restart-WebAppPool MSExchangeAutodiscoverAppPool

    Regards,

    Joyce Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, September 12, 2019 6:46 AM
  • Thanks for the suggestion. 

    I tried to do a manual autodiscover app pool recycle on both the Exchange 2016 servers and it seems to work.

    what about if i am doing the migration for a batch of mailboxes? let say a batch of 10 mailboxes. Do I need to recycle it 10 times as they are not migrating at the same time. at least there must be some delay between them.

    Moreover, I am in Exchange 2016 CU11, which is released a way long after the kb article released. Why MS is not fixing this issue or they think a manual recycle to the App pool is the solution? what if i have 10000+ mailboxes to be migrated? 

    So silly.

    Friday, September 13, 2019 3:42 AM
  • Hi,

    In general, we just need to wait for several minutes after migration. It's not required to manually restart app pool every time. In addition, the migration for the same batch of mailbox finishes almost at the same time.

    Regards,

    Joyce Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, September 16, 2019 8:59 AM
  • Hi,

    Do you have any further issue on this topic?

    Meanwhile, if there is no issue, please remember to mark helpful reply as answer to close the thread. Your action would be helpful to other users who encounter the same issue and read this thread.
    Thanks for your understanding.

    Regards,

    Joyce Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, September 19, 2019 5:34 AM
  • Just finished the migration. At the end it is confirmed there is problem that autodiscover app pool wont auto refresh sometimes. 

    there is a workaround provided:

    Reduce cache expiry time for the Autodiscover application pool on the Exchange 2013 or Exchange 2016 servers. To do this, add the following entry to the Autodiscover web.config file. The default location is “C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\autodiscover”

    <add key="HttpProxy.AnchorMailboxCache.InMemoryOnly.AbsoluteTimeout" value="20" />

    hope it helps someone in the future. 

    • Marked as answer by Freddy Lao Friday, October 25, 2019 9:24 AM
    Friday, October 25, 2019 9:24 AM